Repository 32bit  Forum
Repository 64bit  Wiki

Ipw2200 e monitor mode

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Ipw2200 e monitor mode

Messaggioda Numbifer » dom gen 08, 2006 2:26

Ciao a tutti,
sono giorni che sto spulciando la documentazione relativa al wireless intel Pro 2200BG.
Quello che volevo fare era abilitare la modalità "monitor" del wifi del mio portatile per testare la vulnerabilità della mia rete.
Ho installato il kernel 2.6.15, ho scaricato dal sito di sourceforge, i driver e i firmware aggiornati, ho installato il wireless tools v. 27 ma niente da fare.
Al comando
Codice: Seleziona tutto
#iwconfig eth1 mode monitor

il prompt mi risponde con un laconico
Codice: Seleziona tutto
"Error for wireless request "Set Mode" (8B06) :
    SET failed on device eth1 ; Invalid argument."

Eppure la documentazione dice che è possibile abilitare la modalità monitor.

Non so più dove sbattere la testa...
Qualcuno può darmi qualche indicazione?

Grazie a tutti

Alb
Numbifer
Linux 2.0
Linux 2.0
 
Messaggi: 141
Iscritto il: gio ago 19, 2004 23:00
Località: Altroquando

Messaggioda Numbifer » dom gen 08, 2006 15:03

Tra l'altro, continuando a spulciare mi sono accorto di un'altra cosa.
I wireless-tools che ho installati sono alla versione 27 che supporta le "wireless extension" dalla v11 alla v17; le mie wireless extension sono alle v19.
Credo, quindi, ci siano anche problemi di corretta compatibilità... ho provato a cercare la versione superiore delle tools ma si trova sempre e solo la v27, anche swaret individua solo quella...
Possibile che debba fare un downgrade delle wextension e portarle alla versione v17?

Grazie a tutti e buona domenica

Alb
Numbifer
Linux 2.0
Linux 2.0
 
Messaggi: 141
Iscritto il: gio ago 19, 2004 23:00
Località: Altroquando

Messaggioda the_asker2006 » sab gen 14, 2006 12:20

ciao, senti non lo so se può esserti utile .............. ma sul sito http://www.remote-exploit.org c'è una versione live-CD che si chiama Auditor e c'è la versione specifica per far funzionare il centrino ipw2200. lo so che non è slackware ma magari può servirti come spunto si partenza. Magari se riesci a capire come hanno fatto mi faresti sapere, mi piacerebbe molto capire ma non sono ancora molto esperto. ciao e grazie.
the_asker2006
Linux 1.0
Linux 1.0
 
Messaggi: 1
Iscritto il: sab gen 14, 2006 12:16

Messaggioda Numbifer » dom gen 15, 2006 1:06

Ciao,
allora, prova e riprova ho trovato a questo link ho trovato la versione v28 delle wireless tools. E' ancora in beta ma supporta le wirelesse extension dalla v11 alla v19. La version 19 supporta perfettamente il monitor mode ed infatti...
dopo aver upgradato le wtools il comando "iwconfig eth1 mode monitor" funziona... 8)

Ora non mi resta che studiarmi bene come funzionano i vari kismet et similia...
Spero di essere stato utile ad altri con il mio stesso problema...

Ciao a tutti

Alb
Numbifer
Linux 2.0
Linux 2.0
 
Messaggi: 141
Iscritto il: gio ago 19, 2004 23:00
Località: Altroquando

Messaggioda Bart » mar feb 27, 2007 12:45

Stesso errore stesso problema. Io monto una slackware 11 e le wireless-tools sono alla versione 28 ma rimane il problema:
Codice: Seleziona tutto
iwconfig eth1 mode monitor
Error for wireless request "Set Mode" (8B06) :
SET failed on device eth1 ; Invalid argument.
Idee?
Bart
Staff
Staff
 
Messaggi: 4248
Iscritto il: dom ago 08, 2004 23:00
Località: Rimini

Messaggioda Bart » mar feb 27, 2007 14:06

Risolto abilitando il supporto al monitor mode nel kernel.
Bart
Staff
Staff
 
Messaggi: 4248
Iscritto il: dom ago 08, 2004 23:00
Località: Rimini


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron