Repository 32bit  Forum
Repository 64bit  Wiki

Patchare il kernel per l'IrDA: come scegliere la patch?

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Patchare il kernel per l'IrDA: come scegliere la patch?

Messaggioda pablomrg » mar gen 17, 2006 21:23

Ciao a tutti,
sto tentando di far funzionare l'IrDA sul mio portatile, seguendo l'how-to di Tuxmobil (http://tuxmobil.org/Infrared-HOWTO/infrared-howto-s-kernel.html).

Leggo che consiglia il kernel 2.6, ma io per vari motivi ho grosse resistenze ad effettuare l'upgrade dall'attuale 2.4.26. In alternativa c'è scritto che ci sono delle patches, ma io non sono riuscito a capire quali installare, qualcuno sa aiutarmi?

Tipo frugando in http://irda.sourceforge.net/ftp/patches/2.4.x/, dovrei installare le patch-2.4.1-pre8-irda1? E' proprio la prima volta che patcho un kernel, quindi abbiate pazienza se non ho posto la questione in modo corretto o ho fatto una domanda triviale...

In ultimo, devo ricompilare tutto il kernel o solo i moduli?

Grazie
pablomrg
Linux 1.0
Linux 1.0
 
Messaggi: 57
Iscritto il: lun giu 27, 2005 23:00
Località: Risaie dell'alto pavese, tra nebbie e zanzare...

Messaggioda pablomrg » mar gen 17, 2006 21:32

Sorry, ad una domanda rispondo da solo: devo ricompilare il kernel!

Per compensare ne aggiungo un'altra: analizzando il config vedo che il mio kernel (2.4.26) ha già abilitato tutto quello che rigurda l'IrDA, devo per forza ricompilarlo con le paches?
pablomrg
Linux 1.0
Linux 1.0
 
Messaggi: 57
Iscritto il: lun giu 27, 2005 23:00
Località: Risaie dell'alto pavese, tra nebbie e zanzare...

Messaggioda kobaiachi » mar gen 17, 2006 22:33

penso di si che comunque tu lo debba ricompilare con le patch in quanto slackware come standard adotta appunto il kernel standard senza l'aggiunta di patch .

aspetta comunque la risposta di qualcuno piu competente di me in materia.
ciao
kobaiachi
Linux 3.x
Linux 3.x
 
Messaggi: 1368
Iscritto il: mer lug 13, 2005 23:00
Località: roma

Messaggioda pablomrg » mer gen 18, 2006 7:58

Nel frattempo ho fatto qualche prova, ho caricato il modulo con
Codice: Seleziona tutto
modprobe irda irtty

connesso il dispositivo con
Codice: Seleziona tutto
irattach /dev/ttyS3 -s

e dato un'occhiata a cosa succedeva con
Codice: Seleziona tutto
irdadump

ed in effetti si vedevano un po' di comunicazioni tra il mio pc ed il pocketpc che gli ho messo di fronte...
pablomrg
Linux 1.0
Linux 1.0
 
Messaggi: 57
Iscritto il: lun giu 27, 2005 23:00
Località: Risaie dell'alto pavese, tra nebbie e zanzare...


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti