Repository 32bit  Forum
Repository 64bit  Wiki

toshiba e nvidia: problema risoluzione

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

toshiba e nvidia: problema risoluzione

Messaggioda beato_angelico256 » sab mar 18, 2006 14:47

ho installato la slackware sul notebook toshiba di un mio amico, che ha una nvidia: ho provveduto a mettere i driver ufficiali e l'accelerazione va senza problemi, ma non riesco a fargli prendere la risoluzione "1280x800" ( widescreen ) : ho provato a modificare lo xorg in quella sezione dove c'è
" default depth 24
24:
varie modalità video
"
sulla mia ati ho fatto così, ma la nvidia prende le risoluzio0ni da qualche altra perchè quelle che gli ho specificato manualmente nn le prende proprio ... chi mi sa mettere sulla giusta strada ?
beato_angelico256
Linux 2.6
Linux 2.6
 
Messaggi: 578
Iscritto il: dom mag 01, 2005 23:00

Messaggioda clodo » sab mar 18, 2006 15:12

Il problema è già stato trattato, bisogna impedire al driver di leggere le frequenze del monitor sul bus edid:

Option "IgnoreEDID" "boolean" # true or false;

Disable probing of EDID (Extended Display Identification Data) from your monitor. Requested modes are compared against values gotten from your monitor EDID (if any) during mode validation. Some monitors are known to lie about their own capabilities. Ignoring the values that the monitor gives may help get a certain mode validated. On the other hand, this may be dangerous if you do not know what you are doing. Default: false (use EDID).

inoltre bisogna mettere mano a /etc/modules.conf ( su debian /etc/modules):

The "Mobile" kernel option can be set to any of the following values:
Value Meaning
0xFFFFFFFF let the kernel module autodetect the correct value
1 Dell laptops
2 non-Compal Toshiba laptops
3 all other laptops
4 Compal Toshiba laptops
5 Gateway laptops

Again, the "Mobile" kernel option is only needed if SoftEDIDs is disabled; when it is used, it is usually safest to let the kernel module autodetect the correct value (this is the default behavior).

Should you need to alter either of these options, you may do so in any of the following ways:

editing os-registry.c in the usr/src/nv/ directory of the .run file.

setting the value on the modprobe command line (e.g.: modprobe nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=3)


adding an "options" line to your module configuration file, usually /etc/modules.conf (e.g.: options nvidia NVreg_Mobile=5)

Tutto questo fatto con copy&paste dal README del sito nvidia.
clodo
Linux 2.6
Linux 2.6
 
Messaggi: 511
Iscritto il: dom gen 23, 2005 0:00
Distribuzione: debian

Messaggioda beato_angelico256 » dom mar 19, 2006 14:17

"IgnoreEDID" lo avevo provato ( il readme dei driver l'ho letto, non sono così pigro :-) ),ma le risoluzioni continua a non prenderle dallo xorg, perchè mi dava disponibili risoluzioni diverse da quella (solo 1280x800) che avevo impostato per il depht di default (24)...

la parte seguente (quella dell'opzione "mobile" del kernel) non l'ho capita proprio ...ho cercato nel config del kernel tale opzione ma proprio nn la trovo (probabilmente sto dicendo un'eresia, chiedo scusa in anticipo :lol: )
qualcuno che ha risolto lo stesso problema potrebbe darmi istruzioni in termini "agresti" ? :lol:

PS: se l'argomento è stato già discusso chiedo scusa , ma ho usato anche il tasto cerca e nn ho trovato niente a riguardo
beato_angelico256
Linux 2.6
Linux 2.6
 
Messaggi: 578
Iscritto il: dom mag 01, 2005 23:00

Messaggioda beato_angelico256 » lun mar 20, 2006 19:48

UP :cry:
beato_angelico256
Linux 2.6
Linux 2.6
 
Messaggi: 578
Iscritto il: dom mag 01, 2005 23:00

Messaggioda clodo » mar mar 21, 2006 22:07

Non è difficile, in /etc/rc.d/rc.modules :
/sbin/modprobe nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=3 # metti il numero che ti serve

Oppure in /etc/modules.conf:
options nvidia NVreg_Mobile=5 # metti il numero che ti serve
clodo
Linux 2.6
Linux 2.6
 
Messaggi: 511
Iscritto il: dom gen 23, 2005 0:00
Distribuzione: debian

Messaggioda beato_angelico256 » sab mar 25, 2006 11:24

ho provato con tutte le 5 modalità ma niente ... :cry:
beato_angelico256
Linux 2.6
Linux 2.6
 
Messaggi: 578
Iscritto il: dom mag 01, 2005 23:00

Messaggioda l1q1d » sab mar 25, 2006 16:16

prova a vedere cosa succede se dai:
Codice: Seleziona tutto
xrandr -s 1280x800
Avatar utente
l1q1d
Master
Master
 
Messaggi: 1862
Iscritto il: lun feb 21, 2005 0:00
Località: In uno spazio n-dimesionale

Messaggioda clodo » dom mar 26, 2006 20:20

Scusa ancora, ma a me è successo:
kde/gnome hanno un menu che ti consente di modificare la risoluzione video: l'hai controllato? Io al tempo no, non mi prendeva il 1280x800 e quando l'ho scoperto non ti dico le madonne...vista la banalità del problema.
clodo
Linux 2.6
Linux 2.6
 
Messaggi: 511
Iscritto il: dom gen 23, 2005 0:00
Distribuzione: debian

Messaggioda beato_angelico256 » lun mar 27, 2006 14:00

sisi... ho controllato nel pannello delle risoluzioni ..
beato_angelico256
Linux 2.6
Linux 2.6
 
Messaggi: 578
Iscritto il: dom mag 01, 2005 23:00

Messaggioda prometeo79 » lun mar 27, 2006 14:58

Hai inserito nella modline

Codice: Seleziona tutto
Modeline "1024x800" 80 1024 1024 1256 1344 800 800 803 825


Riduce il refrash da 60 a 58 e permette la visualizzazione 1024x800.
A me funziona
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda prometeo79 » lun mar 27, 2006 15:14

Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite