Repository 32bit  Forum
Repository 64bit  Wiki

Kernel panic hd sata

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Kernel panic hd sata

Messaggioda gisax » lun apr 10, 2006 18:40

Salve ho installato sul mio portatile la slackware 10.2...ma ho rilevato un problema..
All'installazione (sapendo di avere un disco sata)faccio partire dal boot sata.i, faccio le partizioni installo slack ed al reboot faccio partire linux....
ecco il problema è come se nn mi riconoscesse la partizione linux in /dev/sda2...
dicendo Kernel panic....
Ho risolto momentaneamente mettendo al boot
sata.i root=/dev/sda2 noi.... ro
xò è come se fossi in modalità sola lettura
come posso risolvere senza mettere ogni volta il dvd di slackware? grazie tante,Alessandro
gisax
Linux 1.0
Linux 1.0
 
Messaggi: 9
Iscritto il: lun gen 05, 2004 0:00

Messaggioda alessiodf » lun apr 10, 2006 20:33

posta
Codice: Seleziona tutto
fdisk -l

poi sei sicuro di aver configurato bene slack durante l'installazione??? ti consiglio di seguire questo how-to se non hai troppa dimenstichezza... :wink:
http://www.leanux.it/index.php?mod=06_L ... _Slackware
Avatar utente
alessiodf
Linux 2.6
Linux 2.6
 
Messaggi: 823
Iscritto il: ven ott 14, 2005 20:04
Località: Roma
Slackware: current
Kernel: 2.6.26.4
Desktop: Kde 4.1

Messaggioda Paoletta » mar apr 11, 2006 8:05

forse dovrai ricompilare il kernel aggiungendo il driver per il tuo controller scsi...
Avatar utente
Paoletta
Staff
Staff
 
Messaggi: 3907
Iscritto il: dom apr 24, 2005 23:00
Località: Varese
Slackware: 13.1
Desktop: fluxbox

Messaggioda Luci0 » mar apr 11, 2006 23:20

Penso che hai sbagliato qualcosa nello scegliere il kernel giusto in fase di installazione e probabilmente é rimasto il kernel bare.i
In questo caso ti conviene copiare alla bruta il kernel "sata.i" dal CD #1 nella dir di boot, e riconfigurare il lilo e aggiungere una voce in più nel menu e reinstallare il boot manager ... un lavoro di 2 minuti al massimo... se serve qualche dritta in più fai un fischio ... :)
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Risolto

Messaggioda gisax » mer apr 12, 2006 19:00

Grazie a tutti, molto competenti..in effetti quello che sbagliavo era proprio in fase di chiusura dell'installazione....
Nelle precedenti installazioni (non avendo un device sata) davo l'installazione del kernel in automatico (bare.i)...quindi in questo caso ho saltato l'installazione del kernel, dal dvd, sata.i. che gaff...
comunque vi ringranzio infinitamente..comunque la guida che mi è stata proposta mi è servita ;-), da li ho potuto notare il mio errore...

Spero che il mio d errore possa servire ad altri a nn commeterlo..!!
Grazie,saluti Alessandro
gisax
Linux 1.0
Linux 1.0
 
Messaggi: 9
Iscritto il: lun gen 05, 2004 0:00


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti