Repository 32bit  Forum
Repository 64bit  Wiki

Problema Wireless Intel PRO/Wireless 2200BG

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema Wireless Intel PRO/Wireless 2200BG

Messaggioda paolito » lun giu 05, 2006 0:18

Ciao a tutti,
e' da giorni che sto cercando di risolvere un problema con la connessione wireless sul mio notebook Asus A6B00U, su cui e' montata una scheda di rete Intel Corporation PRO/Wireless 2200BG (rev 05). La distro e' slackware 10-2 con kernel 2.6.13.

Leggendo sul forum ho trovato info su come installare il driver ed il firmware necessario per far funzionare la mia scheda. Ho inoltre caricato i seguenti moduli del kernel:

ipw2200
ieee80211
ieee80211_crypt


L'installazione e' andata benissimo, non ho nessun errore se guardo il dmesg ed eventualmente il file /var/log/messages. L'interfaccia assegnata per la mia scheda di rete wireless e' eth1.

Riesco addirittura a fare uno scan degli access point con iwlist eth1 scan (qui ce ne sono parecchi) e trovare quello della mia rete.

Il problema nasce quando voglio collegarmi al mio access point:

iwconfig eth1 essid TLabel
iwconfig eth1 key restricted xxxxxxxxxxxxxxxxxxxxxxx
ifconfig eth1 up
dhcpcd eth1


Non riesco a farmi assegnare un indirizzo IP dal DHCP (ho provato a collegarmi con il cavo di rete sull'interfaccia eth0 e l'indirizzo mi viene assegnato) dell'access point ed anche se su /etc/rc.d/rc.inet1.conf configuro la eth1 con indirizzo ip statico e access point come gateway, non riesco a collegarmi ugualmente.

Stesso discorso per le 3 o 4 connessioni wireless non protette della zona.
Basterebbe mettere l'ESSID per connettersi, ma non riesco.
Ci tengo a precisare che di fianco al mio laptop ho un pc con winxp che riesce a collegarsi all' access point.

Sono disperato non so piu' che cosa guardare per far funzionare la wireless. Chi puo' darmi un aiuto?
Grazie in anticipo.
paolito
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: lun giu 05, 2006 0:11

Messaggioda tgmx » lun giu 05, 2006 8:38

Anche io ho quella scheda e la uso normalmente.

Per prima cosa prova a togliere il WEP dall'access-point e riprovare a collegarti, se tutto funziona allora è lo stesso problema che avevo avuto io.

Il mio access point ha due modalità di protezione wep:
    Open System
    Shared Key

Se uso la prima, devo dare:
Codice: Seleziona tutto
iwconfig eth1 key XXXXXXXXXXXXXXXXXXXx open

se uso la seconda:
Codice: Seleziona tutto
iwconfig eth1 key XXXXXXXXXXXXXXXXXXXx restricted


Non so bene cosa cambi tra le due modalità ma così funziona.

Inoltre ho visto che digitando la chiave in questo modo deve essere in formato esadecimale, cioè non vuole parole tipo "ciao" ma vuole delle stringhe di lunghezza fissa di caratteri 123456789abcdef (26 caratteri se usi wep a 128 bit, 10 se usi 64 bit).
Avatar utente
tgmx
Linux 3.x
Linux 3.x
 
Messaggi: 1330
Iscritto il: ven apr 28, 2006 13:40
Località: Ancona
Slackware: 13.37
Desktop: KDE 4

Messaggioda Bart » lun giu 05, 2006 11:46

Per il wep o il wpa devi usare wpa_supplicant. Trovi una guida anche su questo sito.
Bart
Staff
Staff
 
Messaggi: 4248
Iscritto il: dom ago 08, 2004 23:00
Località: Rimini

Messaggioda paolito » lun giu 05, 2006 20:20

Vi ringrazio per la risposta.
Ho seguito i vostri consigli ma purtroppo continuo ad avere problemi.

Provando con
Codice: Seleziona tutto
iwconfig eth1 key XXXXXXXXXXXXXXXXXXXx open

e
Codice: Seleziona tutto
iwconfig eth1 key XXXXXXXXXXXXXXXXXXXx restricted


mi trovo questo risultato:
Codice: Seleziona tutto
eth1      unassociated  ESSID:"TLabel"  Nickname:"hydra"
          Mode:Managed  Channel=0  Access Point: 00:00:00:00:00:00
          Bit Rate=0 kb/s   Tx-Power=20 dBm
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xx   Security mode:open
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:24   Missed beacon:0


Ma non riesco ad ottenere un indirizzo IP su eth1. Il problema sembra che non riesca a trovare il mac address dell'AP.

Ho provato ad installare wpa_supplicant seguendo il tutorial di Alessio Grillo scaricato da slacky.

Una volta installato e configurato seguendo le istruzioni, eseguo il codice suggerito dalla guida:
Codice: Seleziona tutto
wpa_supplicant -d -c /etc/wpa_supplicant.conf  -ieth1

Ma ricevo questo messaggio:

Codice: Seleziona tutto
Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'default' ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
Line 1: Invalid configuration line 'ctrl_interface=/var/run/wpa_supplicant'.
Line 2: Invalid configuration line 'ctrl_interface_group=wheel'.
Line 8: invalid key_mgmt '*'
Line 8: no key_mgmt values configured.
Line 8: failed to parse key_mgmt '*'.
Line 12: failed to parse network block.
Failed to read read or parse configuration '/etc/wpa_supplicant.conf'.
Failed to add interface eth1
Cancelling scan request


Commento allora le prime due linee che mi danno il problema e rilancio nuovamente lo script, ma ricevo questo errore:

Codice: Seleziona tutto
Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'default' ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
Priority group 0
   id=0 ssid='TLabel'
Initializing interface (2) 'eth1'
wpa_driver_ipw_init is called
SIOCGIWRANGE: WE(compiled)=18 WE(source)=18 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
Own MAC address: 00:15:00:1d:f7:88
wpa_driver_ipw_set_wpa: enabled=1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_countermeasures: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_drop_unencrypted: enabled=1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Setting scan request: 0 sec 100000 usec
Added interface eth1
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Scan timeout - try to get results
Received 1569 bytes of scan results (6 BSSes)
Scan results: 6
Selecting BSS from priority group 0
0: 00:90:4c:7e:00:10 ssid='<hidden>' wpa_ie_len=26 rsn_ie_len=0 caps=0x11
   skip - SSID mismatch
1: 00:14:7c:b8:d0:e8 ssid='RH' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
   skip - SSID mismatch
2: 00:14:a4:77:01:1f ssid='WANADOO-6FA8' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
   skip - SSID mismatch
3: 00:11:50:61:a2:39 ssid='TLabel' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
4: 00:0f:3d:b9:c5:f8 ssid='G604T_WIRELESS' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
5: 00:11:50:a0:df:cc ssid='Belkin54g' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec
CTRL-EVENT-TERMINATING - signal 2 received
Removing interface eth1
State: SCANNING -> DISCONNECTED
No keys have been configured - skip key clearing
wpa_driver_ipw_set_wpa: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_drop_unencrypted: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_countermeasures: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
No keys have been configured - skip key clearing
Cancelling scan request


La chiave del router è WEP 128bit, come dicevo precedentemente non ho problemi a collegarmi da altri pc (winxp) in rete.

Ho anche provato ad installare wlassistant, mi trova 4 o 5 reti ma non riesco a collegarmi.

Avete altri suggerimenti?
Grazie.
paolito
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: lun giu 05, 2006 0:11

Messaggioda tgmx » lun giu 05, 2006 20:49

se quando dai iwconfig hai tutti zeri significa che non sei collegato alla rete wireless quindi non può assegnarti l'ip.

hai provato a disabilitare completamente la protezione wep nell'access-point e collegarti di nuovo?
Avatar utente
tgmx
Linux 3.x
Linux 3.x
 
Messaggi: 1330
Iscritto il: ven apr 28, 2006 13:40
Località: Ancona
Slackware: 13.37
Desktop: KDE 4

Messaggioda paolito » lun giu 05, 2006 21:37

Ho provato ora..... anche togliendo il WEP non riesco a collegarmi :(
Ho anche provato a connettermi con il tool wlassistant su kde ma mi rifiuta la connessione in ogni caso.......
paolito
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: lun giu 05, 2006 0:11

Messaggioda gnubit » mar giu 06, 2006 7:30

Per rifilare a iwconfig la chiave in formato stringa io uso (con successo)
iwconfig wlan0 key s:stringa_chiave_wep

Obbligatoriamente 13 char per la 128bit.

La scheda l'ho gia usata sotto slack su un A6 (quello con AMD), ma senza DHCP onestamente, andava senza problemi.
Avatar utente
gnubit
Linux 2.6
Linux 2.6
 
Messaggi: 751
Iscritto il: dom apr 16, 2006 23:16
Località: Verona

Messaggioda tgmx » mar giu 06, 2006 9:33

magari forniscici l'output di iwlist così vediamo di che rete si tratta.

Hai controllato che l'AP non abbia un filtro sul mac-address e permetta l'accesso solo a determinati dispositivi bloccando gli altri?


Dopo questo mi arrendo :wink:
Avatar utente
tgmx
Linux 3.x
Linux 3.x
 
Messaggi: 1330
Iscritto il: ven apr 28, 2006 13:40
Località: Ancona
Slackware: 13.37
Desktop: KDE 4

Messaggioda paolito » mar giu 06, 2006 16:17

Questo e' il risultato che ottengo con un iwlist eth1 scan

Codice: Seleziona tutto
Cell 02 - Address: 00:11:50:61:A2:39
                    ESSID:"TLabel"
                    Protocol:IEEE 802.11bg
                    Mode:Master
                    Channel:13
                    Encryption key:on
                    Bit Rate:1 Mb/s
                    Bit Rate:2 Mb/s
                    Bit Rate:5.5 Mb/s
                    Bit Rate:6 Mb/s
                    Bit Rate:9 Mb/s
                    Bit Rate:11 Mb/s
                    Bit Rate:12 Mb/s
                    Bit Rate:18 Mb/s
                    Bit Rate:24 Mb/s
                    Bit Rate:36 Mb/s
                    Bit Rate:48 Mb/s
                    Bit Rate:54 Mb/s
                    Quality=93/100  Signal level=-34 dBm
                    Extra: Last beacon: 4ms ago
                    Extra: Channel flags: INVALID


Sull' AP non ci sono filtri su indirizzi IP o mac address..........
*disperato*
paolito
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: lun giu 05, 2006 0:11

Messaggioda tgmx » mar giu 06, 2006 16:27

Sembra che vada tutto bene.

Io come ultima cosa proverei a cambiare il canale sull'AP (ad es 7) e settarlo a mano con iwconfig:

Codice: Seleziona tutto
iwconfig eth1 channel 7


Se anche così non va non so proprio cosa dire. Comunuque tutte le prove ti consiglio di farle sempre senza wep attivo in modo da eliminare una probabilità di errore.
Avatar utente
tgmx
Linux 3.x
Linux 3.x
 
Messaggi: 1330
Iscritto il: ven apr 28, 2006 13:40
Località: Ancona
Slackware: 13.37
Desktop: KDE 4

Messaggioda paolito » mer giu 07, 2006 0:16

Ho risolto!!
Tgmx, il tuo ultimo post è stato illuminante. Sono andato sul router ed ho impostato il channel su "Auto".

Poi ho digitato:

Codice: Seleziona tutto
/sbin/iwconfig eth1 essid TLabel
/sbin/iwconfig eth1 key xxxxxxxxxxxxxxxxxxxxxxxxxxx
/sbin/ifconfig eth1 up
/sbin/dhcpcd eth1


E come per magia mi sono connesso.
Grazie mille per il supporto!
paolito
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: lun giu 05, 2006 0:11


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite