Problema ipw2200

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
kernel_panic
Linux 1.0
Linux 1.0
Messaggi: 1
Iscritto il: dom giu 18, 2006 17:27
Contatta:

Problema ipw2200

Messaggioda kernel_panic » dom giu 18, 2006 17:35

Ciao a tutti, ho una slackware 10.2 su un acer travelmate 4020.

Ho aggiornato il kernel alla versione 2.6.16 inserendo il supporto per la mia scheda wireless

anche dopo aver installato il firmware, il sistema non mi riconosce la periferica.

ho quindi reinstallato i moduli ieee80211 e ipw2200 scaricando i sorgenti ma quando cerco di caricarli mi appare questo errore:

WARNING: Error inserting ieee80211_crypt (/lib/modules/2.6.16.1/net/ieee80211/ieee80211_crypt.ko): Invalid module format
WARNING: Error inserting ieee80211 (/lib/modules/2.6.16.1/net/ieee80211/ieee80211.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting ipw2200 (/lib/modules/2.6.16.1/kernel/drivers/net/wireless/ipw2200.ko): Unknown symbol in module, or unknown parameter (see dmesg)


e questo DMesg

ieee80211_crypt: exports duplicate symbol ieee80211_crypt_deinit_entries (owned by kernel)
ieee80211: disagrees about version of symbol ieee80211_get_crypto_ops
ieee80211: Unknown symbol ieee80211_get_crypto_ops
ieee80211: disagrees about version of symbol ieee80211_crypt_deinit_entries
ieee80211: Unknown symbol ieee80211_crypt_deinit_entries
ieee80211: disagrees about version of symbol ieee80211_crypt_delayed_deinit
ieee80211: Unknown symbol ieee80211_crypt_delayed_deinit
ieee80211: disagrees about version of symbol ieee80211_crypt_quiescing
ieee80211: Unknown symbol ieee80211_crypt_quiescing
ipw2200: disagrees about version of symbol ieee80211_wx_get_encodeext
ipw2200: Unknown symbol ieee80211_wx_get_encodeext
ipw2200: disagrees about version of symbol ieee80211_wx_set_encode
ipw2200: Unknown symbol ieee80211_wx_set_encode
ipw2200: disagrees about version of symbol ieee80211_wx_get_encode
ipw2200: Unknown symbol ieee80211_wx_get_encode
ipw2200: disagrees about version of symbol ieee80211_txb_free
ipw2200: Unknown symbol ieee80211_txb_free
ipw2200: disagrees about version of symbol ieee80211_wx_set_encodeext
ipw2200: Unknown symbol ieee80211_wx_set_encodeext
ipw2200: disagrees about version of symbol ieee80211_wx_get_scan
ipw2200: Unknown symbol ieee80211_wx_get_scan
ipw2200: disagrees about version of symbol ieee80211_rx
ipw2200: Unknown symbol ieee80211_rx
ipw2200: disagrees about version of symbol ieee80211_rx_mgt
ipw2200: Unknown symbol ieee80211_rx_mgt
ipw2200: disagrees about version of symbol free_ieee80211
ipw2200: Unknown symbol free_ieee80211
ipw2200: disagrees about version of symbol alloc_ieee80211
ipw2200: Unknown symbol alloc_ieee80211


come posso fare? vi ringrazio in anticipo!

ciao!

Avatar utente
l1q1d
Master
Master
Messaggi: 1862
Iscritto il: lun feb 21, 2005 0:00
Località: In uno spazio n-dimesionale
Contatta:

Messaggioda l1q1d » dom giu 18, 2006 19:44

se hai ricompilato dai sorgenti in teoria questi errori te li dovrebbe dare in compilazione, mq hai compilato la sezione net/wireless nel kernel?

Avatar utente
gnubit
Linux 2.6
Linux 2.6
Messaggi: 751
Iscritto il: lun apr 17, 2006 0:16
Località: Verona
Contatta:

Messaggioda gnubit » lun giu 19, 2006 8:54

Non è che hai sbagliato il firmware?

Se non erro ce ne è più d'uno e sempre se non ricordo male io la prima volta avevo fatto questo ragionamento, scarico l'ultimo che sicuramente va meglio, invece mi pare che a seconda del kernel ci sia un firmware apposito.

Mi pare che in dmesg generasse un errore segnalando la versione del firmware necessaria.

Avatar utente
gallows
Staff
Staff
Messaggi: 3466
Iscritto il: lun set 20, 2004 0:00
Kernel: FreeBSD 8.0-RELEASE-p3
Desktop: ratpoison
Località: Palermo
Contatta:

Messaggioda gallows » sab giu 24, 2006 18:36

Ti consiglio di usare l'ultima versione di linux (2.6.17.x).
Se vuoi consigli sulla configurazione dai un'occhiata qui

Avatar utente
gnubit
Linux 2.6
Linux 2.6
Messaggi: 751
Iscritto il: lun apr 17, 2006 0:16
Località: Verona
Contatta:

Messaggioda gnubit » sab giu 24, 2006 21:58

Con la serie 2.6.16 mi pare serva il 2.4 di firmware.

Avatar utente
prometeo79
Linux 3.x
Linux 3.x
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Slackware: 12
Località: Torino

Messaggioda prometeo79 » lun giu 26, 2006 9:37

Credo che il problema sia il firmware. Le versioni fino alla 2.4 hanno dei problemi di likaggio. La versione 3.0 a me funziona egregiamente, prova con questa.

Avatar utente
simgidacav
Linux 1.0
Linux 1.0
Messaggi: 3
Iscritto il: ven mag 26, 2006 10:31

Messaggioda simgidacav » lun giu 26, 2006 22:39

Banalmente, togli il firmware e usa modprobe per caricare il modulo. Poi guarda dmesg e vedrai di quale versione specifica hai bisogno. In effetti dovrebbe essere la 2.4.


Torna a “Laptop”

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti