Repository 32bit  Forum
Repository 64bit  Wiki

intel 945gm e accelerazione grafica

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

intel 945gm e accelerazione grafica

Messaggioda aLe46 » dom lug 09, 2006 11:10

Qualcuno è riuscito a far funzionare l'accelerazione con la scheda in oggetto ?

Con il kernel 2.6.17.4 ora funziona anche l'agp,

root@darkstar:~# dmesg | grep agp
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected an Intel 945GM Chipset.
agpgart: Detected 7932K stolen memory.
agpgart: AGP aperture is 256M @ 0xc0000000

però quando in xorg (6.9-4 di pat) i810 o i915 al posto di vesa non parte X e mi da il classico no screens found ...

root@darkstar:~# lsmod
Module Size Used by
i915 18176 0
drm 66452 1 i915
ipv6 242272 12
ipw3945 200864 1
ieee80211 46120 1 ipw3945
ieee80211_crypt 5056 1 ieee80211
snd_seq_dummy 2884 0
snd_seq_oss 32832 0
snd_seq_midi_event 6016 1 snd_seq_oss
snd_seq 51216 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 6796 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 39904 0
snd_mixer_oss 17408 1 snd_pcm_oss
intel_agp 20700 1
snd_hda_intel 15764 0
snd_hda_codec 144240 1 snd_hda_intel
snd_pcm 81348 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer 21060 2 snd_seq,snd_pcm
snd 47332 9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
snd_page_alloc 8392 2 snd_hda_intel,snd_pcm
uhci_hcd 21580 0
ipt_LOG 6464 3
xt_pkttype 1728 2
xt_tcpudp 3392 4
ehci_hcd 31240 0
xt_state 1920 1
usbcore 119744 3 uhci_hcd,ehci_hcd
hw_random 5016 0
i2c_i801 8076 0
ohci1394 32688 0
ieee1394 92472 1 ohci1394
iptable_filter 2368 1
ip_tables 12508 1 iptable_filter
x_tables 11396 5 ipt_LOG,xt_pkttype,xt_tcpudp,xt_state,ip_tables
nls_iso8859_15 4544 1
nls_cp437 5632 1
vfat 10624 1
fat 48092 1 vfat
nls_iso8859_1 3968 1
ntfs 228180 1
agpgart 30048 2 drm,intel_agp
psmouse 39496 0
unix 23376 223

Un aiutino? ho provato con gli snapshots dri ma si freeza ... http://dri.freedesktop.org/snapshots/

volevo provare con xorg 7... qualcuno sa dove posso scaricarlo ?


grazie
Avatar utente
aLe46
Linux 2.4
Linux 2.4
 
Messaggi: 257
Iscritto il: gio feb 10, 2005 0:00

Messaggioda lamarozzo » mer lug 12, 2006 9:12

guarda per un po' c'ho provato anch'io a farlo funzionare ma mi si presenta lo stesso problema. Anch'io proverei con xorg 7.0.

Qui qualcuno c'è riuscito:

http://www.slacky.it/forum/viewtopic.ph ... light=i810

Se riesci fammi sapere.
Avatar utente
lamarozzo
Linux 2.6
Linux 2.6
 
Messaggi: 732
Iscritto il: mer lug 13, 2005 23:00
Località: Roma
Desktop: xfce
Distribuzione: archlinux


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti