Repository 32bit  Forum
Repository 64bit  Wiki

Problemi con ethernet e dhcp

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problemi con ethernet e dhcp

Messaggioda assorec » sab ott 28, 2006 14:24

Salve il problema è il seguente: linux non riesce a prendere l'indirizzo via dhcp mentre windows si collega tranquillamente.
Ho provato a impostare l'indirzzo che mi da sotto windows con ifconfig

ifconfig eth0 xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx

route add default gw xxx.xxx.xxx.xxx
qui mi da errore perche non trova la rete

qualcuno sa qualche cosa

Ciao
assorec
Linux 1.0
Linux 1.0
 
Messaggi: 9
Iscritto il: dom mag 16, 2004 23:00

Messaggioda albatrosla » sab ott 28, 2006 14:39

Intanto controlla se dopo l'ifconfig ha messo in piedi l'interfaccia di rete (basta dare ifconfig senza opzioni). Puoi provare a far fare tutto in automatico alla slack modificando il file /etc/rc.d/rc.inet1.conf eppoi lanciando lo script /etc/rc.d/rc.inet1
Nel file di configurazione devi impostare come attivo il dhcp sulla tua interfaccia e specificare l'indirizzo del gateway.
albatrosla
Packager
Packager
 
Messaggi: 1294
Iscritto il: sab mar 27, 2004 0:00
Località: Bressa - Friuli / Torino
Slackware: current
Desktop: fluxbox.git

Messaggioda assorec » sab ott 28, 2006 14:53

questo lo faccio, la configurazione è tutta ok.
Al boot la lancia la richiesta per avere l'indirizzo perchè fa il dhcp request col il mac address solo che non riceve nessuna risposta
assorec
Linux 1.0
Linux 1.0
 
Messaggi: 9
Iscritto il: dom mag 16, 2004 23:00

Messaggioda lennynero » sab ott 28, 2006 18:03

io dopo aver messo su la eth1 eseguo "dhcpcd eth1" e prendo tranqueillamente l'ip, prova così poi magari automatizzi la cosa se hai appurato che funziona il dhcp client...
Avatar utente
lennynero
Linux 2.6
Linux 2.6
 
Messaggi: 566
Iscritto il: dom mag 02, 2004 23:00
Località: Salerno
Slackware: 14.1-x64
Kernel: 3.10.17
Desktop: xfce-4.10


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti