Repository 32bit  Forum
Repository 64bit  Wiki

ipw3945

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

ipw3945

Messaggioda nic » gio dic 07, 2006 21:39

Ciao a tutti.Allora ragazzi mi sembra di essere riuscito a installare tutti i pacchetti per la scheda wireless del mio portatile la ipw3945.Ho ricompilato il kernel 2.6.17,dopo aver installato il sottosistema ieee80211.Quindi al comando lsmod vedo.

Codice: Seleziona tutto
 ieee80211              29960  1 ipw3945
ieee80211_crypt         5056  1 ieee80211
firmware_class          7936  1 ipw3945


e se entro nei sorgenti di ipw3945 e do il comando ./load il demone parte:

Codice: Seleziona tutto
Unloaded: ipw3945 ieee80211 ieee80211_crypt
Loaded: ieee80211 ipw3945
Loading ipw3945d.ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.22
Intel PRO/Wireless 3945ABG Network Connection found at:
 /sys/bus/pci/drivers/ipw3945/0000:02:00.0
Daemon launched as pid 4038.  Exiting.
..done.


Quindi è una cosa normale,che al comando iwconfig ottenga questo risultato:

Codice: Seleziona tutto
lo        no wireless extensions.

eth0      no wireless extensions.


Grazie a tutti
Avatar utente
nic
Linux 2.0
Linux 2.0
 
Messaggi: 195
Iscritto il: dom mag 08, 2005 23:00
Località: Malalbergo

Messaggioda LaZyBoY » gio dic 07, 2006 22:27

a me la stessa scheda viene vista come eth1..
di piu nn saprei dirti. sorry :(
LaZyBoY
Linux 2.0
Linux 2.0
 
Messaggi: 153
Iscritto il: mar mar 14, 2006 21:43

Messaggioda nic » ven dic 08, 2006 1:41

LaZyBoY ha scritto:a me la stessa scheda viene vista come eth1..
di piu nn saprei dirti. sorry :(


Ma hai fatto altri settaggi o modifiche,dopo l'installazione dei vari pacchetti?
Grazie e ciao
Avatar utente
nic
Linux 2.0
Linux 2.0
 
Messaggi: 195
Iscritto il: dom mag 08, 2005 23:00
Località: Malalbergo

Messaggioda tgmx » ven dic 08, 2006 11:17

Posso solo dirti che ho una ipw2200 e funziona molto bene. Credo che la procedura di istallazione sia la stessa che vale per te tranne per il nome dei driver quindi dai un'occhiata a questa discussione, magari può esserti utile:

http://www.slacky.it/forum/viewtopic.php?t=16204
Avatar utente
tgmx
Linux 3.x
Linux 3.x
 
Messaggi: 1330
Iscritto il: ven apr 28, 2006 13:40
Località: Ancona
Slackware: 13.37
Desktop: KDE 4

Messaggioda Zapata » ven dic 08, 2006 12:32

Come sai ho la tua stessa skeda wireless nel tuo stesso laptop. A me succede che la skeda di rete viene vista solo se c'è il segnale radio. Mi spiego: se sono in un ambiente con un segnale wireless allora facendo iwconfig mi appare la skeda con eth1. Altrimenti non mi da nulla. Fai questa prova.
Zapata
Linux 1.0
Linux 1.0
 
Messaggi: 22
Iscritto il: dom nov 14, 2004 0:00

Messaggioda LaZyBoY » ven dic 08, 2006 12:33

Boh, a me pare che i passaggi eseguiti siano giusti.
Non ho settato niente di particolare.
La guida che ho seguito io è quella relativa al mio portatile, ma immagino che le procedure siano identiche per tutte le schede.
Se vuoi darci un'occhiata:
http://www.slacky.it/wikislack/index.ph ... s_ipw3945d
LaZyBoY
Linux 2.0
Linux 2.0
 
Messaggi: 153
Iscritto il: mar mar 14, 2006 21:43

Re: ipw3945

Messaggioda aLe46 » ven dic 08, 2006 13:01

nic ha scritto:Ciao a tutti.Allora ragazzi mi sembra di essere riuscito a installare tutti i pacchetti per la scheda wireless del mio portatile la ipw3945.Ho ricompilato il kernel 2.6.17,dopo aver installato il sottosistema ieee80211.Quindi al comando lsmod vedo.

Codice: Seleziona tutto
 ieee80211              29960  1 ipw3945
ieee80211_crypt         5056  1 ieee80211
firmware_class          7936  1 ipw3945


e se entro nei sorgenti di ipw3945 e do il comando ./load il demone parte:

Codice: Seleziona tutto
Unloaded: ipw3945 ieee80211 ieee80211_crypt
Loaded: ieee80211 ipw3945
Loading ipw3945d.ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.22
Intel PRO/Wireless 3945ABG Network Connection found at:
 /sys/bus/pci/drivers/ipw3945/0000:02:00.0
Daemon launched as pid 4038.  Exiting.
..done.


Quindi è una cosa normale,che al comando iwconfig ottenga questo risultato:

Codice: Seleziona tutto
lo        no wireless extensions.

eth0      no wireless extensions.


Grazie a tutti



man iwconfig

setta il SSID mon ami

Salùt
Avatar utente
aLe46
Linux 2.4
Linux 2.4
 
Messaggi: 257
Iscritto il: gio feb 10, 2005 0:00

Re: ipw3945

Messaggioda nic » ven dic 08, 2006 14:35

Codice: Seleziona tutto


man iwconfig

setta il SSID mon ami

Salùt


Ho guardato il man di iwconfig però non ho capito il comando che devo dare ti riferisci per caso a questo:

Codice: Seleziona tutto
PARAMETERS
       essid  Set the ESSID (or Network Name - in some products it may also be called Domain ID). The ESSID is used to identify cells which are  part  of
              the same virtual network.
              As  opposed to the AP Address or NWID which define a single cell, the ESSID defines a group of cells connected via repeaters or infrastruc-
              ture, where the user may roam transparently.
              With some cards, you may disable the ESSID checking (ESSID promiscuous) with off or any (and on to reenable it).
              If the ESSID of your network is one of the special keywords (off, on or any), you should use -- to escape it.
              Examples :
                   iwconfig eth0 essid any
                   iwconfig eth0 essid "My Network"
                   iwconfig eth0 essid -- "ANY"


Ciao e grazie
Avatar utente
nic
Linux 2.0
Linux 2.0
 
Messaggi: 195
Iscritto il: dom mag 08, 2005 23:00
Località: Malalbergo

Messaggioda LaZyBoY » ven dic 08, 2006 14:47

si, credo si riferisse a quello.
io per connettermi do:
Codice: Seleziona tutto
iwconfig eth1 essid NOME_ESSID

e poi:
Codice: Seleziona tutto
dhcpcd eth1
LaZyBoY
Linux 2.0
Linux 2.0
 
Messaggi: 153
Iscritto il: mar mar 14, 2006 21:43

Messaggioda nic » ven dic 08, 2006 15:43

LaZyBoY ha scritto:si, credo si riferisse a quello.
io per connettermi do:
Codice: Seleziona tutto
iwconfig eth1 essid NOME_ESSID

e poi:
Codice: Seleziona tutto
dhcpcd eth1


L primo comando ottengo questo messaggio di errore:
Codice: Seleziona tutto
Cannot read /proc/net/wireless
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device eth1 ; Invalid argument.

:(
Ciao
Avatar utente
nic
Linux 2.0
Linux 2.0
 
Messaggi: 195
Iscritto il: dom mag 08, 2005 23:00
Località: Malalbergo

Messaggioda checcozorzi » sab dic 09, 2006 21:31

io ho la stessa scheda e mi funziona.
Ho messo ieee80211 versione 1.2.15 e ipw3945 versione 1.1.0

Tu che versioni hai messo?
Avatar utente
checcozorzi
Linux 2.0
Linux 2.0
 
Messaggi: 138
Iscritto il: mer mag 03, 2006 11:50
Località: Mestre (VE)
Nome Cognome: Francesco Zorzi
Slackware: 13.0
Kernel: 2.6.29.6-smp
Desktop: KDE-4.2.4

Messaggioda nic » dom dic 10, 2006 11:00

checcozorzi ha scritto:io ho la stessa scheda e mi funziona.
Ho messo ieee80211 versione 1.2.15 e ipw3945 versione 1.1.0

Tu che versioni hai messo?


ieee80211-1.2.15
ipw3945-1.1.2
Avatar utente
nic
Linux 2.0
Linux 2.0
 
Messaggi: 195
Iscritto il: dom mag 08, 2005 23:00
Località: Malalbergo

Messaggioda targzeta » lun dic 11, 2006 22:28

Io ho un Dell 6400 Inspiron. Anche io ho seguito la guida suggerita in un post più su.
comunque, ho scoperto delle cose fichissime!!
Innanzitutto puoi semplicemente pacthare il kernel attuale in modo da creare il modulo solo abilitandolo da make menuconfig.
Ho scoperto anche che lo sviluppatore del driver è attivissimo. Gli ho scritto
tempo fa e mi ha risposto immediatamente. Non solo, ma ha già messo on-line la versione 1.1.3 modificata per il kerner 2.6.19.
Allora, a me funziona benissimo, tanto è che sono connesso con la wireless! Ma ovviamenta a te tutto questo non interessa. Ieri sera ho giusto ricompilato creato il modulo come ti descrivo:
- Scarica la version 1.1.3 da questo sito
http://ipw3945.sourceforge.net/
- NON scaricare la versione ieee802.11, quella del kernel a me va bene e compila senza warning (al contrario di quella nuova). In effetti lo sviluppatore del driver l'ha testato con la versione 1.1.14, quella del kernel 2.6.19 è la 1.1.13, ma a me va bene uguale.
- Decomprimi il file ipw3945-1.1.3.tgz che hai scaricato.
- Entra nella directory è scrivi:
Codice: Seleziona tutto
make patch_kernel

guarda che forse ti suggerisce di lanciare prima
Codice: Seleziona tutto
make add_radiotap
, lancia
Codice: Seleziona tutto
make add_radiotap && make patch_kernel

- Finito, vai nei sorgenti del kernel e abilita quanto segue (magari con make menuconfig):
Codice: Seleziona tutto
Networking  --->  Generic IEEE 802.11 Networking Stack
abilita tutto, vedi che ti ha aggiunto
Codice: Seleziona tutto
Enable RAIODTAP headers for capibilities that can support it

Ancora:
Codice: Seleziona tutto
Device Drivers --> Network device support --> Wireless LAN (non-hamradio) --> Intel PRO/Wireless 3945ABG Network Connection

ti è stata aggiunta con la procedura di patch, seleziona tutto, è fichissimo, puoi settare l'opzione per la modalità promiscua :).
- Lancia
Codice: Seleziona tutto
make modules_install


Ovviamente dovresti aver pulito tutto quello che hai fatto.
Poi installati il demone (ipw3945d) dove ti pare a te, e il firmware
(ipw3945.ucode) nella directory:
Codice: Seleziona tutto
/lib/firmware/


A me basta questo per farla partire! Possibile che tu non hai fatto
Codice: Seleziona tutto
ifconfig eth0 up
?
C'è da dire che a me va anche compilando tutto come hai fatto tu.
Se il led lampeggia, fai un
Codice: Seleziona tutto
iwlist eth0 scan
e vedi se rileva
qualche access point.

Fammi sapere
Spina
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6194
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Messaggioda targzeta » lun dic 11, 2006 22:29

P.S. iwconfig essid "nome-rete" serve solo se vuoi collegarti ad un access point, non per impostare l'interfaccia.
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6194
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Messaggioda nic » mer dic 13, 2006 19:55

spina ha scritto:Io ho un Dell 6400 Inspiron. Anche io ho seguito la guida suggerita in un post più su.
comunque, ho scoperto delle cose fichissime!!
Innanzitutto puoi semplicemente pacthare il kernel attuale in modo da creare il modulo solo abilitandolo da make menuconfig.
Ho scoperto anche che lo sviluppatore del driver è attivissimo. Gli ho scritto
tempo fa e mi ha risposto immediatamente. Non solo, ma ha già messo on-line la versione 1.1.3 modificata per il kerner 2.6.19.
Allora, a me funziona benissimo, tanto è che sono connesso con la wireless! Ma ovviamenta a te tutto questo non interessa. Ieri sera ho giusto ricompilato creato il modulo come ti descrivo:
- Scarica la version 1.1.3 da questo sito
http://ipw3945.sourceforge.net/
- NON scaricare la versione ieee802.11, quella del kernel a me va bene e compila senza warning (al contrario di quella nuova). In effetti lo sviluppatore del driver l'ha testato con la versione 1.1.14, quella del kernel 2.6.19 è la 1.1.13, ma a me va bene uguale.
- Decomprimi il file ipw3945-1.1.3.tgz che hai scaricato.
- Entra nella directory è scrivi:
Codice: Seleziona tutto
make patch_kernel

guarda che forse ti suggerisce di lanciare prima
Codice: Seleziona tutto
make add_radiotap
, lancia
Codice: Seleziona tutto
make add_radiotap && make patch_kernel

- Finito, vai nei sorgenti del kernel e abilita quanto segue (magari con make menuconfig):
Codice: Seleziona tutto
Networking  --->  Generic IEEE 802.11 Networking Stack
abilita tutto, vedi che ti ha aggiunto
Codice: Seleziona tutto
Enable RAIODTAP headers for capibilities that can support it

Ancora:
Codice: Seleziona tutto
Device Drivers --> Network device support --> Wireless LAN (non-hamradio) --> Intel PRO/Wireless 3945ABG Network Connection

ti è stata aggiunta con la procedura di patch, seleziona tutto, è fichissimo, puoi settare l'opzione per la modalità promiscua :).
- Lancia
Codice: Seleziona tutto
make modules_install


Ovviamente dovresti aver pulito tutto quello che hai fatto.
Poi installati il demone (ipw3945d) dove ti pare a te, e il firmware
(ipw3945.ucode) nella directory:
Codice: Seleziona tutto
/lib/firmware/


A me basta questo per farla partire! Possibile che tu non hai fatto
Codice: Seleziona tutto
ifconfig eth0 up
?
C'è da dire che a me va anche compilando tutto come hai fatto tu.
Se il led lampeggia, fai un
Codice: Seleziona tutto
iwlist eth0 scan
e vedi se rileva
qualche access point.

Fammi sapere
Spina


Fatto tutto come mi hai detto tu.Sono riuscito a patchare il 2.6.19,è l'ho ricompilato pari pari da nuovo.Ho messo il firmware in /lib/firmware e il demone in /sbin
All'avvio non vedo il led della scheda accendersi.Il comando che hai inserito tu a me non va bene visto che la rete ethernet è già attiva.Se provo con iwconfig ottengo:
Codice: Seleziona tutto
lo        no wireless extensions.

eth0      no wireless extensions.


come nei tentativi precedenti
:cry:
Non è che forse non ripulito bene il sistema?Tu come faresti per cancellare le installazioni precedenti?Che sia anche che il demone e il firmware non siano quelli riferiti al ipw3945-1.1.3 di cui parlavi tu?
Grazie e ciao
Avatar utente
nic
Linux 2.0
Linux 2.0
 
Messaggi: 195
Iscritto il: dom mag 08, 2005 23:00
Località: Malalbergo

Prossimo

Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti