Repository 32bit  Forum
Repository 64bit  Wiki

Kernel Dell Inspiron 9400

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Kernel Dell Inspiron 9400

Messaggioda sardylan » gio apr 26, 2007 23:14

Salve a tutti...
Come ho già scritto su un altro topic, il mio problema è compilare il kernel. Quello originale del CD non va... Fa riferimento ad un errore su hda7, quando io ho soltanto 4 partizioni che vanno da hda1 ad hda4... Allora ho pensato di caricare il 2.6, ma niente... Appaiono i due pinguini in alto, carica per un po', e poi il "kernel panic"... :? :? :? :?
Altre volte mi dice che il kernel non è di tipo eseguibile... Qualcuno può aiutarmi??? Gliene sarei molto grato...
Ciao a tutti di nuovo!!! :D
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Messaggioda michele.p » ven apr 27, 2007 0:17

....ho visto che il tuo PC ha un serial ATA; durante l'installazione hai indicato il kernel sata.i?...

Ad ogni modo prova a dare un'occhiata a questa guida;

http://thebigmachine.org/debian-on-inspiron-9400.html

Quando ti da kernelpanic, cosa c'è scritto di preciso?

Bye
Avatar utente
michele.p
Packager
Packager
 
Messaggi: 1275
Iscritto il: ven nov 24, 2006 16:52
Località: Pontecorvo(FR)
Nome Cognome: Michele Petrecca
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE
Distribuzione: ..Fedora e Mandriva

Messaggioda sardylan » ven apr 27, 2007 15:00

Queste sono le ultime 7 righe dell'output:
Codice: Seleziona tutto
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem)
/boot/initrd.gz: Loading kernel modules from initrd image:
Using /lib/modules/2.6.17.13/reiserfs.ko
VFS: Cannot open root device "<NULL>" or onknown block (3,4)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs or onknown block(3,4)

Questo è l'output... Se c'è qualche errore è perché l'ho ricopiato prima su carta.

Il fatto per cui sono passato al 2.6 è perché con il kernel copiato dal DVD dava errori relativi all'accesso ad una partizione hda7 (ero in ext3) che non esiste. Allora, visto che dovevo ricompilare il kernel, ho pensato di passare direttamente al 2.6 perché lo conosco di più e lo uso tutti i giorno con Ubuntu.

Per compilarlo, sono partito da un .config che ho trovato relativo ad un Dell Inspiron 6400, ed ho controllato che fossero attive tutte le caratteristiche spiegate nelle numerose guide (SMP, Pentium M, etc...). Dopo la compilazione ho creato l'initrd.gz per caricarmi i moduli relativi al reiserfs, ho aggiunto la voce su grub e dopo "kernel panic"...

Le partizioni sono le seguenti:
hda1 Windows NTFS
hda2 Ubuntu Reiserfs
hda4 Slackware Reiserfs
hda3 Swap
La partizione hda4 è stata ricavata ridimensionando la vecchia hda2.

Posto i link al .config relativo all'ultima compilazione ed il contenuto del menu.lst di GRUB:

http://www.lucacireddu.it/archive/files/config.txt
Codice: Seleziona tutto
default      0
timeout      10
color cyan/blue white/blue

title      Slackware, kernel 2.6.17.13
root      (hd0,3)
kernel      /boot/vmlinuz vga=791
initrd      /boot/initrd.gz
savedefault
boot

title      Ubuntu, kernel 2.6.15-28-686 SMP
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.15-28-686 root=/dev/sda2 ro quiet splash vga=791
initrd      /boot/initrd.img-2.6.15-28-686
savedefault
boot

title      Ubuntu, kernel 2.6.15-26-386
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.15-26-386 root=/dev/sda2 ro quiet splash vga=791
initrd      /boot/initrd.img-2.6.15-26-386
savedefault
boot

title      Ubuntu, kernel 2.6.15-28-686 SMP (recovery mode)
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.15-28-686 root=/dev/sda2 ro single
initrd      /boot/initrd.img-2.6.15-28-686
boot

title      Ubuntu, kernel 2.6.15-26-386 (recovery mode)
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.15-26-386 root=/dev/sda2 ro single
initrd      /boot/initrd.img-2.6.15-26-386
boot

title      Ubuntu, memtest86+
root      (hd0,1)
kernel      /boot/memtest86+.bin
boot

title      Other operating systems:
root

title      Microsoft Windows XP Professional
root      (hd0,0)
savedefault
makeactive
chainloader   +1
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Leggere l'output è importante !!!!!!!

Messaggioda sardylan » ven apr 27, 2007 15:37

:lol: :lol: :lol: :lol: :lol: :lol:

Ragazzi ho imparato una cosa nuova:
Leggere l'output è importante

E si... Perché avrò compilato e ricompilato il kernel almeno una ventina di volte senza ottenere risultati, ed invece bastava aggiungere un root=/dev/sda4 per risolvere il tutto...
E si... Proprio così... Se usate il file di config per grub che ho postato prima sostituite la parte relativa a Slackware con questa
Codice: Seleziona tutto
title      Slackware, kernel 2.6.17.13
root      (hd0,3)
kernel      /boot/vmlinuz root=/dev/sda4 vga=791
initrd      /boot/initrd.gz
savedefault
boot

naturalmente sostiutendo i dati della vostra situazione relativa alle partizioni...
Comunque non appena ho sotto mano una connessione che vada un po' meglio rispetto alla 56k ;) ;) ;) ;) carico nel mio sito il kernel già compilato...
Grazie tante a michele.p... E complimenti per il sito... Davvero una grande fonte per pacchetti e consigli...
Ciao!!!!
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Messaggioda michele.p » ven apr 27, 2007 15:41

...nel file .config che hai indicato nel link alla voce ReiserFS (alias il filesystem da te utilizzato con la Slackware), leggo;

CONFIG_REISERFS_FS=m

Allora delle due o hai sbagliato a fare l'initial ram disk (initrd.gz) oppure l'initrd non l'hai fatto e allora DEVI far si che il modulo per ReiserFS non sia caricabile a run time, ma faccia parte dell'immagine statica del kernel. Altrimenti detto; nella configurazione del kernel NON devi lasciare (o mettere) m bensì y (o il segno di spunta nella configurazione grafica con make xconfig...ma NON devi mettere il punto). Io ti suggerisco di integrare direttamente il modulo nell'immagine del kernel...a meno che hai esigenze particolari per avere l'initrd.

..facci sapere...

Bye
Avatar utente
michele.p
Packager
Packager
 
Messaggi: 1275
Iscritto il: ven nov 24, 2006 16:52
Località: Pontecorvo(FR)
Nome Cognome: Michele Petrecca
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE
Distribuzione: ..Fedora e Mandriva

Messaggioda sardylan » ven apr 27, 2007 15:47

Ok... Visto che ora ho risolto il problema, provo ad inserire il reiserfs come built-in, se ho ben capito...
Anche se mi ricordo che nelle guide parlava di lasciarlo come modulo ed utilizzare l'initrd per caricarlo.
Comunque appena ho un po' di tempo ricompilo il tutto e vi faccio sapere...
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Messaggioda targzeta » ven apr 27, 2007 16:43

sardylan ha scritto:...Anche se mi ricordo che nelle guide parlava di lasciarlo come modulo ed utilizzare l'initrd per caricarlo...

Questa non e' la prima volta che la sento. Qualcuno mi sa spiegare bene perche' non si dovrebbe mettere il reiserfs come built-in se il root filesystem e' proprio un reiser?

Spina
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Messaggioda sardylan » ven apr 27, 2007 19:20

Avevi ragione spina...
Ho ricompilato il kernel attivando come built-in tutte le voci relative al reiserfs tranne la debug, ed è tutto a posto... Non c'è stato bisogno neanche di caricare l'initrd...

Ecco la parte relativa al file system:
Codice: Seleziona tutto
CONFIG_REISERFS_FS=y
# CONFIG_REISERFS_CHECK is not set
CONFIG_REISERFS_PROC_INFO=y
CONFIG_REISERFS_FS_XATTR=y
# CONFIG_REISERFS_FS_POSIX_ACL is not set
# CONFIG_REISERFS_FS_SECURITY is not set
CONFIG_JFS_FS=m
CONFIG_JFS_POSIX_ACL=y
# CONFIG_JFS_SECURITY is not set
# CONFIG_JFS_DEBUG is not set
# CONFIG_JFS_STATISTICS is not set


Nel config di Grub ho commentato la riga relativa all'initrd

Funziona a meraviglia...
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Di nuovo kernel (questa volta 2.6.21.5)

Messaggioda sardylan » gio ago 23, 2007 14:47

Sempre qui, di nuovo problemi con il kernel... Sempre il solito Dell Inspiron 9400, ma questa volta con la Slackware 12.
Il problema, se così si può definire :? :? , è che ho problemi con la compilazione del kernel.
Tra i 4 che installa la slackware funzionano solo la huge (single CPU) e la huge-smp (dual core), però entrambi non supportano la frequenza variabile della CPU, che viene vista costantemente al massimo (più o meno 1800 MHz).
Ogni volta che compilo mi si presenta il solito errore relativo al parametro root da passare al kernel all'avvio, ma questa volta il parametro c'è... Comunque posto il file lilo.conf
Codice: Seleziona tutto
boot = /dev/sda
#message = /boot/boot_message.txt
prompt
timeout = 50
change-rules
reset
vga = 791

image = /boot/vmlinuz-original
root = /dev/sda1
label = Original
read-only

image = /boot/vmlinuz-rebuild
root = /dev/sda1
label = Rebuild
read-only
.
vmlinuz-original ed vmlinuz-rebuild sono due link simbolici. Il primo punta a vmlinuz-huge-smp-2.6.21.5-smp, l'altro punta al kernel ricompilato.

Un'altro motivo per il quale ho deciso di ricompilare il kernel è che il sistema non supporta il DMA per il lettore/masterizzatore (e penso quindi che non lo supporti neanche per l'hard disk), il che è un problema per masterizzare DVD, ma anche per leggerli (velocità massima di scrittura di un DVD intorno al 0,6x).

Per iniziare ho copiato il file config-huge-smp-2.6.21.5-smp nella directory dei sorgenti del kernel, ho controllato tutte le opzioni ed erano già a posto... Ho controllato la guida del wiki relativa all'Inspiron 6400, ed era tutto OK... Ho dovuto soltanto correggere l'archittetura da Pentium Pro e Pentium M.

Nonostante tutto, qualsiasi kernel mi dava problemi. Ho ripreso anche il config postato da me nei precedenti posts, ma niente... :? :? :?
Ma il bello è che utilizzando INALTERATO il config-huge-smp-2.6.21.5-smp (che dovrebbe dar vita ad un kernel praticamente identico), ottengo comunque un kernel panic...
Non so proprio come fare... Qualcuno di voi ha qualche consiglio??? Vi ringrazio in anticipo...
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Messaggioda submax82 » gio ago 23, 2007 15:45

spina ha scritto:
sardylan ha scritto:...Anche se mi ricordo che nelle guide parlava di lasciarlo come modulo ed utilizzare l'initrd per caricarlo...

Questa non e' la prima volta che la sento. Qualcuno mi sa spiegare bene perche' non si dovrebbe mettere il reiserfs come built-in se il root filesystem e' proprio un reiser?

Spina


perchè è un'alternativa poi uno fà come vuole
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Messaggioda sardylan » gio ago 23, 2007 20:02

Ho provato ad utilizzare il config di cui ho parlato nei precedenti post, ed a prepararlo con make oldconfig... Morale della favola... Il kernel funziona con il parametro root=/dev/hda1... Ma anche utilizzando hda1 invece che sda1, le cose vanno male... E tutto molto più lento... Impossibile da utilizzare anche solo con la shell... Come posso risolverla??? Grazie a tutti in anticipo...
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Messaggioda sardylan » sab ago 25, 2007 14:57

Ho risolto molte cose senza dover ricompilare il kernel, utilizzando l'originale hugesmp... Faccio un riepilogo delle principali:

1. Problemi di velocità per HDD e DVD/Masterizzatore:
Passare al kernel "libata.atapi_enabled=1 combined_mode=libata pci=routeirq ide0=noprobe ide1=noprobe". Ecco come risulta la sezione relativa a Slackware 12 su lilo.conf:
Codice: Seleziona tutto
image = /boot/vmlinuz-huge-smp-2.6.21.5-smp
root = /dev/sda2
label = Slackware
append = "libata.atapi_enabled=1 combined_mode=libata pci=routeirq ide0=noprobe ide1=noprobe"
read-only


2. Frequenza variabile del processore:
Decommentate le seguenti righe in rc.modules
Codice: Seleziona tutto
/sbin/modprobe acpi-cpufreq
/sbin/modprobe cpufreq_powersave
/sbin/modprobe cpufreq_performance
/sbin/modprobe cpufreq_ondemand

ed aggiungete queste altre
Codice: Seleziona tutto
/sbin/modprobe thermal
/sbin/modprobe battery
/sbin/modprobe button
/sbin/modprobe fan
/sbin/modprobe processor
/sbin/modprobe ac
/sbin/modprobe dock

in modo da poter riconoscere le varie funzioni per la carica della batteria, la temperatura, etc...
Installate il pacchetto cpufrequtils ed inserite in rc.local queste righe:
Codice: Seleziona tutto
echo -n "Setting CPU policy:  /usr/bin/cpufreq-set -g ondemand... "
/usr/bin/cpufreq-set -c 0 -g ondemand
/usr/bin/cpufreq-set -c 1 -g ondemand
echo "done!"


Il gioco è fatto... Dovrebbe essere tutto a posto per il momento...
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron