Repository 32bit  Forum
Repository 64bit  Wiki

scheda video via unichrome pro

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

scheda video via unichrome pro

Messaggioda sya54M » mer giu 06, 2007 13:59

salve a tutti.
non so se riuscite ad aiutarmi in quanto il mio problema è abbastanza complicato.
ho la suddetta scheda video sul portatile, ho correttamente configurato xorg (usa il driver via e carica dri con i giusti permessi), il kernel carica i giusti moduli (via.ko e agp-amd64.ko), ma digitando "glxinfo | grep direct" mi dice "direct rendering: No" ed infatti non funziona l'accelerazione 3d.
la cosa più strana è che ho visto che avviando zenwalk live 4.4.1 funziona perfettamente.
quindi ho cancellato i pacchetti di xorg della slackware-current che stavo usando ed ho installato quelli di zenwalk su slackware, ma non è cambiato nulla, è solo più stabile (quello di slackware-current creshava durante la riproduzione di video) ma l'accelerazione 3d comunque non funziona.
ho provato anche ad usare il kernel di zenwalk su slackware ma niente, il risultato non cambia.
spero che qualcuno sappia aiutarmi. grazie in anticipo!

ps: uso linux abitualmente da 5/6 anni, non prendetela per una cosa banale.
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1440
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Messaggioda lucif3r0 » mer giu 06, 2007 18:11

ciao non ho mai avuto a che fare con queste schede, però
tanto per iniziare dicci che portatile è, poi ti consiglio di dare
un'occhiata qui: http://wiki.openchrome.org/tikiwiki/tiki-index.php
Avatar utente
lucif3r0
Linux 2.6
Linux 2.6
 
Messaggi: 617
Iscritto il: mar mag 10, 2005 23:00
Slackware: 13.1
Kernel: 2.6.33.4
Desktop: KDE 4.3

Messaggioda sya54M » gio giu 07, 2007 9:12

ciao grazie della risposta.
però già uso questi driver che sono anche quelli già inclusi in xorg nel pacchetto xf86-video-via.
il portatile è un progress school ma non ricordo che modello,
ti posto il risultato di lspci per darti un idea dei componenti:

00:00.0 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:09.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter (rev 01)
ciao!
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1440
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Messaggioda lucif3r0 » gio giu 07, 2007 16:57

ok, ripeto, non ho mai usato questa scheda, sto solo provando.
Mi incolleresti anche il tuo xorg.conf e il risultato di lsmod?
Avatar utente
lucif3r0
Linux 2.6
Linux 2.6
 
Messaggi: 617
Iscritto il: mar mag 10, 2005 23:00
Slackware: 13.1
Kernel: 2.6.33.4
Desktop: KDE 4.3


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron