Repository 32bit  Forum
Repository 64bit  Wiki

DUB-C2

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

DUB-C2

Messaggioda odiusseus » sab giu 30, 2007 13:29

Salve a tutti...sono un nuovo iscritto..
ho un serio problema con il mio vecchissimo portatile (2000) che non ha porte USB2.0 per tale motivo ho comprato una scheda PCMCIA USB2.0 precisamente D-link USB 2.0 (DUB-C2).
Se Slackware (10.2) parte con un kernel della serie 2.4 funzione alla perfezione, se parte con un kernel 2.6 si blocca all'hotplug.
So che devo applicare una patch al kernel ma non so quale sia!!!
Grazie
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde

Messaggioda michele.p » sab giu 30, 2007 13:54

Ciao e benvenuto,

inizia con l'indicare marca e modello del portatile, vedi mai che c'è già una guida bella che scritta in rete. :D

Prova a installare la current che usa di defautl il kernel 2.6.21.5.
Se non hai i CD (o il DVD) puoi scaricarne le ISO belle che pronte da qui;

ftp://ftp.slackware.no/pub/linux/ISO-im ... ISO-build/

che come puoi ben vedere sono aggiornate a pochi giorni fa.


Bye
Avatar utente
michele.p
Packager
Packager
 
Messaggi: 1275
Iscritto il: ven nov 24, 2006 16:52
Località: Pontecorvo(FR)
Nome Cognome: Michele Petrecca
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE
Distribuzione: ..Fedora e Mandriva

Messaggioda danix » sab giu 30, 2007 14:13

premetto che non so come aiutarti direttamente, ma con la slackware 11.0 hai provato?? se la installi con il kernel di default ti ritrovi un 2.4 e quindi credo che dovrebbe funzionare, se installi un kernel 2.6 c'è lo huge che ha praticamente tutto quindi è probabile che funzioni pure...
La current è praticamente la 12 rc2, puoi provarla ma scordati il kernel 2.4... pat l'ha abbandonato...

A presto...
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

grazie

Messaggioda odiusseus » sab giu 30, 2007 14:38

Grazie per l'aiuto...
E' un HP omnibook XE2 con processore AMD K6-2.
Non ho ancora provato slackware 11.0 su questo pc !!
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde

Messaggioda michele.p » sab giu 30, 2007 15:00

...come puoi vedere da qui;

http://www.linux-on-laptops.com/hp.html

c'era proprio sull'XE2 una guida ma a quanto pare non è più raggiungibile!
Ci sono svariate guide per l'XE3.

L'unico suggerimento è provare con la current con i link che ti ho postato in precedenza.


...facci sapere....

Bye
Avatar utente
michele.p
Packager
Packager
 
Messaggi: 1275
Iscritto il: ven nov 24, 2006 16:52
Località: Pontecorvo(FR)
Nome Cognome: Michele Petrecca
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE
Distribuzione: ..Fedora e Mandriva

Risolto

Messaggioda odiusseus » lun lug 16, 2007 21:35

Ciao a tutti,
sono riuscito a risolvere il problema con la scheda. Non sono riuscito ad installare nuove versioni di Slackware (11.0 e 12.0 per intenderci) ma sono rimasto con la vecchia 10.2. Ho installato il kernel 2.6.18 e ho fatto un upgrade di pcmciautil. La sintassi è stata proprio banale:
#upgradepkg oldpackage%newpackage

precisamente:
$su
#upgradepkg pcmcia-cs-3.2.8-i486-1%pcmciautils-014-i486-2.tgz

questo crea un file in /etc/rc.d/ chiamato rc.pcmcia.new

#mv /etc/rc.d/rc.pcmcia /etc/rc.d/rc.pcmcia.back

non elimino mai i file che più o meno funzionano fino al test completo dei nuovi file di configurazione

#mv /etc/rc.d/rc.pcmcia.new /etc/rc.d/rc.pcmcia

Ho riavviato...ed ecco la scheda che funziona a meraviglia
Grazie a tutti per le risposte...ciao
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite