ipw3945 e wpa

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
sbabaro
Packager
Packager
Messaggi: 388
Iscritto il: ven set 09, 2005 0:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

ipw3945 e wpa

Messaggioda sbabaro » ven ott 12, 2007 11:03

Sto cercando di far andare il wifi con il wpa
Senza problemi quando lavoro senza encryption
non solo si connette, ma se faccio un

Codice: Seleziona tutto

iwlist eth1 scan

mi torna correttamente l'AP
Il problema nasce quando pro ad usare il wpa_supplicant
infatti con il comando

Codice: Seleziona tutto

wpa_supplicant -D wext -i eth1 -c /etc/wpa_supplicant.conf

se faccio ancora l'iwlist mi da no scan result

qualcuno ha idea come mai?

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun ago 09, 2004 0:00
Località: Rimini

Messaggioda Bart » ven ott 12, 2007 11:17

Ciao, se la scheda ti funziona senza crittografia già sei a cavallo. Prova a postare /etc/wpa_supplicant.conf relativo alla tua configurazione. Per i driver sei certo che siano i wext? Io una una ipw2200 e con i wext va benissimo ma non ho esperienza sulla tua ipw3945. Ti posto anche un link dove spiega come ho configurato la mia scheda wireless che credo sia una sorella della tua, magari ti aiuta: http://www.slacky.eu/wikislack/index.ph ... H#Wireless

sbabaro
Packager
Packager
Messaggi: 388
Iscritto il: ven set 09, 2005 0:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Messaggioda sbabaro » ven ott 12, 2007 14:33

grazie per il suggerimento, quella pagina l'avevo vista
il driver dovrebbe essere quello
all'ap mi connetto tranquillamente se non è criptato
il file di configurazione dovrebbe essere a posto, ho anche provato ad abilitare pezzi in più e in meno
la cosa strana è che smette di fare lo scan.
tra l'altro oggi, inizialmente, ha trovato l'ap durante lo scan con debug fatto da wpa_supplicant, ma di nuovo non trova nulla e blocca lo scan anche di iwlist fino a quando non scarico il modulo
non riesco a capire

sbabaro
Packager
Packager
Messaggi: 388
Iscritto il: ven set 09, 2005 0:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Messaggioda sbabaro » gio ott 18, 2007 14:04

nessuno che ha (o ha avuto) un problema simile???????


Torna a “Laptop”

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti