Repository 32bit  Forum
Repository 64bit  Wiki

Crash di KDM inserendo una SD Card

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Crash di KDM inserendo una SD Card

Messaggioda Alcatraz » sab ott 20, 2007 12:23

Ciao a tutti.

Allora, risolto il problema sulla ipw3945 passo al successivo.

Ho un lettore di memory card integrato sul mio Acer Aspire 5652WLMi.

Codice: Seleziona tutto
# lspci | grep ENE
06:04.0 CardBus bridge: ENE Technology Inc CB-712/4 Cardbus Controller (rev 10)
06:04.1 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller (rev 01)
06:04.2 Generic system peripheral [0805]: ENE Technology Inc ENE PCI Secure Digital Card Reader Controller (rev 01)
06:04.3 FLASH memory: ENE Technology Inc FLASH memory: ENE Technology Inc: (rev 01)
06:04.4 FLASH memory: ENE Technology Inc SD/MMC Card Reader Controller (rev 01)


Codice: Seleziona tutto
# dmesg
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci: SDHCI controller found at 0000:06:04.2 [1524:0550] (rev 1)
PCI: Enabling device 0000:06:04.2 (0000 -> 0002)
ACPI: PCI Interrupt 0000:06:04.2[B] -> GSI 17 (level, low) -> IRQ 17
PCI: Setting latency timer of device 0000:06:04.2 to 64
mmc0: SDHCI at 0xd2202400 irq 17 DMA
sdhci: SDHCI controller found at 0000:06:04.4 [1524:0551] (rev 1)
PCI: Enabling device 0000:06:04.4 (0000 -> 0002)
ACPI: PCI Interrupt 0000:06:04.4[B] -> GSI 17 (level, low) -> IRQ 17
mmc1: SDHCI at 0xd2202100 irq 17 PIO


Per eseguire l'automount di una scheda SD (per ora ho solo questa) ho inserito in /etc/fstab la riga

Codice: Seleziona tutto
/dev/mmcblk0p1   /mnt/sd          vfat        noauto,users,owner 0 0


creando ovviamente la directory /mnt/sd.

Quando inserisco la scheda, questa viene rilevata automaticamente, parte HAL e mi apre la risorsa. Peccato però che vada in crash KDM - Il gestore dei crash di KDE.

Il log dell'errore è questo:

Codice: Seleziona tutto
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1236039952 (LWP 3400)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0xb7867a5e in QWidget::~QWidget ()
   from /usr/lib/qt-3.3.8/lib/libqt-mt.so.3
#6  0xb78c1f38 in QButton::~QButton ()
   from /usr/lib/qt-3.3.8/lib/libqt-mt.so.3
#7  0xb7f75751 in KCommonDecorationButton::~KCommonDecorationButton ()
   from /usr/lib/libkdecorations.so.1
#8  0xb6458ce5 in KWinPlastik::PlastikButton::~PlastikButton ()
   from /usr/lib/kde3/kwin3_plastik.so
#9  0xb7f776c0 in KCommonDecoration::~KCommonDecoration ()
   from /usr/lib/libkdecorations.so.1
#10 0xb6456e68 in KWinPlastik::PlastikClient::~PlastikClient ()
   from /usr/lib/kde3/kwin3_plastik.so
#11 0x0805bb14 in ?? ()
#12 0x08052fa9 in ?? ()
#13 0x08050e36 in ?? ()
#14 0xb782f0c9 in QObject::activate_signal ()
   from /usr/lib/qt-3.3.8/lib/libqt-mt.so.3
#15 0xb7e568a1 in KWinModule::windowRemoved () from /usr/lib/libkdecore.so.4
#16 0xb7e57547 in KWinModulePrivate::removeClient ()
   from /usr/lib/libkdecore.so.4
#17 0xb7dfe1ca in NETRootInfo::update () from /usr/lib/libkdecore.so.4
#18 0xb7dfe58d in NETRootInfo::event () from /usr/lib/libkdecore.so.4
#19 0xb7e579f0 in KWinModulePrivate::x11Event () from /usr/lib/libkdecore.so.4
#20 0xb7de8333 in KApplication::x11EventFilter ()
   from /usr/lib/libkdecore.so.4
#21 0x080535c3 in ?? ()
#22 0xb7761b24 in ?? () from /usr/lib/qt-3.3.8/lib/libqt-mt.so.3
#23 0x080692f0 in ?? ()
#24 0xbfe4d6c8 in ?? ()
#25 0x00400000 in ?? ()
#26 0xb7c66c34 in ?? () from /usr/lib/qt-3.3.8/lib/libqt-mt.so.3
#27 0xb7c66c34 in ?? () from /usr/lib/qt-3.3.8/lib/libqt-mt.so.3
#28 0x00000003 in ?? ()
#29 0xbfe4d5b8 in ?? ()
#30 0xb777065b in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3.8/lib/libqt-mt.so.3
Backtrace stopped: frame did not save the PC


Il /var/log/messages questo:

Codice: Seleziona tutto
mmc1: new high speed SD card at address b368
mcblk0: mmc1:b368 SD    1960448KiB (ro)
mmcblk0: p1


Chiudo la finestra dell'errore e posso tranquillamente lavorare, seleziono i file all'interno della scheda e li copio sull'hard disk. Però poi devo riavviare KDE, altrimenti tutte le finestre risultano senza la barra in alto, quella con ingrandisci, minimizza ecc. (che non so come si chiami).

Quando poi smonto la scheda per rimuoverla esce quest'altro errore:

Codice: Seleziona tutto
Il dispositivo è stato smontato con successo, ma non è stato possibile espellerlo


anche se questo credo sia normale, visto che non può espellere una memory card!

Bene, a voi la parola. :D
Alcatraz
Linux 2.0
Linux 2.0
 
Messaggi: 126
Iscritto il: ven ott 12, 2007 11:28

Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite