Repository 32bit  Forum
Repository 64bit  Wiki

Problema con iwconfig

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema con iwconfig

Messaggioda Gengis » gio mar 06, 2008 14:14

Ciao a tutti,

da quando ho fatto upgrade con slapt-get della slackware 12.0 alla current durante il boot ho questo errore:


Codice: Seleziona tutto
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.


stesso errore se provo ad riavviare /etc/rc.d/rc.inet1 restart

e se provo ad impostare manualmente :

Codice: Seleziona tutto
root@AcDc:/# iwconfig wlan0 nickname prova
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.


Qualcuno puo' aiutarmi ?

il kernel è il 2.6.24, uso il modulo b43 e la scheda wifi è un bcm4318 su notebook Hp Pavilion dv5000.

- Ps: la wifi continua comunque a funzionare come prima dell'upgrade.

Grazie a tutti
Gengis
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: sab dic 04, 2004 0:00

Re: Problema con iwconfig

Messaggioda conraid » gio mar 06, 2008 14:21

Non tutte le schede e/o driver supportano l'opzione nickname.
A me da errore, ma poi va tranquillamente
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Problema con iwconfig

Messaggioda JohnnyMnemonic » gio mar 06, 2008 14:22

E' successo anche a me con il passaggio al 2.6.24.x, ho una ipw3945 e i nuovi driver integrati nel kernel semplicemente non hanno la "funzionalità" per il nickname.
Ma niente di grave, come vedi anche tu, funziona lo stesso.

Non so in effetti lo scopo di nickname....
Avatar utente
JohnnyMnemonic
Staff
Staff
 
Messaggi: 2732
Iscritto il: sab set 04, 2004 23:00
Località: Bologna
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos

Re: Problema con iwconfig

Messaggioda conraid » gio mar 06, 2008 14:26

Gengis ha scritto:Ciao a tutti,

da quando ho fatto upgrade con slapt-get della slackware 12.0 alla current durante il boot ho questo errore:


Comunque la prossima volta, per sicurezza, non lo fare tramite slapt-get e simili
http://www.slacky.eu/wikislack/index.ph ... or_Dummies
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Problema con iwconfig

Messaggioda Gengis » gio mar 06, 2008 14:32

intanto vi ringrazio... e poi vorrei chiedervi:

Se la mia wifi non supportasse veramente il nickname, l'errore si sarebbe dovuto verificare anche prima dell'aggiornamento, giusto?

Cosa dovrei modificare per fare in modo che non si cerki in automatico d'impostare il nickname ?

il mio /etc/rc.d/rc.wireless http://www.nopaste.com/p/a02Iticky
Gengis
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: sab dic 04, 2004 0:00

Re: Problema con iwconfig

Messaggioda conraid » gio mar 06, 2008 14:36

Gengis ha scritto:intanto vi ringrazio... e poi vorrei chiedervi:

Se la mia wifi non supportasse veramente il nickname, l'errore si sarebbe dovuto verificare anche prima dell'aggiornamento, giusto?


Sì, ma come detto prima a volte sono i driver a non supportarlo. E nel nuovo kernel magari sono cambiati proprio quelli.

Gengis ha scritto:Cosa dovrei modificare per fare in modo che non si cerki in automatico d'impostare il nickname ?

il mio /etc/rc.d/rc.wireless http://www.nopaste.com/p/a02Iticky


rc.wireless.conf non ti serve, a meno che non hai più periferiche, ma anche in questo caso mi trovo bene anche solamente con rc.inet1.conf
Lascia perdere il discorso del nickname, tanto anche se non lo configuri lui prova a settarlo ad any
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Problema con iwconfig

Messaggioda Gengis » gio mar 06, 2008 14:41

il kernel e quindi i driver sono gli stessi che avevo con la 12.0, non li ho modificati.

/etc/rc.d/rc.inet1.conf http://www.nopaste.com/p/aeAzH9nIc
Gengis
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: sab dic 04, 2004 0:00

Re: Problema con iwconfig

Messaggioda conraid » gio mar 06, 2008 14:46

Gengis ha scritto:il kernel e quindi i driver sono gli stessi che avevo con la 12.0, non li ho modificati.

/etc/rc.d/rc.inet1.conf http://www.nopaste.com/p/aeAzH9nIc


Hai aggiornato alla current senza aggiornare il kernel?

Non sembra che hai configurato il nickname da nessuna parte. Ma ti da così tanto fastidio?
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Problema con iwconfig

Messaggioda Gengis » gio mar 06, 2008 14:49

Avevo gia compilato il kernel 2.6.24 prima di passare alla current.
Bhe piu che fastidio, vorrei provare a capire cosa è accaduto e se possibile sistemare, non è proprio bello un "error" durante la schermata di boot
Gengis
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: sab dic 04, 2004 0:00

Re: Problema con iwconfig

Messaggioda conraid » gio mar 06, 2008 15:03

Gengis ha scritto:Avevo gia compilato il kernel 2.6.24 prima di passare alla current.
Bhe piu che fastidio, vorrei provare a capire cosa è accaduto e se possibile sistemare, non è proprio bello un "error" durante la schermata di boot


Considerato le nuove glibc e il nuovo gcc ti consiglio di ricompilare.
Non so che driver usa la tua scheda, come ti abbiamo detto anche con le intel (ed a me anche con la zd1211) da quell'errore.
Se non vuoi usare il nickname commenta la riga che imposta il nickname da rc.wireless, che è un file diverso da quello che hai postato prima, o meglio ancora ridirigi l'output in /dev/null così non vedi l'errore
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Problema con iwconfig

Messaggioda Gengis » gio mar 06, 2008 15:12

Grazie, provero a ricompilare il kernel e guardero rc.wireless
Gengis
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: sab dic 04, 2004 0:00


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron