Repository 32bit  Forum
Repository 64bit  Wiki

VFS: Cannot open root device "803"... [RISOLTO]

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

VFS: Cannot open root device "803"... [RISOLTO]

Messaggioda BOFH » gio mar 13, 2008 21:49

Salve,
ero indeciso se postare in questa sezione o in quelle relative ai problemi generali.
Se qualche moderatore pensa che questa discussione vada spostata lo faccia pure

Ho un Samsung Q45 su cui uso Slackware 12.0; ho installato il sistema senza riscontrare nessun problema, sono anche riuscito a configurare le varie periferiche, ma avevo la necessità di passare a una versione del kernel successiva a quella presente nei cd di installazione.
La versione che ho cercato di installare è la 2.6.23.14, mentre quella già presente e funzionante è la 2.6.21.5-smp (da quello che ho capito smp significa semplicemente che è compilata col supporto per CPU multiple).
Ho copiato il config della versione 2.6.21.5 nella directory dei sorgenti del nuovo kernel, ho compilato i sorgenti e i moduli senza alcun problema e ho aggiunto la voce del nuovo kernel tra le scelte del boot loader lilo.
Al reboot ho provato ad avviare il kernel appena compilato, il quale è partito senza problemi, finchè non è arrivato il momento di montare il filesystem di root, che nel mio caso è /dev/sda3.
A quel punto ho ottenuto il seguente errore:
Codice: Seleziona tutto
VFS: Cannot open root device "803" or unknown-block(8,3)
Please append a correct "root=" boot option

Il boot si è fermato in quel momento. Poco prima dell'errore è apparsa una lista di partizioni, per la precisione le stesse che ho su /dev/sda, nominate però in maniera differente, cioè anzichè sda si legge hda. Da questo ho supposto che il mio disco Serial ATA venisse visto come un normale IDE; per verificarlo ho provato a cambiare la voce "root=" nel menu di boot inserendo hda3 anzichè sda3, e sono riuscito a far partire il sistema. Ho notato però che era tremendamente lento nel compiere qualsiasi operazione, così ho provato a testare il disco con hdparm e ho visto che la velocità era di circa 2 MB/s mentre normalmente con l'altro kernel (e quindi col device /dev/sda) si aggira intorno ai 48 MB/s.

Una volta capito quale fosse il problema ho cercato un po' dappertutto le soluzioni su internet, ho seguito tanti consigli trovati qua e la, ricompilato il kernel varie volte aggiungendo altri parametri alla configurazione, sempre con esito negativo.

Ciò che non riesco a spiegarmi è perchè la stessa identica configurazione funzioni per il kernel "vecchio" e non per quello che sto cercando di installare. Ci sono esattamente gli stessi driver caricati nella stessa maniera (non modulari, non uso initrd).

Incollo qui sotto l'output di qualche comando per darvi le informazioni che ritengo necessarie per provare a risolvere il problema.

Codice: Seleziona tutto
bash-3.1# lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
02:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. Unknown device 4353 (rev 15)
04:09.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b4)
04:09.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 09)
04:09.2 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 18)
04:09.3 System peripheral: Ricoh Co Ltd Unknown device 0843
04:09.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 09)
04:09.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 04)
bash-3.1# 


Codice: Seleziona tutto
bash-3.1# uname -r
2.6.21.5-smp
bash-3.1#


Codice: Seleziona tutto
bash-3.1# cat /proc/cpuinfo | grep model     
model           : 15
model name      : Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz
model           : 15
model name      : Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz
bash-3.1#


Codice: Seleziona tutto
bash-3.1# grep -i 'ata.*=y' config-2.6.23.14-smp
CONFIG_ATA=y
CONFIG_ATA_ACPI=y
CONFIG_SATA_AHCI=y
CONFIG_SATA_SVW=y
CONFIG_ATA_PIIX=y
CONFIG_SATA_MV=y
CONFIG_SATA_NV=y
CONFIG_SATA_QSTOR=y
CONFIG_SATA_PROMISE=y
CONFIG_SATA_SX4=y
CONFIG_SATA_SIL=y
CONFIG_SATA_SIL24=y
CONFIG_SATA_SIS=y
CONFIG_SATA_ULI=y
CONFIG_SATA_VIA=y
CONFIG_SATA_VITESSE=y
CONFIG_PATA_SIS=y
CONFIG_USB_STORAGE_DATAFAB=y
bash-3.1#


Ormai ci ho perso qualche giornata, ma evidentemente non ho le conoscenze necessarie per venirne a capo.
Vi sarei veramente grato se riusciste a darmi una mano.
Per qualsiasi altra informazione sul computer chiedete.

Grazie anticipatamente.
Ultima modifica di BOFH il gio mar 13, 2008 22:49, modificato 1 volta in totale.
BOFH
Linux 1.0
Linux 1.0
 
Messaggi: 3
Iscritto il: gio mar 13, 2008 20:11

Re: VFS: Cannot open root device "803"...

Messaggioda conraid » gio mar 13, 2008 21:54

BOFH ha scritto:La versione che ho cercato di installare è la 2.6.23.14, mentre quella già presente e funzionante è la 2.6.21.5-smp (da quello che ho capito smp significa semplicemente che è compilata col supporto per CPU multiple).
Ho copiato il config della versione 2.6.21.5 nella directory dei sorgenti del nuovo kernel, ho compilato i sorgenti e i moduli senza alcun problema e ho aggiunto la voce del nuovo kernel tra le scelte del boot loader lilo.


Perché proprio la 2.6.23.14?
Hai preso il config del generic o dell'huge?
Nel primo caso devi fare anche l'initrd.
Comunque prima di dare make per compilare il kernel, dai un make oldconfig per allinearlo alla nuova versione
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: VFS: Cannot open root device "803"...

Messaggioda phobos3576 » gio mar 13, 2008 22:39

Probabilmente si tratta del solito problema che abbiamo già affrontato parecchie volte; tutto dovrebbe risolversi compilando direttamente nel kernel il supporto per il filesystem utilizzato.
In pratica, se la partizione Linux si trova su filesystem ext3, bisogna compilare direttamente nel kernel il supporto per ext3, mentre il supporto per gli altri filesystem deve essere compilato come modulo; se non si segue questa procedura, allora è necessario creare l'init ram disk!
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: VFS: Cannot open root device "803"...

Messaggioda BOFH » gio mar 13, 2008 22:49

@conraid
La 2.6.23.14 mi serve perchè assieme a dei driver patchati per la scheda wireless integrata del mio portatile mi consente di utilizzare aircrack (avevo intenzione di fare qualche test a casa sulla mia rete).
Ho usato il config del kernel che uso di solito, non ti so dire se sia il generic o il huge, credo il huge comunque.
Solitamente anzichè usare make oldconfig copio direttamente il vecchio config nella directory dei sorgenti e lo carico usando make menuconfig.

@phobos3576
Ho compilato il supporto per l'ext3 in modo statico proprio per evitare che ci fosse quest'altro problema (tutta questa situazione mi ha fatto imparare un bel po' di cose nuove)

Detto ciò, devo darmi qualche decina di frustate sulla schiena (o preferibilmente martellate sui testicoli), perchè ho guardato dappertutto tranne che all'interno di questo forum, per slackware, in italiano, e così non ho visto prima questo post, che miracolosamente ha risolto tutti i miei problemi proprio pochi secondi fa.

Scusate se ho fatto perdere del tempo a qualcuno e grazie per avermi aiutato. Edito il nome della discussione e ci appiccico un bel [RISOLTO]
BOFH
Linux 1.0
Linux 1.0
 
Messaggi: 3
Iscritto il: gio mar 13, 2008 20:11

Re: VFS: Cannot open root device "803"... [RISOLTO]

Messaggioda phobos3576 » gio mar 13, 2008 23:06

Anche se hai risolto, credo proprio che l'eliminazione del supporto IDE/ATA non c'entri nulla; io l'ho attivato (in quanto ho, sia periferiche SATA, sia periferiche IDE/ATA) e funziona tutto perfettamente.
E' più probabile che il problema dipenda da una errata configurazione nel kernel del supporto per il controller dell'hard disk.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: VFS: Cannot open root device "803"... [RISOLTO]

Messaggioda BOFH » gio mar 13, 2008 23:21

Non so che dirti, so solo che è l'unica cosa che ho cambiato e che mi ha dato qualche risultato.
In realtà è un'opzione che avevo già considerato, dato che avevo letto in qualche forum straniero che l'utilizzo di alcuni driver escludeva quello di altri.
Magari quella sezione impediva al kernel di usare i driver corretti, ma questo va oltre quelle che sono le mie limitate competenze.
BOFH
Linux 1.0
Linux 1.0
 
Messaggi: 3
Iscritto il: gio mar 13, 2008 20:11

Re: VFS: Cannot open root device "803"...

Messaggioda conraid » ven mar 14, 2008 11:02

BOFH ha scritto:@conraid
Solitamente anzichè usare make oldconfig copio direttamente il vecchio config nella directory dei sorgenti e lo carico usando make menuconfig.


Se prendi un config di una versione diversa del kernel ti conviene dare make oldconfig per allinearlo. Nel modo che fai tu puoi sempre farlo con make menuconfig o xconfig, ma rischi di perderti qualcosa per strada. Make oldconfig ti mostra le nuove voci e ti fa decidere cosa fare. Se noti strani cambiamenti dopo modifichi tramite make menuconfig o xconfig, altrimenti lanci make e via
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current


Torna a Laptop

Chi c’è in linea

Visitano il forum: Baidu [Spider] e 1 ospite