Repository 32bit  Forum
Repository 64bit  Wiki

Tasti speciali su ASUS a6vc A6Q00VC

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Tasti speciali su ASUS a6vc A6Q00VC

Messaggioda lostratega » gio mar 20, 2008 16:52

Salve ragazzi

prima di riaprire un post che tratta questo argomento, mi sono guardato tutte le discussioni sotto la voce laptop
e ho visto linux-HOWTO presente nella sitribuzione (in più ho fatto ricerche in google).
Come si capisce sto cercando di attivare i tasti speciali presenti sul mio portatile Asus A6VC (A6Q00VC)
In questo sito c'è una guida proprio inerente al mio laptop e al mio problema, ma da essa ho tratto parziale beneficio
(sicuramente per una mia inesperienza) riuscendo a configurare i tasti per il volume stidiandomi il meccanismo di amixer.
Anche su questo forum si è trattato l'argomento ma le procedure non vanno a buon fine, idem per i suggerimenti trovati in rete.

Vi dico in breve che cosa ho fatto:

Ho una slackware 12.0
Kernel 2.6.21.5-smp
Ho attivato
ASUS_ACPI
ACPI
ASUS_LAPTOP presente nel kernel
in quanto al modulo non so come caricarlo; do il comando modprobe asus_laptop
(ho provato anche con asus-laptop) ma mi da errore
root@darkstar:~# modprobe asus_laptop
FATAL: Error inserting asus_laptop (/lib/modules/2.6.21.5-smp/kernel/drivers/misc/asus-laptop.ko):No such device

La voce nel kernel è: CONFIG_ASUS_LAPTOP=y

ad ogni modo ho provato a verificare la mappatura dei tasti tramite XEV e XBINDKEYS
e più precisamente i tasti: Velocità; Mail; Browser; Touchpad; fn+F2 (wireless); senza ottenere risultato
solo dopo aver premuto i tasti e mandato via terminale il comando: cat /var/log/acpid
posso apprendere che la procedura non va a buon fine perchè c'è un errore:

[Thu Mar 20 16:37:39 2008] received event "hotkey ATKD 00000051 0000000c"
[Thu Mar 20 16:37:39 2008] notifying client 3105[82:82]
[Thu Mar 20 16:37:39 2008] notifying client 3241[0:0]
[Thu Mar 20 16:37:39 2008] notifying client 3241[0:0]
[Thu Mar 20 16:37:39 2008] executing action "/etc/acpi/browser.sh "
[Thu Mar 20 16:37:39 2008] BEGIN HANDLER MESSAGES

(firefox-bin:7382): Gtk-WARNING **: cannot open display:
[Thu Mar 20 16:37:39 2008] END HANDLER MESSAGES
[Thu Mar 20 16:37:39 2008] action exited with status 1
[Thu Mar 20 16:37:39 2008] executing action "/etc/acpi/acpi_handler.sh hotkey ATKD 00000051 0000000c"
[Thu Mar 20 16:37:39 2008] BEGIN HANDLER MESSAGES
[Thu Mar 20 16:37:39 2008] END HANDLER MESSAGES
[Thu Mar 20 16:37:39 2008] action exited with status 0
[Thu Mar 20 16:37:39 2008] completed event "hotkey ATKD 00000051 0000000c"


su internet ho trovato qualcosa di molto specifico qui: http://leufke.info/linux/asus/index.html
però è per debian e non so fino a che punto possa essere compatibile con slackware 12.

posto per completezza il contenuto dei file creati:

In /etc/acpi/events ho creato un file di testo chiamato browser
con questo contenuto:
event=hotkey ATKD 00000051
action=/etc/acpi/browser.sh

in /etc/acpi il corrispondente file reso eseguibile con il comando chmod +x nomefile
con questo contenuto:
#!/bin/sh
/usr/bin/firefox.

premuto il pulsante browser non accade nulla.

Fatemi sapere dove sto sbagliando, al momento sono fermo al solo tasto per la navigazione gli altri non li ho configurati.

Grazie

L.S.
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: Tasti speciali su ASUS a6vc A6Q00VC

Messaggioda conraid » gio mar 20, 2008 17:09

Non lanciare programmi grafici da root tramite ACPI, usalo solamente per configurazione periferiche hardware (volume, schermo, etc...)
Per lanciare applicazioni da utente usa i keycode
ttp://www.slacky.eu/wikislack/index.php ... i_in_linux
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Tasti speciali su ASUS a6vc A6Q00VC

Messaggioda lostratega » gio mar 20, 2008 22:34

Ciao Conraid

grazie per la segnalazione, quella guida l'ho già letta ma incontro una limitazione, ovvero il programma XEV non mi permette di scoprire il keycode del tasto gia predisposto all'apertura del browser. Non si tratta di una combinazione da me scelta della tastiera, ma di un tasto nativo del mio portatile e, caso strano, non viene tracciato dal programma. Ho studiato anche il programma xbinfkeys segnalato nella guida il quale ha anche una funzione di tracciatura dei tasti, ma anche con questo non sono in grado di rilevare il key code del tasto browser. L'unico modo che ho avuto per confermanre gli hotkey segnalati nella guida riferita al mio portatile e presente in questo sito è stato lanciando da terminale il comando che già avevo reso noto: cat /var/log/acpid.

l'unica cosa che non faccio è quella di gestirmi la macchina tra utente e root, cioè opero nella macchina solo e soltanto come root, non ho creato un altro utente; può essere questa la limitazione? Onestamente non credo.

Grazie

L.S.
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: Tasti speciali su ASUS a6vc A6Q00VC

Messaggioda conraid » ven mar 21, 2008 11:01

lostratega ha scritto:l'unica cosa che non faccio è quella di gestirmi la macchina tra utente e root, cioè opero nella macchina solo e soltanto come root, non ho creato un altro utente; può essere questa la limitazione? Onestamente non credo.


Per la scelte di usare solo root, pessima scelta.

Per l'errore:
se tu guardi il tipo di errore
(firefox-bin:7382): Gtk-WARNING **: cannot open display:
Vedi che è l'errore classico di quando non hai i permessi per avviare una applicazione su quel display. Solitamente si ha per esempio quando da una console dentro X si da il comando su per diventare root e poi si avvia una applicazione grafica.
Cerca nel forum per la soluzione. Se sai in init 3 ti basta xhost +localhost
Se però sei root allora la cosa è "strana".

Prova così:

Leggi questa pagina
http://www.thinkwiki.org/wiki/How_to_configure_acpid

E' per gli IBM, ma a me è servita, come altra, per capire meglio il tutto.
Se vedi in fondo alla pagina ci sono degli script per lanciare programmi.
Fai xhost e poi uno script che fa da wrapper per lanciare firefox.

Dimmi se funziona
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Tasti speciali su ASUS a6vc A6Q00VC

Messaggioda lostratega » sab mar 22, 2008 1:07

Ciao conraid

grazie per l'intervento

con il comando che mi hai segnalato xhost +localhost [mi spieghi un pò il significato di questo comando?]
sono riuscito ad eliminare l'errore
(firefox-bin:7382): Gtk-WARNING **: cannot open display

ma l'associazione punlsante > applicazione continua a darmi esito negativo.
Alla pressione del pulsante corrispettivo e lanciando da shell: tail /var/log/acpid
ho come risultato:

[Sat Mar 22 00:47:30 2008] completed event "hotkey ATKD 00000051 0000000a"
[Sat Mar 22 00:52:38 2008] received event "hotkey ATKD 00000051 0000000b"
[Sat Mar 22 00:52:38 2008] notifying client 3378[82:82]
[Sat Mar 22 00:52:38 2008] notifying client 3538[0:0]
[Sat Mar 22 00:52:38 2008] notifying client 3538[0:0]
[Sat Mar 22 00:52:38 2008] executing action "/etc/acpi/acpi_handler.sh hotkey ATKD 00000051 0000000b"
[Sat Mar 22 00:52:38 2008] BEGIN HANDLER MESSAGES
[Sat Mar 22 00:52:38 2008] END HANDLER MESSAGES
[Sat Mar 22 00:52:38 2008] action exited with status 0
[Sat Mar 22 00:52:39 2008] completed event "hotkey ATKD 00000051 0000000b"


ho studiato la guida che mi hai segnalato e sinceramente non mi sembra che io abbia mancato qualcosa
se non appunto il comando che dice di eseguire prima delle operazioni: xhost +local:root
se lo digito ho come risposta:
non-network local connections being added to access control list [puoi spegarmi anche questo]

se invece faccio così:
oot@darkstar:~# xhost
access control enabled, only authorized clients can connect
INET:localhost
LOCAL:


ad ogni modo non riesco ancora a capire bene quanto accade.
riesci a capire qualcosa tu? Al momento sono un pò bloccato.

ho creato uno script e se ci clicco sopra firefox parte, ma ciò non accade quando premo il pulsante in questione
il quale non è rotto visto che sotto windows mi funziona.

Grazie

L.S.
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: Tasti speciali su ASUS a6vc A6Q00VC

Messaggioda conraid » sab mar 22, 2008 9:56

Allora.
Xhost gestisce i permessi alla tua sessione di X

Non dare xhost e basta, perché cambia il permesso che avevi. Come leggi dal messaggio, dopo che hai dato xhost ti dice che solo i client autorizzati possono accedere, in quanto lo abiliti.
xhost +localhost in pratica permette a tutti i client su localhost di accedere alla tua sessione di X.

Il comando IBM si vede che ha local invece di localhost, non preoccuparti di seguire alla lettera.
Abilita il permesso solo a root, che poi nel tuo caso sei tu stesso, quindi è inutile per te.

Se sei in init4 la cosa è diversa, perché X è avviato da gdm/kdm/xdm e non dal tuo utente. Ora non ricordo la procedura da fare, ma qualche minuto su google e la trovi.


Per vedere se funziona il tuo script fai così.
Prima dell'invocazione di firefox fagli scrivere un file, per esempio
Codice: Seleziona tutto
#!/bin/sh
echo "Firefox by ACPI" > /tmp/firefox.txt
firefox


E controlla il file /tmp/firefox.txt se è stato creato e se ha quella stringa.
Se sì allora il problema è relativo all'invocazione di firefox, altrimenti va guardato ACPI e/o lo script con relativi permessi.
Ma ti ripeto, perché fai tutto, compreso navigare, da root?
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Tasti speciali su ASUS a6vc A6Q00VC

Messaggioda lostratega » sab mar 22, 2008 12:16

Buongiorno Conraid

ho inserito lo script che mi hai dato all'interno del file che io chiamo "browser.sh",alla pressione del rispettivo pulsante non accade nulla nemmeno la creazione del file firefox.txt, mentre il tutto va a buon fine quando clicco sul file contenete lo script [browser.sh](spero di essermi spiegato).
Fatto questo si ritorna a ciò che hai dettu tu:
"
Se sì allora il problema è relativo all'invocazione di firefox

per quanto concerne il discorso init3 init4, beh non so cosa siano:

Se sei in init4 la cosa è diversa, perché X è avviato da gdm/kdm/xdm e non dal tuo utente


in che senso X [cioè il server grafico] è avviato da gdm/kdm/xdm e non dal mio utente ovvero root?

sto facendo delle ricerche su questo, ma procedo bracolando nella penombra, almeno in questi primi minuti.

volevo segnalarti questo link che ho trovato ieri, dimmi che ne pensi, cioè se lo reputi risolutivo al caso:
http://talug.altervista.org/guide/hotkeys/index.html

ciò che ho notato è che oltre al pacchetto acpid [già presente in slackware],
richiede anche acpi4asus che non ho trovato tra le installazioni navite di slackware 12.
può essere questa la motivazione per cui il pulsante non è efficace?

nel frattempo cerco di metabolizzare quello che ci siamo detti e vedere se esce qualche "ispirazione".

Grazie

L.S. :thumbright:

P.S.

in quanto all'utilizzo dell'utente root, uso solo questo perchè in fase di installazione è l'unico che è stato creato [so che se ne possono creare diversi]
ma mi chiedo perchè crearli visto che il padrone della macchina sono io e non ho bisogno di crearmi limiti?
So che la creazione di un secondo utente e buona cosa, non per altro per sopperire ai danni che volontariamente o involontariamente si possono verificare
nel portare avanti determinate procedure, accedere da root in casi come questi può essere risolutivo.
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: Tasti speciali su ASUS a6vc A6Q00VC

Messaggioda nuitari » sab mar 22, 2008 12:25

Per quanto riguarda i laptop asus, ti consiglio (come consigliato dal kernel stesso) di non usare il demone acpi standard ma uno ad hoc, asus_acpid. Se non erro c'è sul repository di slacky. Io lo usavo sul mio vecchio asus ed era una bomba! :-)
Avatar utente
nuitari
Linux 2.6
Linux 2.6
 
Messaggi: 777
Iscritto il: dom ott 14, 2007 11:51
Località: San Colombano al Lambro
Slackware: 12.0

Re: Tasti speciali su ASUS a6vc A6Q00VC

Messaggioda lostratega » sab mar 22, 2008 12:40

si l'ho scaricato il pacchetto, quindi dovrei disabilitare dal kernel le voci relativa ad ACPI che ho abilitato e installare quel pacchetto?

Codice: Seleziona tutto
CONFIG_ACPI=y
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_BATTERY=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_VIDEO=y
CONFIG_ACPI_FAN=y
CONFIG_ACPI_DOCK=m
CONFIG_ACPI_BAY=m
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
CONFIG_ACPI_ASUS=y
CONFIG_ACPI_IBM=m
CONFIG_ACPI_IBM_BAY=y
CONFIG_ACPI_TOSHIBA=m
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
CONFIG_X86_PM_TIMER=y
CONFIG_ACPI_CONTAINER=m
# CONFIG_ACPI_SBS is not set


Codice: Seleziona tutto
CONFIG_IBM_ASM=m
CONFIG_SGI_IOC4=m
CONFIG_TIFM_CORE=m
CONFIG_TIFM_7XX1=m
CONFIG_ASUS_LAPTOP=y
CONFIG_MSI_LAPTOP=m
CONFIG_SONY_LAPTOP=m


vanno bene come impostazioni del kernel?

come mai è così difficile per me impostare questi pulsanti?
alla fine non servono a molto ma mi sto incaponendo perchè almeno voglio imparare qualcosa
e del perchè sopratutto non funzionano. Volendo posso far partire un'applicazione scegliento in un altro modo la combinazione dei tasti
impostando magari K>impostazioni>Regionali e accesso facilitato>scorciatoie della tastiera.
Ma così è troppo facile e poi ripeto non capisco perchè non debbano funzionare!!!!!

Accetto qualunque suggerimento:) specialmente da chi ha avuto un asus:)

Grazie
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: Tasti speciali su ASUS a6vc A6Q00VC

Messaggioda lostratega » sab mar 22, 2008 13:59

MI CORREGGO e chiedo scusa per l'errore

quando inserisco lo script datomi da Conraid e premo il pulsante browser
il file firefox.txt viene creato nella directory tmp.
questa condizione PERO' si viene a creare quando lo script viene inserito in un file nativo presente in /etc/acpi e che si chiama acpi_handler.sh
se invece lo script lo inserisco in un file creato di mia mano chiamato in questo caso per convenzione browser.sh messo sempre nella /etc/acpi
e reso eseguibile con il comando chmod +x browser.sh
lo script passatomi da Conraid NON svolge la sua operazione.
se quindi all'interno del file sopra menzionato "acpi_handler.sh" metto anche la voce firefox [cioè che deve eseguire il programma in questione]
il cat /var/log/acpid continua a dirmi:

Codice: Seleziona tutto
[Sat Mar 22 14:25:12 2008] received event "hotkey ATKD 00000051 0000001a"
[Sat Mar 22 14:25:12 2008] notifying client 3251[82:82]
[Sat Mar 22 14:25:12 2008] notifying client 3403[0:0]
[Sat Mar 22 14:25:12 2008] notifying client 3403[0:0]
[Sat Mar 22 14:25:12 2008] executing action "/etc/acpi/acpi_handler.sh hotkey ATKD 00000051 0000001a"
[Sat Mar 22 14:25:12 2008] BEGIN HANDLER MESSAGES

[b](firefox-bin:7345): Gtk-WARNING **: cannot open display:[/b]
[Sat Mar 22 14:25:12 2008] END HANDLER MESSAGES
[Sat Mar 22 14:25:12 2008] action exited with status 1
[Sat Mar 22 14:25:12 2008] completed event "hotkey ATKD 00000051 0000001a"


pur avendo già inserito il comando xhost + localhost
che succede?

L.S.
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Messaggioda conraid » dom mar 23, 2008 20:53

Quel messaggio deriva da una mancanza di permessi.

http://www.google.it/search?q=Gtk-WARNI ... en+display

Per il tuo caso cerca qualche esempio di avvio applicazioni grafiche direttamente da ACPI
Io non ho mai provato, appena posso faccio qualche prova
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current


Torna a Laptop

Chi c’è in linea

Visitano il forum: Bing [Bot] e 3 ospiti

cron