Pagina 1 di 1

sony vaio

Inviato: gio ago 07, 2008 19:02
da sbabaro
ho un vgn-fe41m
sto cercando di configurare tutti i pezzi del portatile
al momento ho 2 problemi:
-il microfono interno
-la luminosità dello schermo

Per il primo problema, ho gslacky installato con pulse audio
se apro il pulse audio volume meter (capture) è evidente che il microfono funziona, anche se non sento nulla (vedo muoversi gli indicatori)
ma qualsiasi programma non riesce ad avere il segnale in ingresso (ho provato sia con skype che con amsn)

Secondo problema
se premo i tasti funzione a schermo vedo su OSD l'immagine della luminosità, ho trovato un how to che mi indica quali sono gli eventi acpi legati, ma non accade nulla. Non riesco neanche a vedere se gli eventi acpi vengono generati

qualcuno con un sony vaio questi problemi li ha risolti?

Re: sony vaio

Inviato: gio ago 07, 2008 19:50
da sbabaro
per la luminosità, intercetto correttamente gli eventi acpi, ma non riesco a cambiare la luminosità dello schermo
provo a dare echo a
/sys/class/backlight/sony/brightness
ma non cambia nulla: sapete dove si imposta la luminosità?

Re: sony vaio

Inviato: gio ago 07, 2008 20:09
da sbabaro
anche in giro ho trovato che basta dare un echo a /sys/class/backlight/sony/brightness per cambiare la luminosità, ma invece nulla
se qualcuno ha un suggerimento......

Re: sony vaio

Inviato: ven ago 08, 2008 10:00
da Bart
Anche io ho un vaio e quel comando funziona. Per la precisione il comando è:

Codice: Seleziona tutto

echo "8" > /sys/class/backlight/sony/brightness
Dove 8 è il grado di luminosità che volete settare (da 0 a 8 ). Questo però solo con gli ultimi kernel. Se usate kernel più datati le cose cambiano e dovete usare dei driver specifici.
Qui ci sono alcune informazioni: http://www.slacky.eu/wikislack/index.ph ... VGN-FS285H

Re: sony vaio

Inviato: mar ago 12, 2008 16:36
da Slippery
Il file /sys/class/backlight/sony/brightness esiste?
Purtroppo i nuovi Vaio montano un chipset per il controllo del brightness differente dai precedenti e sembra che ci sia una sorta di scaricabarile tra nVidia e Sony per chi debba sviluppare i driver (o fornire i dettagli per permettere a qualcuno di implementarli) di questo dispositivo...
Se qualcuno volesse approfondire può cominciare da qui:
http://ubuntuforums.org/showthread.php?t=465491&page=51
http://ubuntuforums.org/showthread.php?t=88611&page=14
http://www.nvnews.net/vbulletin/showthread.php?t=100494&page=6

Re: sony vaio

Inviato: mar ago 19, 2008 14:50
da sbabaro
credo sia la mia situazione, infatti il file brightness c'è, ma non modifica nulla

Re: sony vaio

Inviato: mer ago 20, 2008 2:06
da Roland
Salve ragazzi, è il mio primo post anche se seguo slacky da anni ormai...
Anch'io possiedo un vaio (fe41s), per la luminosità dello schermo ho risolto con smartdimmer usandolo insieme a klcddimmer, una applet per kicker http://klcddimmer.sourceforge.net (sotto gnome uso gnomesmartdimmer, una applet trovata su un forum ubuntu).

Io ho un problema col driver per la webcam che non compila col kernel 2.6.26.2: posso chiedere se qualcuno che usa questo kernel ha lo stesso problema?

Re: sony vaio

Inviato: mer ago 20, 2008 14:29
da sbabaro
sotto 2.6.26 funziona

Re: sony vaio

Inviato: mer ago 20, 2008 15:07
da Roland
io sto avendo problemi con qualsiasi versione degli r5u870 che ho trovato...potresti darmi il link da cui scaricare il sorgente che hai usato tu?

Re: sony vaio

Inviato: mer ago 20, 2008 15:30
da sbabaro
ho utilizzato r5u870-0.11.1, non trovo il link da cui l'ho scaricato, in caso ti posso passare il tar.gz

EDIT

http://mediati.org/r5u870/r5u870-0.11.1.tar.gz

Re: sony vaio

Inviato: mer ago 20, 2008 15:57
da Roland
ok grazie, è lo stesso driver che ho usato io. ricevo gli stessi errori che vengono riportati qui http://bugs.mediati.org/r5u870/issue18 nel terzo post.
Il modulo viene caricato ma quando provo a far partire un programma che usa la webcam (ho installato wxcam dal repository slacky) non parte. In più all'apertura di skype vien fuori una finestra che dice così:

Codice: Seleziona tutto

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel: invalid opcode: 0000 [#1] SMP

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel: Process skype (pid: 3497, ti=f356e000 task=f489b390 task.ti=f356e000)

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel: ------------[ cut here ]------------

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:        00000000 00000001 00000004 00000078 f6d1a800 f8caab80 c0178206 f7560040

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:        00000000 00000001 00000004 00000078 f6d1a800 f8ba77a0 f7090000 f8cafba4

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel: Stack: 00000000 f6d1a808 00000000 00000000 ffffffed f6d1a800 f6f50180 f8ba5088

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<f8ba5088>] videobuf_queue_sg_init+0x38/0x40 [videobuf_dma_sg]

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel: Call Trace:

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<f8cafba4>] usbcam_v4l_open+0x74/0x190 [usbcam]

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c0178206>] cdev_get+0x16/0x60

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<f8ca7c17>] video_open+0x97/0x140 [videodev]

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c0178120>] exact_match+0x0/0x10

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<f8ca7b80>] video_open+0x0/0x140 [videodev]

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c01787f2>] chrdev_open+0xa2/0x180

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c0173cb3>] __dentry_open+0xb3/0x230

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c0173e77>] nameidata_to_filp+0x47/0x60

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c0178750>] chrdev_open+0x0/0x180

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c018088c>] do_filp_open+0x17c/0x7a0

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c01739d2>] get_unused_fd_flags+0x52/0xd0

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c017e5f5>] getname+0xa5/0xc0

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c0173a9c>] do_sys_open+0x4c/0xe0

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c0173bac>] sys_open+0x2c/0x40

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  [<c01030d2>] syscall_call+0x7/0xb

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel:  =======================

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel: Code: 24 04 8b 7c 24 04 05 c4 00 00 00 89 87 c4 00 00 00 89 87 c8 00 00 00 83 c4 0c 5b 5e 5f 5d c3 0f 0b eb fe 0f 0b eb fe 8d 74 26 00 <0f> 0b eb fe 0f 0b eb fe 0f 0b eb fe 8d 74 26 00 0f 0b eb fe 8d

Message from syslogd@darkstar at Wed Aug 20 15:37:39 2008 ...
darkstar kernel: EIP: [<f8b463a0>] videobuf_queue_core_init+0xd0/0xf0 [videobuf_core] SS:ESP 0068:f356fe04


Io purtroppo non sono in grado di interpretarlo....dipende anche ciò dalla webcam?

Re: sony vaio

Inviato: mar set 02, 2008 14:55
da sbabaro
non so come aiutarti

Re: sony vaio

Inviato: dom set 07, 2008 16:46
da Roland
Grazie lo stesso sbabaro, cercando un po' in rete credo di aver capito che i driver attuali non siano compatibili col kernel 2.6.26....anche se tu in effetti sei riuscito ad installarli....non saprei,sarà un problema di configurazione del mio .config

Re: sony vaio

Inviato: lun feb 09, 2009 19:50
da sbabaro
Per la cronaca, il problema della gestione delle hotkeys è risolto, semplicemente non trovavo il file di log, che è /var/log/acpid
Trovato quello ho individuato gli errori nello script e gestito gli eventi