Repository 32bit  Forum
Repository 64bit  Wiki

nvidia schermo nero all'uscita di X

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

nvidia schermo nero all'uscita di X

Messaggioda metallo68 » sab gen 10, 2009 19:26

Su di un portatile Acer Aspire 6930G con scheda video nvidia GeForce 9300M GS 256MB ho installato la slackware 12.2 ed il driver NVIDIA-Linux-x86-180.22-pkg1.run. L'installazione di quest'ultimo è andata a buon fine senza nessun errore.
Il server X si avvia correttamente e funziona bene ed è performante. L'unico problema che si verifica è che quando esco dall'anterfaccia grafica il video resta completamente buio, sia se lancio X con startx che se la avvio direttamente da inittab con runlevel 4.
In alternativa se uso il driver nv funziona tutto ma naturalmente le prestazioni diminuiscono notevolmente.
Allego il mio xorg.conf. Ringrazio tutti anticipatamente per eventuali suggerimenti.
Allegati
xorg.conf.txt
Listato di xorg.conf generato con nvidia-xconfig
(3.15 KiB) Scaricato 30 volte
metallo68
Linux 1.0
Linux 1.0
 
Messaggi: 21
Iscritto il: mar gen 16, 2007 18:39

Re: nvidia schermo nero all'uscita di X

Messaggioda phobos3576 » sab gen 10, 2009 23:14

Se te la cavi con l'inglese, ti conviene mandare un bug-report al forum nVidia Linux; li hai l'eccezionale opportunità di ottenere una risposta, non solo dagli altri forumisti esperti, ma persino dagli sviluppatori del driver.

http://www.nvnews.net/vbulletin/forumdi ... forumid=14

Per avere una risposta comunque è fondamentale generare il bug-report; a tale proposito, dopo che si verifica il problema, devi loggarti come root e eseguire il comando:
Codice: Seleziona tutto
sh nvidia-bug-report.sh

Il relativo file credo venga salvato in /root

Il problema è dato dal fatto che devi riuscire a generare questo file dopo che Xorg è andato in crash (generalmente, in casi del genere il kernel sta continuando a funzionare); a tale proposito, ti puoi connettere da un altro PC, oppure, se ti accorgi che la tastiera sta funzionando, puoi provare a digitare i comandi alla cieca e poi riavviare il computer.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: nvidia schermo nero all'uscita di X

Messaggioda metallo68 » dom gen 11, 2009 10:59

Ho seguito il tuo consiglio collegandomi in ssh e generando il file e poi lo pubblicato sul forum e spedito a
linux-bugs@nvidia.com.

Grazie. :)
metallo68
Linux 1.0
Linux 1.0
 
Messaggi: 21
Iscritto il: mar gen 16, 2007 18:39

Re: nvidia schermo nero all'uscita di X

Messaggioda phobos3576 » lun gen 12, 2009 0:22

Metallo68, per curiosità stavo leggendo il bug-file che hai generato ed ho notato alcuni errori segnalati nel LOG; in particolare, l'installer dice di aver trovato un vecchio driver e di aver tentato di rimuoverlo riuscendoci solo parzialmente in quanto la precedente installazione aveva subito modifiche impreviste.
Quindi, è probabile che adesso nel tuo sistema siano presenti file del vecchio e del nuovo driver nVidia!

Prima di ogni installazione di un nuovo driver nVidia, è consigliabile sempre eseguire (da root e dalla modalità testuale) il comando:
Codice: Seleziona tutto
nvidia-installer --uninstall

Il problema è che adesso devi riuscire ad eliminare manualmente anche i vecchi file; da qualche parte ci dovrebbero essere le istruzioni su come procedere in un caso del genere.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: nvidia schermo nero all'uscita di X

Messaggioda metallo68 » mar gen 13, 2009 10:33

Ho reinstallato la slackware su un'altra partizione. Ma il problema ello schermo nero all'uscita di X persiste. Inoltre i font all'interno di KDE3 si vedono male. :(
metallo68
Linux 1.0
Linux 1.0
 
Messaggi: 21
Iscritto il: mar gen 16, 2007 18:39

Re: nvidia schermo nero all'uscita di X

Messaggioda phobos3576 » mer gen 14, 2009 22:08

metallo68 ha scritto:Ho reinstallato la slackware su un'altra partizione. Ma il problema ello schermo nero all'uscita di X persiste. Inoltre i font all'interno di KDE3 si vedono male. :(


Il problema dei font è legato al fatto che nella Slackware sono disabilitate di default alcune funzionalità coperte da copyright; in particolare, il "bytecode" è copyright Apple, mentre il "subpixel hinting" è copyright Microsoft.
Se vuoi abilitare queste funzionalità devi ricompilare il package freetype che trovi nel DVD (o nel sito ufficiale di Slackware) in /source/l/freetype.
Scarica tutta la directory nel tuo hard disk ed edita il file freetype.SlackBuild; al suo interno devi deccommentare le due righe:
Codice: Seleziona tutto
#zcat $CWD/freetype.bytecode.interpreter.diff.gz | patch -p1 --verbose || exit 1

e
Codice: Seleziona tutto
#zcat $CWD/freetype.subpixel.rendering.diff.gz | patch -p1 --verbose || exit 1

Da utente root ricompila il tutto eseguendo lo SlackBuild; poi, esci in modalità testo, disinstalla il vecchio freetype e installa il nuovo.
Una volta tornato in modalità grafica, dal centro di controllo KDE abilita l'antialiasing e il subpixel hinting per i font.

Puoi migliorare ulteriormente la situazione installando i font TrueType di Windows; nel forum trovi diversi tutorial.

Per quanto riguarda il crash di X, prova ad installare un driver nVidia più vecchio.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron