Repository 32bit  Forum
Repository 64bit  Wiki

Dopo aver installato driver il wifi non funziona

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Dopo aver installato driver il wifi non funziona

Messaggioda Dadde » sab mag 15, 2010 8:49

ciao raga ho slackware 13 ed ho installato i driver della scheda wireless dal sito della broadcom quando vado a fare iwlist s mi dice

Codice: Seleziona tutto
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Network is down


perchè?
Dadde
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: gio feb 04, 2010 15:44
Slackware: 13.0

Re: Dopo aver installato driver il wifi non funziona

Messaggioda stan » sab mag 15, 2010 9:12

Hai cercato online?
Hai caricato il modulo?
Che dice dmesg?
Che rete è?
Avatar utente
stan
Linux 2.6
Linux 2.6
 
Messaggi: 524
Iscritto il: lun dic 25, 2006 11:55
Località: Bs
Slackware: 12.1
Kernel: 2.6.xx
Desktop: Kde3

Re: Dopo aver installato driver il wifi non funziona

Messaggioda Ansa89 » sab mag 15, 2010 10:25

Che driver usi?
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2623
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: Dopo aver installato driver il wifi non funziona

Messaggioda Dadde » sab mag 15, 2010 11:01

premetto che prima avevo slackware 32 bit ieri ho formattato tutto ho messo slackware a 64 bit e penso di aver installato i driver giusti che ho preso qui: http://wireless.kernel.org/en/users/Drivers/b43

e ho scaricato questi: You are using the deprecated bcm43xx driver
Dadde
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: gio feb 04, 2010 15:44
Slackware: 13.0

Re: Dopo aver installato driver il wifi non funziona

Messaggioda Ansa89 » sab mag 15, 2010 12:01

1) I b43 sono sempre stati buggati e non stabili.
2) I b43 sono già inseriti nei kernel più recenti, quindi dovresti già averli di default.
3) Il problema potrebbe essere legato al firmware per la tua schede che manca. In questo caso devi usare b43fwcutter per estrarlo dai driver di win e copiarlo in "/lib/firmware".

Che kernel stai usando?
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2623
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: Dopo aver installato driver il wifi non funziona

Messaggioda Dadde » sab mag 15, 2010 12:06

gli stessi driver prima funzionavano comunque ho questo kernel 2.6.29.6
Dadde
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: gio feb 04, 2010 15:44
Slackware: 13.0

Re: Dopo aver installato driver il wifi non funziona

Messaggioda Ansa89 » sab mag 15, 2010 13:20

Ma è quello di default o l'hai ricompilato tu?
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2623
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: Dopo aver installato driver il wifi non funziona

Messaggioda Dadde » sab mag 15, 2010 16:29

di default
Dadde
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: gio feb 04, 2010 15:44
Slackware: 13.0

Re: Dopo aver installato driver il wifi non funziona

Messaggioda phobos3576 » sab mag 15, 2010 18:06

Prima di ricompilare il kernel, prova con un:
Codice: Seleziona tutto
ifconfig wlan0 up
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Dopo aver installato driver il wifi non funziona

Messaggioda Dadde » sab mag 15, 2010 18:49

da errore infatti ifconfig non vede wlan0

però quando spengo il pc esce scritto shutting down b43 quindi i driver sembrano giusti e anche che la scheda funziona ma è come se non fosse attivata
ditemi se sbaglio .
Dadde
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: gio feb 04, 2010 15:44
Slackware: 13.0

Re: Dopo aver installato driver il wifi non funziona

Messaggioda phobos3576 » sab mag 15, 2010 18:59

Dopo il boot, apri il file /var/log/dmesg e controlla se trovi errori legati alla tua scheda wireless.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Dopo aver installato driver il wifi non funziona

Messaggioda erio » sab mag 15, 2010 19:49

se c'è nella slackware 64 installa wicd,con i driver gia installati, non dovresti avere problemi a farla funzionare
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1083
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde


Torna a Laptop

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 1 ospite