Repository 32bit  Forum
Repository 64bit  Wiki

ASUS 3500D e modem

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

ASUS 3500D e modem

Messaggioda schnauzer » dom ago 07, 2005 14:49

Ho installato la slackware 10.1 sul mio ASUS L3500D con kernel 2.4.29

Il driver del modem che funzionava con la mandrake è di smartlink, versione slmodem2.9.10, l'ultima.

HO compilato e installato con successo, kppp rivela e appronta il modem (comandi ATX3DT come sempre....) ma al tentativo di connessione il log è vuoto e non funziona.

Qualcuno sa come faccio ad andare in internet?

Devo usare un kernel 2.6?
schnauzer
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: mar mag 04, 2004 23:00

Messaggioda napoleone1981 » dom ago 07, 2005 14:55

Posta il comando che dai a slmodemd così vediamo se cìè qualche errore lì...
Avatar utente
napoleone1981
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: mer ago 25, 2004 23:00
Località: Sant'Elena

Messaggioda schnauzer » dom ago 07, 2005 18:22

Ho provato a installare il kernel 2.6 e a ricompilare i drivers...stavolta non li carica proprio e da gli stessi errori che ritrovo con tutte le altre distribuzioni...

ossia, make e make install sono regolari e vanno ala grande. Quando faccio modprobe slamr, mi da errore.

[root@localhost ~]# modprobe slamr
FATAL: Error inserting slamr (/lib/modules/2.6.11-6mdk/extra/slamr.ko): Unknown
symbol in module, or unknown parameter (see dmesg)

penso sia un problema di driver con kernel successivi al 2.6.8

Nel frattempo io ho seguito le istruzioni della Slackware4Dummies per instalare il nuovo kernel e il vecchio 2.4 non riesco a ricaricarlo...

Stasera rimonto la vecchia mdk 10.1 che fino ad oggi è l'unica con cui quel f****o modem funziona...

anche la debian fa casino...

Riassumendo: tale modem non ha mai funzionato con i smlink con il kernel 2.4, ma solo con i 2.6 che però mi restituiscono tale errore se sono troppo recenti...bel problema.
schnauzer
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: mar mag 04, 2004 23:00

Messaggioda schnauzer » mar ago 16, 2005 10:47

Ultime novità in merito al modem interno in oggetto: ferragosto hacker :-)

In questi due giorni ho ritentato a reinstallare la slackware 10.1 sul mio ASUS L3500D. Ho provato a usare il kernel 2.4.29 di default (bareacpi.i) e a installare il driver smlink-2.7.14. Il modem funziona nel senso che carica senza problemi i moduli nel kernel, usando kppp configura correttamente comandi (con i soliti ATX3DT al posto di ATDT) e all'interrogazione risulta pronto all'uso con tutti gli ATI restituiti giusti.

Alla connessione però...il log compone ma non restituisce risposta. Evidentemente è un problema di driver.

Secondo tentativo: disinstallazione slmdm e installazione di pctel-0.9.6 che funzionava con la mdk che usava il kernel 2.4
Niente da fare, il modem risulta costantemente occupato...

Altro tentativo drastico: installazione con compilazione manuale di un kernel 2.6.8 (chè è lo stesso con cui la mdk 10.1 riesce a far funzioinare il modem...chiaro, questo è un kernel pulito, senza patch e altro).

Reinstallo completamente la slackware 10.1 e compilo il nuovo kernel con tutto quel che occorre. Quindi provo la compilazione del driver slmodem2.9.10 che su mandrake funziona. La fase di make si arresta bruscamente quando mi da un errore nella directory scripts dei sorgenti kernel...evidentemente il kernel di mandrake è foraggiato con delle patch particolari che permettono l'uso del mio modem...dannatamente proprietario.

Da notare comunque che con tali drivers che sbandierano la compatibilità su kernel 2.4 e 2.6, in realtà mai hanno funzionato con kernel 2.4 in nessuna distribuzione che ho provato. Il mio portatile ha il modem funzionante solo con mdk 10.1 con kernel 2.6.8 suo, basta.

Fra una slackware e l'altra ho provato anche una SuSE 9.2 senza successo....penso di non aver mai perso così tanto tempo a causa di un modem interno.

Per chiudere, ho dovuto rimettere la mdk 10.1 con cui su tale portatile riesco a fare tutto...peccato perchè la slacky funziona perfettamente...a parte il modem.

Se qualcuno riesce a usare i driver smartlink su portatili ASUS con la slackware 10.1 mi faccia sapere per piacere come fa, sono curioso di capire cosa non funziona nella mia macchina.
schnauzer
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: mar mag 04, 2004 23:00


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron