Repository 32bit  Forum
Repository 64bit  Wiki

Problema con kernel bare acpi

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema con kernel bare acpi

Messaggioda Jack » ven set 02, 2005 7:41

Salve ragazzi, ho installato la slack 10.1 sul mio bel laptop, con supporto per l'acpi!

Mi sono trovato in difficoltà quando ho installato il kernel 2.6.12 (se nn erro, ma comunque stiamo la!) Solo che mi sono accorto (niubbata esagerata) che il supporto per acpi non è attivo automaticamente!

Dato che mi serve per spremere il mio centrino al max possibile, ho dovuto rimettere il 2.4, ma le differenze sono troppe col 2.6, primo il supporto usb!

Mi sapete indicare un howto, che mi guidi abbastanza passo passo? Dato che di Linux nn sono molto pratico?

Thx
Avatar utente
Jack
Linux 1.0
Linux 1.0
 
Messaggi: 20
Iscritto il: mar set 21, 2004 23:00

Messaggioda Rocky » ven set 02, 2005 8:24

Vai nella sezione Howto c'e la documentazione su come compilare e ricompilare il kernel , se vuoi la configurazione del kernel in italiano vai sul sito del progetto configurazione kernel in italiano http://massimo.solira.org/pcikl/ e scaricati la versione per il tuo kernel , dopodichè dovresti compilarti il kernel attivando l'acpi e altre cose che ti servono. ciao
Avatar utente
Rocky
Linux 2.0
Linux 2.0
 
Messaggi: 141
Iscritto il: ven set 24, 2004 23:00
Località: Torino
Nome Cognome: Rocco Garzia
Slackware: 12
Desktop: window maker

Messaggioda manny » ven set 02, 2005 8:24

Supponendo che:

-acpi sia installato
-che /etc/rc.d/rc.acpid sia 755
-ricompilato il kernel col supporto acpi (ma tu usi bare.acpi)

e non funzionasse ancora, prova a mettere

append = "acpi=force"

in lilo.

Col mio notebook kernel 2.4.29 ha funzionato, senza niente da fare.

Ciao,
Manny
Avatar utente
manny
Linux 2.4
Linux 2.4
 
Messaggi: 277
Iscritto il: mer ott 29, 2003 0:00
Slackware: 13.1 (fisso)
Kernel: 2.6.33.4
Desktop: kde
Distribuzione: Debian 5 (notebook)

Messaggioda MAT » ven set 02, 2005 12:11

Nel config del 2.6.12.3 di Pat non è attivo nemmeno alsa :shock: pertanto ti consiglio di scaricare i sorgenti del kernel e, partendo da quella configurazione, aggiungere le opzioni che ti interessano, salvare il .config e ricompilare. Alla fine modifica /etc/lilo.conf, dai un lilo -v e riavvia.

P.S. mantieni SEMPRE un kernel funzionante
Avatar utente
MAT
Linux 3.x
Linux 3.x
 
Messaggi: 1242
Iscritto il: mer mar 09, 2005 0:00
Località: Vignola, Modena
Nome Cognome: Matteo Magni
Kernel: 2.6.20
Desktop: Fluxbox
Distribuzione: Gentoo

Messaggioda brancalessio » sab set 03, 2005 13:35

Con

Codice: Seleziona tutto
append = "apm=off acpi=on"


in lilo.conf dovresti ottenere quello che vuoi...
brancalessio
Linux 2.4
Linux 2.4
 
Messaggi: 316
Iscritto il: mar giu 21, 2005 23:00
Località: Modena/Bari

"LCD ON" "LCD OFF"

Messaggioda Corgan » dom ott 30, 2005 16:37

Salve ho installato slackware 10.2 con il kernel 2.4.31 e precedentemente con il 2.6.*, sul mio notebook asus con scheda video radeon 9700 128mb. Mi appare in continuazione sullo schermo "LCD ON" e dopo un pò "LCD OFF", indirizzatemi voi è un problema fastidioso più del softmodem che non funziona :cry: il modello del portatile è asus a6790GALH
Corgan
Linux 1.0
Linux 1.0
 
Messaggi: 5
Iscritto il: dom ott 30, 2005 16:24
Slackware: 14.1 64bit
Kernel: 3.10.17
Desktop: KDE

Messaggioda Raistlin84 » dom ott 30, 2005 18:18

Il kernel sui portatili è sempre bene ricompilarlo secondo me.
Se vuoi il 2.6.x devi scaricarti i sorgenti e compilarlo così abiliti tutte le cosette che ti servono e alleggerisci togliendo il resto.
Anche io sul mio volevo trovare un .config adatto e scricarlo senza quindi dover mettermi lì a studiarci un po' [era la prima volta che lo compilavo].Ora invece mi ci diverto a compilare il Kernel.
Ti condiglio davvero di scaricare i sorgenti e compilarlo secondo le tue esigenze.E poi nel 2.6 ci sono talmente tanti commenti per ogni voce che è davvero semplice riuscirci.
E poi se te lo compili lo spremi davvero al massimo il tuo Centrino,ma soprattutto puoi configurarlo per risparmiare di brutto la batteria!
Ho sempre sentito dire che Linux ciucia un po' più di batteria di win a causa dell'acpi non perfetta,ma da quando sono usciti gli ultimi Kernel,con la mia configurazione mi dura come su win,se non qualcosa di più.
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron