Pagina 1 di 1

Aiuto Batteria

Inviato: ven ott 21, 2005 21:30
da gek
Ho appena installato la slackware 10.2 con kernel 2.6.13 sul mio portatile e fin qui tutto ok... L'unico problema e' che non avendo ma avuto un portatile non so come configurare la mia la slack in modo che mi visualizzi la quantita' di carica della batteria. Ho gia' attivato l'apm ma mi richiede di attivare l'acpi e non so proprio come fare. Grazie a tutti.

Inviato: ven ott 21, 2005 22:07
da hendrixiano
devi ricompilare il kernel con l'acpi attivo.

Inviato: ven ott 21, 2005 23:02
da gek
Allora dove posso trovare una guida (in italiano) su come ricompilare il kernel?

Inviato: sab ott 22, 2005 0:40
da lunos
da root:
modprobe ac
modprobe battery

questi due comandi li inserisci poi nel file /etc/rc.d/rc.modules per far si che vengano caricati all'avvio. sul laptop toshiba di un mio amico, su cui abbiamo appena installato la 10.2 funziona benissimo...
ciao

Inviato: sab ott 22, 2005 9:18
da elettronicha
Gek, se fossi stato più attento e avessi usato la funzione" cerca", avresti trovato almeno un topic in cui si parla in dettaglio di quello che cerchi e avresti trovato anche la guida. Perché non lo hai fatto? Avresti risolto il tuo problema praticamente subito. 8)
Non serve ricompilare il kernel 2.6.13 per la tua richiesta, segui l'ottimo consiglio di lunos.

Ciao.

Inviato: sab ott 22, 2005 10:34
da Bart
lunos ha scritto:da root:
modprobe ac
modprobe battery

questi due comandi li inserisci poi nel file /etc/rc.d/rc.modules per far si che vengano caricati all'avvio. sul laptop toshiba di un mio amico, su cui abbiamo appena installato la 10.2 funziona benissimo...
ciao
Io ti consiglio di evitare i moduli e di mettere tutto staticamente. Che senso ha caricare ogni volta dei moduli che tanto di servono sempre.

Codice: Seleziona tutto

# Power management options (ACPI, APM)
# ACPI (Advanced Configuration and Power Interface) Support
CONFIG_ACPI=y
CONFIG_ACPI_BOOT=y
CONFIG_ACPI_INTERPRETER=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SLEEP_PROC_FS=y
# CONFIG_ACPI_SLEEP_PROC_SLEEP is not set
CONFIG_ACPI_AC=y
CONFIG_ACPI_BATTERY=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_VIDEO=y
# CONFIG_ACPI_HOTKEY is not set
CONFIG_ACPI_FAN=y
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_IBM is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_BUS=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_PCI=y
CONFIG_ACPI_SYSTEM=y
# CONFIG_ACPI_CONTAINER is not set
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_SPEEDSTEP_CENTRINO_ACPI=y
# CONFIG_X86_ACPI_CPUFREQ_PROC_INTF is not set
CONFIG_PNPACPI=y
# CONFIG_SERIAL_8250_ACPI is not set
Queste sono le impostazioni acpi del mio kernel sul portatile. Altra cosa: se usi acpi devi eliminare apm, perchè uno sclude l'altro.

Inviato: dom ott 23, 2005 13:07
da gek
Inanzi tutto volevo ringraziarvi tantissimo per l'aiuto che mi avete dato! Alla fine ho optato per la soluzione dei modprobe... Magari mi rallenta un po' l'avvio ma funziona.
Visto che sono qui vi chiedo ancora due cose: la prima, forse un po' piu' semplice, e' come posso attivare la rotellina del mouse usb sulla mia slack?
E la seconda e': ho qualche possibilitia' di configurare la mia scheda audio usb? Se si come?
Ancora grazie.

Inviato: dom ott 23, 2005 13:34
da Paoletta
la rotellina del mouse usb sulla mia slack?

per questo esiste la guida slackware for dummies....cerca, la trovi sul sito