Repository 32bit  Forum
Repository 64bit  Wiki

slmodem+2.6.13+slack 10.2

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Messaggioda simone » ven nov 04, 2005 18:09

Ok, con l'ultimo driver messo "probabilmente" a punto da chi ne sa veramente molto segnalato da Firetux il modulo slamr si compila e si carica correttamente come alla vecchia maniera.
Ora stranamente il test di kppp mi da "modem pronto" ma alla fine dei suoi test le varie righe dei comandi (ATI1...) sono vuote.

ma questo FORSE è un altro problema.
ci siamo quasi.

ciao
Simone
Avatar utente
simone
Linux 2.0
Linux 2.0
 
Messaggi: 100
Iscritto il: sab lug 24, 2004 23:00
Località: Cremona

Messaggioda simone » sab nov 05, 2005 0:15

:D :D :D :D :D FUNZIONAAAAAAAAA :D :D :D :D :D :D

confermo come da post precedente che i driver slmodem-2.9.11-20051101 funzionano come alla vecchia maniera compilando il modulo "slamr".
il problema dei comandi del modem era una mia disattenzione (non avevo controllato il link simbolico /dev/modem a che cosa puntava).

inutile dire che sto postando connesso tramite lo smartlink con kernel 2.6.13 :D :D :D

ciao e come sempre grazie a tutti

Simone
Avatar utente
simone
Linux 2.0
Linux 2.0
 
Messaggi: 100
Iscritto il: sab lug 24, 2004 23:00
Località: Cremona

Messaggioda Firetux » sab nov 05, 2005 9:42

ottimo :D
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda teme » mar dic 06, 2005 21:31

a me con kernel 2.6.14 continua a non andare...Ho provato alla vecchia maniera ma ho problemi qui:
/usr/sbin/slmodemd --country=ITALY /dev/slusb0

bash-3.00# /usr/sbin/slmodemd --country=ITALY /dev/slusb0
error: mdm setup: cannot open dev `/dev/slusb0': No such device or address
error: cannot setup device `/dev/slusb0'

Praticamente sembra non vedermi il dev/slusb0.
Devo provare con ALSA? Io quel modulo intel...ce l'ho!
Avatar utente
teme
Linux 2.4
Linux 2.4
 
Messaggi: 362
Iscritto il: mar gen 27, 2004 0:00

Messaggioda teme » mer dic 07, 2005 13:12

Problema risolto, casini con i moduli (come al solito faccio sempre casini). Ora mi compone il numero ma quando mi collego ho sempre NO CARRIER, (prima avevo NO DIAL, ma ho risolto aggiungendo ATX3 alla stringa del modem. che posso fare?
Avatar utente
teme
Linux 2.4
Linux 2.4
 
Messaggi: 362
Iscritto il: mar gen 27, 2004 0:00

Messaggioda teme » gio dic 08, 2005 15:23

Problema apparentemente risolto facendo qualche tentativo, ma può essere che il 50% dei miei tentativi di connessione fallisce con NO CARRIER?
Avatar utente
teme
Linux 2.4
Linux 2.4
 
Messaggi: 362
Iscritto il: mar gen 27, 2004 0:00

Messaggioda tux » dom gen 08, 2006 1:52

sono riuscito a configurare il modem il sistema lo vede, ma non funge lo stesso.

All'avvio di slmodemd ho questo errore:

slmodemd -a hw:0
error: mixer setup: Off-hook switch not found for card hw:0
SmartLink Soft Modem: version 2.9.11 Jan 8 2006 00:56:42
symbolic link `/dev/ttySL0' -> `/dev/pts/3' created.
modem `hw:0' created. TTY is `/dev/pts/3'
Use `/dev/ttySL0' as modem device, Ctrl+C for termination.

come posso rimediare?
Avatar utente
tux
Linux 2.4
Linux 2.4
 
Messaggi: 202
Iscritto il: mer lug 21, 2004 23:00

Precedente

Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti