Repository 32bit  Forum
Repository 64bit  Wiki

Firmware Centrino wireless

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Firmware Centrino wireless

Messaggioda Raistlin84 » ven nov 11, 2005 16:48

Scusate ma non so davvero dove trovare il firmware.
Pensavo fosse qui: Firmware
Ma non me lo fa scaricare... mi sembra assurdo,ma sembra impossibile da trovare questo firmware..
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia

Messaggioda Firetux » ven nov 11, 2005 16:57

infatti è li! selezioni la versione del firmware...nella pagina successiva ci sono le condizioni, scorri fino in fondo e clicki su "I Agree" e parte il dowload :wink:
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda Raistlin84 » ven nov 11, 2005 17:27

Il download non mi parte!Nè con firefox,nè opera,nè IE, etc.. Ho provato con tutti browser pensando che magari fosse un problema di browser.
A te lo scarica?
Se hai il firmware per ipw2200 me la passeresti o via mail o via msn? Grazie.
raistlin84@tin.it per entrambi.
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia

Messaggioda prometeo79 » ven nov 11, 2005 17:38

Ciao
Stavo giusto per aprire un topic sulla scheda intel. Allora ho scaricato e installato driver e fw, ho dato modprobe ipw2200 e mi ha caricato il modulo. Il problema ora è che non sempre mi rileva la scheda, cioè ha volte (ma di rado) me la rileva su eth1 e allora si attiva, altre mi rileva solo eth0 dove ho la scheda di rete e basta. Credo che il problema stia nel fatto che non punta direttamente a eth1 ma vada a rilevare le periferiche a caso. Sapete darmi consigli?
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda prometeo79 » ven nov 11, 2005 18:28

Come non detto. Ho rimosso il modulo e l'ho reimpostato con modprobe ipw2200 eth1
EDIT: Non ha funzionato
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda Raistlin84 » ven nov 11, 2005 18:48

Allora ho messo il firmware giusto, in /lib/firmware
dmesg mi da questo errore:
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.0
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ACPI: PCI Interrupt 0000:06:02.0[A] -> GSI 22 (level, low) -> IRQ 19
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw-2.2-boot.fw load failed: Reason -2
ipw2200: Unable to load firmware: 0xFFFFFFFE
ipw2200: failed to register network device
ACPI: PCI interrupt for device 0000:06:02.0 disabled
ipw2200: probe of 0000:06:02.0 failed with error -5
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia

Messaggioda mach » ven nov 11, 2005 19:49

Come ti dice nel messaggio, lui cerca il file 'ipw-2.2-boot.fw', ma se non erro gli ultimi firmware sono chiamati 'ipw-2.4-*': io ho risolto creando dei semplici link simbolici per ognuno dei file:
Codice: Seleziona tutto
ln -s ipw-2.2-boot.fw ipw-2.4-boot.fw
Avatar utente
mach
Linux 2.0
Linux 2.0
 
Messaggi: 104
Iscritto il: mer apr 28, 2004 23:00
Località: Racconigi (CN)

Messaggioda prometeo79 » sab nov 12, 2005 13:20

Ciao
Vi spiego idue problemi che ho con la scheda. I driver della scheda mi funzionano correttamente ma per fargli riconoscere il modulo come eth1 devo rimouverlo e reinserirlo fin quando non decide di connettersi a eth1, come faccio a dirgli di impostarsi automaticamente su eth1?
Secondo problema. Una volta che riesco a far riconoscere la scheda mi riconosce e pinga i pc della rete ma se provo a uscire dalla lan non c'è verso. C'è qualcosa che devo abilitare?
Grazie
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda Firetux » sab nov 12, 2005 14:10

per il primo problema metti una cosa di questo tipo in /etc/modprobe.conf
Codice: Seleziona tutto
alias eth0 NOME_MODULO

per il secondo problema...in che senso non riesci ad uscire dalla lan? non riesci a pingare ip che non appartengano alla tua rete?
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda prometeo79 » sab nov 12, 2005 14:24

Codice: Seleziona tutto
alias eth1 ipw2200


Così non và
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda mach » sab nov 12, 2005 14:35

pinga i pc della rete ma se provo a uscire dalla lan non c'è verso

Supponendo che 192.168.0.1 sia l'indirizzo del tuo router
Codice: Seleziona tutto
route add default gw 192.168.0.1
Avatar utente
mach
Linux 2.0
Linux 2.0
 
Messaggi: 104
Iscritto il: mer apr 28, 2004 23:00
Località: Racconigi (CN)

Messaggioda prometeo79 » sab nov 12, 2005 16:13

Grande! Era proprio lui. Il problema ora è un'altro.
Di default mi abilita la scheda di rete, il che mi va bene. Se voglio passare al wireless devo dare ifconfig eth0 down, anche questo mi va bene. Se voglio passare ancora a ethernet do ifconfig eth0 up ma devo anche ridare il route del gataway. Perchè?
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda Raistlin84 » sab nov 12, 2005 19:07

Allora con il kerneli nuovo 2.6.14, il wireless sui centrino sembra esser una formalità!!!
Infatti mi funziona tutto!
Il problema è che mi ha messo la scheda wifi come eth0, ma eth0 era la mia scheda di rete 10/100.
Esiste un modo per modificare questa cosa?
Vorrei poter scegliere che connessione usare, del tipo eth0 la scheda e wlan0 il wireless.Però di default, cioè appena carica il firmware in /lib/firmware, eth0 diventa la scheda wireless mentre prima di mettere il firmware era la scheda 10/100.
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia

Messaggioda Raistlin84 » sab nov 12, 2005 19:16

In pratica ho provato e... uffa!!! Se c'è il firmware non vede più la scheda di rete, ma solo il wireless.Ho provato a disattivare la scheda wireless tramite il pulsante posto di lato, ma ccomunque non la vede la schede di rete.
In pratica col firmware su mi vede solo il wireless! Perchè?
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia

Messaggioda Raistlin84 » sab nov 12, 2005 19:56

Scusate apro un nuovo post,qui sono parecchio off topic.

Comunque per chi è interessato il nuovo kernel supporta ieee802.11 e ipw2200 alla grande.
Basta mettere il firmware in /lib/firmware, richiede la versione 2.2, ma potete usare anche la 2.4. Basta rinominarli cambiando in 2.2 opure create del link simbolici al 2.4.
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron