Repository 32bit  Forum
Repository 64bit  Wiki

Come creo wlan0 e ci associo la scheda wireless?

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Come creo wlan0 e ci associo la scheda wireless?

Messaggioda Raistlin84 » sab nov 12, 2005 20:01

Allora la scheda wireless del centrino funziona adesso.
Tuttavia dopo che ho messo il firmware la mia scheda di rete 10/100 che era eth0 è scomparsa. Infatti eth0 è diventata il device del scheda wireless.
Vorrei poter averle entrambe e non dover togliere il firmware per riabilitare la scheda di rete 10/100, e rimetterlo per riabilitare il wireless.In pratica vorrei un eth0 e un wlan0.
Però non ho idea di come fare.Il problema è che praticamente entrambe le schede si identificano con lo stesso device e la scheda wireless ha la meglio.
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia

Messaggioda Firetux » dom nov 13, 2005 11:16

in /etc/modprobe.conf
Codice: Seleziona tutto
alias wlan0 ipw2200
options ipw2200 ifname = wlan0


dopo di che carichi il modulo ipw2200
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda Raistlin84 » dom nov 13, 2005 11:39

Adesso eth0 è della scheda di rete, ma non esiste più l'interfaccia per la scheda wireless.
Infatti non mi dà wlan0. In pratica dovrei creare wlan0.Come faccio?

Edit: dmesg dice:
ifname: string parameter expected
ipw2200: `' invalid for parameter `ifname'

Si dovrebbe riferire a quello che ho scritto in modprobe.conf.Io ho copiato pari pari quello che hai scritto nel file vuoto modprobe.conf.
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia

Messaggioda Firetux » dom nov 13, 2005 11:44

togli lo spazio prima e dopo l'uguale
Codice: Seleziona tutto
alias wlan0 ipw2200
options ipw2200 ifname=wlan0

così dovrebbe andare...vado a memoria
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda Raistlin84 » dom nov 13, 2005 12:04

Ok, ora me la vede come wlan0!
Ma non riesco a fargli acquisire l'IP.Mentre eth0 la scheda 10/100 prende l'ip.
Ho provato a lanciare rc.inet1 e con questo eth0 prende l'ip ma non wlan0.
Poi dhcpd wlan0 ma niente.
Ma devo modificare qualcosa?perchè ho provato a lanciare rc.wireless,e dice che si può lanciare solo da rc.inet1.
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia

Messaggioda prometeo79 » dom nov 13, 2005 14:04

Io ho provato come dici tu firetux ma mi da quest'errore quando carico il modulo
Codice: Seleziona tutto
 FATAL: Error inserting ipw2200 (/lib/modules/2.6.12.4/kernel/drivers/net/wireless/ipw2200.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda Raistlin84 » dom nov 13, 2005 16:01

A quanto pare alla fine ce l ho fatta...Penso che festeggerò, perchè è da quando ho comprato il portatile che desidero averci sopra la slackware con tutte le periferiche funzionanti.

Scrivo come ho fatto almeno qualcuno col mio stesso problema magari qui trova le risposte. Sicuramente per questo risultato devo ringraziare firetux, senza di lui non avrei fatto niente.

Allora ho compilato il kernel 2.6.14 con il supporto ai driver ieee802.11 e ipw2200.
Dopo ho messo nella directory /lib/firmware il firmware 2.4, però richiede il 2.2, quindi ho rinominato i file appunto in xxx2.2xxx.
Poi siccome la scheda wireless mi mangiava l'altra scheda di rete in /etc/modprobe.conf ho scritto:
alias eth3 ipw2200
options ipw2200 ifname=eth3
Sono andato in /etc/rc.d/rc.inet1.conf e all'interfaccia eth3 ho dato usedhcp="yes"

Adesso tutto funziona correttamente. Quindi i driver inclusi nel nuovo kernel sono soddisfacenti, anche se ho notato una stabilità nel segnale abbastanza inferiore rispetto a windows.

Grazie davvero firetux!
Avatar utente
Raistlin84
Linux 2.6
Linux 2.6
 
Messaggi: 542
Iscritto il: dom mar 27, 2005 23:00
Località: Pistoia

Messaggioda Firetux » dom nov 13, 2005 17:48

@prometeo79:
come dice l'errore guarda cosa ti da dmesg e postacelo

@Raistlin84:
di niente! siamo qui apposta per aiutarci l'uno con l'altro! :D
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda prometeo79 » lun nov 14, 2005 10:09

Ok. Ecco il dmasg
Codice: Seleziona tutto
ipw2200: failed to send TX_POWER: Command not found
ipw2200: failed to send TX_POWER: Command not found
ipw2200: failed to send TX_POWER: Command not found
ipw2200: failed to send TX_POWER: Command not found
ipw2200: failed to send TX_POWER: Command not found
ipw2200: Unable to initialize device after 5 attempts
ipw2200: failed to register network device
ipw2200: probe of 0000:00:09.0 failed with error -5
ieee80211_crypt: unregistered algoritm 'NULL'
ieee80211_crypt: registered algoritm 'NULL'
ieee8011: 802.11 data/management/control stack 1.1.6
ieee80211: Copyright (con i deti del copyright)
ipw2200: Unknow parameter 'ifname'
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda Firetux » lun nov 14, 2005 10:19

anche Raistlin84 aveva il tuo stesso errore. Guarda sopra. La prima volta ho dato la soluzione "sbagliata".
la soluzione corretta è senza gli spazi prima e dopo l' = di ifname
Codice: Seleziona tutto
alias wlan0 ipw2200
options ipw2200 ifname=wlan0
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda prometeo79 » lun nov 14, 2005 10:28

Ho letto e avevo comunque già provato con e senza spazi e anche mettendo la stringa options sulla stessa riga di alias. Tra le faq del sito dei driver ho letto che potrebbe dipendere dal fatto che bisogna caricare il modulo firmware_class ma in maniera modulare non ce l'ho e ricompilando no sò dove andarlo a cercare
Codice: Seleziona tutto
 When I try and run insmod ipw2200 I get -1 Unknown symbol in module.
    When using insmod you need to manually load any dependency modules (the alternative is to install the module into the correct location and use modprobe). The specific module you may need to load varies based on how you have configured your kernel, but for most people the missing module is the firmware_class. To load this module, simply run:

% modprobe firmware_class
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda prometeo79 » lun nov 14, 2005 16:07

Incredibile ma vero ce l'ho fatta!!!
Aggiungo a quello che ha detto Raistlin84 la mia esperienza.

Partiamo dal presupposto che come kernel ho il 2.6.12.4, quello che ho fatto io dovrebbe farsi fino al 2.6.13 perchè nel 2.6.14 i moduli per la scheda sono già inseriti.ù
Ho dovuto ricompilare il kernel mettendo come modulare "hotplug firmware loading support" invece che statico (se qualcuno mi spiega perchè apprezzo molto). Così facendo il kernelmi ha caricato il modulo firmware_class. A questo punto ho installato i driver ieee80211 e ipw2200 e ho decompresso il firmware in /lib/firmware e cleato i link come indicato da Raistlin, modprobe ipw2200 e il gioco è fatto. Non ho dovuto modificare il modprobe.conf con le stringhe sopra citate perchè la scheda wireless si è andata a piazzare subito su eth1. Non ho pututo ancora testarne il funzionamento ma dovrebbe essere ok

Sentiti ringraziamenti a firetux e Raistlin84
Ultima modifica di prometeo79 il lun nov 14, 2005 17:55, modificato 1 volta in totale.
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda Firetux » lun nov 14, 2005 16:35

di niente! :D
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda prometeo79 » mar nov 15, 2005 10:16

Ancora una piccola cosa. Uso da kde kwifimanager e come lo avvio mi trova la rete wireless senza problemi, però l'unico modo di disattivarla è direttamente dall'applicazione dalla voce file disattiva. Dato che vorrei associare ad un tasto fn questa operazione, sapete indicarmi una stringa per disattivare il programma?
Spero di essere stato chiaro
Cià
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda Firetux » mar nov 15, 2005 10:36

Codice: Seleziona tutto
ifconfig wlan0 down
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Prossimo

Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron