Pagina 2 di 2

Re: Get-compiz su Slamd64

Inviato: mar mar 04, 2008 17:45
da 414N
Al massimo potresti trovare la variabile CFLAGS. Normalmente non è definita, comunque. Io l'ho definita nei miei file di profilo utente, in modo che a ogni login venga settata in automatico (e non debba ogni volta rispecificarli sulla shell).
Si tratta comunque solo di una finezza della quale si può fare anche a meno, anche perchè a volte impostando flag troppo aggressivi si rende il programma instabile. Se vuoi qualche indicazione su CFLAGS sicuri che non comportano magagne: http://gentoo-wiki.com/Safe_Cflags

Re: Get-compiz su Slamd64

Inviato: mar mar 04, 2008 21:25
da 414N
Ho effettuato alcune modifiche allo script, in modo che, se l'architettura è x86_64, vengano scaricati i pacchetti sorgenti di ORBit2 e gconf, compilati e installati (sarebbe stato più comodo un package già pronto ma non ne ho trovati).
ORBit2 si scarica, compila e installa tranquillamente.
GConf si scarica e, durante il configure, mi dice che non trova linc.
Dopo varie ricerche, mi sono reso conto che c'è una versione di linc embedded in ORBit2.
Domani ci tornerò sopra...

Re: Get-compiz su Slamd64

Inviato: mar mar 04, 2008 21:38
da Ansa89
Se non ricordo male GConf ti fa scaricare praticamente tutti i pacchetti di GNOME (uno è la dipendenza dell'altro). Comunque mi sembra stia diventando una cosa troppo complicata, non voglio credere che non esista un flag che permetta di installare compiz su un 64bit...
Prima di diventare matto a compilare quei pacchetti, prova a verificare se compiz funziona anche senza di loro...magari con le ultime release non vengono più richiesti...

Re: Get-compiz su Slamd64

Inviato: mer mar 05, 2008 11:05
da 414N
Ho dato una letta al forum di compiz (ho trovato anche il tuo post Ansa89 :) ) e ho trovato questo thread: http://forum.compiz-fusion.org/showthread.php?t=5801
Sembra sia difficilotto compilare compiz da git senza gconf installato per via di un bug nei tools automake. Non è stato neppure rilasciato un work-around e il bug è stato bollato dagli sviluppatori di compiz come un "not a bug" e risolto, percui non ci torneranno di certo sopra.
Al momento la vedo quindi grigia fare andare quello script su Slamd64, a meno di trovare un pacchetto per slamd64 di gconf (che è una falsa dipendenza comunque). Se troverò una soluzione te lo farò sapere. Comunque Slamd64 include già una versione di compiz (0.5.0) a 64bit.

PS: il fatto di indicare --libdir=/usr/lib64 vuole solo indicare al configure (più che altro al make install successivo) di andare a piazzare le librerie create in /usr/lib64 invece che in /usr/local/lib come di default. Non implica nessuna ricerca delle librerie in /usr/lib64, serve solo a mantenere un po' di ordine e separare le librerie a 32 bit da quelle a 64 bit (tanto alla fine ldconfig non si scandalizza :D )

Re: Get-compiz su Slamd64

Inviato: gio mar 06, 2008 19:20
da Ansa89
414N ha scritto:PS: il fatto di indicare --libdir=/usr/lib64 vuole solo indicare al configure (più che altro al make install successivo) di andare a piazzare le librerie create in /usr/lib64 invece che in /usr/local/lib come di default. Non implica nessuna ricerca delle librerie in /usr/lib64, serve solo a mantenere un po' di ordine e separare le librerie a 32 bit da quelle a 64 bit (tanto alla fine ldconfig non si scandalizza :D )

Grazie per la precisazione :D
Allora per la faccenda dei 64bit la chiudiamo qui...Almeno fino a quando non correggono quel bug (magari durante l'implementazione di altro codice :roll: ), oppure viene fuori GConf pacchettizzato per 64bit.

Re: Get-compiz su Slamd64

Inviato: gio mar 06, 2008 19:48
da 414N
Quando avrò più tempo ci tornerò sopra per trovare un work-around :D