Pagina 1 di 2

[RISOLTO] mbr corrotto

Inviato: mar feb 24, 2009 12:04
da HaVaNa7
Buongiorno, ho dato un'impostazione sbagliata a lilo.conf ed eseguendo lilo -v ho reso inavviabile la mia slack 12.0
Sapevo ripristinare mbr con questo comando da una live: mount -t reiserfs /dev/sda6 /mnt/windows
dd if=/dev/sda of=/mnt/windows/lilo.mbr bs=512 count=1
il problema è che il lilo.mbr in questione è quello che non è usabile.

Come posso fare?

Re: mbr corrotto

Inviato: mar feb 24, 2009 12:09
da tigerwalk
non puoi fare un chroot sulla partizione e sistemare ed installare lilo?

Re: mbr corrotto

Inviato: mar feb 24, 2009 12:13
da raffaele181188
Inserisci il DVD di Slackware 12.x e lui ti dice quello che devi fare per avviare il tuo sistema. Devi digitare qualcosa tipo

Codice: Seleziona tutto

hugesmp.s root=/dev/sda1 read-only .... (è un esempio, fai delle prove)

e questo ti avvia la TUA Slackware, però con il kernel dell'installazione. ovviamente se usi driver video compilati per il tuo kernel non potrai avere accesso alla parte grafica. Poco male. Sei in init 3, quindi loggati come root, modifica il lilo.conf e reinstalla lilo

Re: mbr corrotto

Inviato: mar feb 24, 2009 12:27
da HaVaNa7
il problema è che non ho il dvd della slack, l'unico livecd che ho è la backtrack3.
ho provato a fare chroot /mnt/sda6 dopo aver montato dev sda6 in appunto mnt/sda6
ma mi restituisce: /egrep/cmdline: no such file or directory
e quindi se eseguo lilo restituisce errori : fatal: raid_setup: stat("/dev/sda")
faccio presente che non ho raid, è un hd sata

Re: mbr corrotto

Inviato: mar feb 24, 2009 12:37
da FireEater
Non ti capisco, da quel che dici sda6 dovrebbe essere la partizione di windows.
Per quale motivo fai chroot sulla partizione di windows?? :?

Monta la tua root partition e fai chroot su di essa, poi edita /etc/lilo.conf ed infine dai lilo -v.

Ma poi: Hai il mount point chiamato /mnt/sda6?? [-(

Re: mbr corrotto

Inviato: mar feb 24, 2009 12:43
da HaVaNa7
si scusami sono stato poco chiaro, nel comando di prima montavo dev/sda6 dentro mnt/windows solo perchè avevo una directory windows già presente nella live.

Si ho il mount point /mnt/sda6

ho trovato questo post:

Codice: Seleziona tutto

Per un bug di Backtrack 3 riceveremo il seguente errore :

BT ~ # chroot /tmp/bt3/
egrep: /proc/cmdline: No such file or directory
egrep: /proc/cmdline: No such file or directory
egrep: /proc/cmdline: No such file or directory

Apriamo un altra shell console e idigitiamo il comando di chroot:

 BT ~ # chroot /tmp/bt3/

Riceveremo lo stesso errore ma non importa.

Apriamo una nuova shell console e digitiamo lilo

BT ~ # lilo

(anche se riveremo degli errori il comando andrà a buon fine)


Ho fatto come dice cambiando solo il mount point ma non ha avito successo

Re: mbr corrotto

Inviato: mar feb 24, 2009 12:48
da FireEater
OK.

Hai aperto delle altre shell per fare quelle operazioni?

Nel caso prova ad usare il comando chroot (/bin/chroot) della partizione di slackware.

Re: mbr corrotto

Inviato: mar feb 24, 2009 13:07
da HaVaNa7
si ho fatto tutto come scritto ma non c'è verso...

Re: mbr corrotto

Inviato: mar feb 24, 2009 13:24
da conraid
Ci dici un po' come sono e cosa contengono le tue partizioni

Re: mbr corrotto

Inviato: mar feb 24, 2009 13:29
da raffaele181188
Allora forse non hai fatto proprio come ti è stato suggerito! :D

Comunque dalla live monta la tua Slackware sotto /mnt/slackware (che è meglio)Dopo di che

Codice: Seleziona tutto

vim /mnt/slackware/etc/lilo.conf
...modifichi il file opportunamente... e, se sulla tua live c'è installato Lilo
chroot /mnt/slackware lilo -v


Deve funzionare per forza. Se dà errori riportali

Re: mbr corrotto

Inviato: mar feb 24, 2009 13:51
da HaVaNa7
sda1 bachup vaio
sda2 windows vista
sda3 windows 7
sda4 extended
sda5 swap
sda6 backtrack3 reiserfs
sda7 ubuntu ext3
sda8 dati ntfs


ho creato dalla live la dir /mnt/slackaware
ho montato sda6 su mnt/slackware facendo mount -t reiserfs /dev/sda6 /mnt/slackware
ho dato chroot /mnt/slackware
ho eseguioto lilo-v:

Warning: LBA32 addressing assumed
/proc/misc: fopen failed: No such file or directory
Is device-mapper driver missing from kernel?
Failure to communicate with kernel device-mapper driver.
fatal: raid_setup: stat("/dev/sda")

Re: mbr corrotto

Inviato: mar feb 24, 2009 13:53
da tigerwalk
dai il comando

Codice: Seleziona tutto

fdisk -l

oppure, meglio ancora

Codice: Seleziona tutto

blkid

in una shell di root e posta il risultato!

Re: mbr corrotto

Inviato: mar feb 24, 2009 13:58
da conraid
Perché sei hai backtrack nel primo messaggio hai scritto slackware?

Prima di fare chroot da live, monta /proc e /sys

Codice: Seleziona tutto

mount -t proc proc /mnt/slackware/proc
mount -t sysfs sysfs /mnt/slackware/sys


Se continua a darti errore di device-mapper monta il modulo.

Re: mbr corrotto

Inviato: mar feb 24, 2009 14:02
da HaVaNa7
bt ~ # blkid
/dev/sda1: TYPE="ntfs"
/dev/sda2: TYPE="ntfs"
/dev/sda3: TYPE="ntfs"
/dev/sda5: TYPE="swap" UUID="5b85ae6c-87c4-4f63-9e43-4c9e2e79108e"
/dev/sda6: UUID="61ca2517-66f7-4585-853d-f03ffe76e0b5" TYPE="reiserfs"
/dev/sda7: UUID="ea7408c5-075e-47da-9ad8-3fbf054f0353" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda8: TYPE="ntfs"

Re: mbr corrotto

Inviato: mar feb 24, 2009 14:07
da HaVaNa7
conraid ha scritto:Perché sei hai backtrack nel primo messaggio hai scritto slackware?

Prima di fare chroot da live, monta /proc e /sys

Codice: Seleziona tutto

mount -t proc proc /mnt/slackware/proc
mount -t sysfs sysfs /mnt/slackware/sys


Se continua a darti errore di device-mapper monta il modulo.


allora ho aperto una shell ed ho dato i 2 comandi che mi hai postato.
adesso dopo aver fatto chroot /mnt/slackware ho dato lilo -v
e l'errore è diverso:
Warning: LBA32 addressing assumed
fatal: raid_setup: stat("/dev/sda")

non l'ho detto perchè so che è basata su slack 12.0 non credevo cambasse molto