Repository 32bit  Forum
Repository 64bit  Wiki

il microfono non ne vuol sapere

Forum dedicato ai Porting ufficiali e non di Slackware, vedi Slack/390, ARMedslack, Slamd64, Slackintosh, Ocsid, Sloox, Zenwalk, How-Tux, Slax etc etc

Moderatore: Staff

Regole del forum
1) Specificare nome e versione del porting.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

il microfono non ne vuol sapere

Messaggioda maxim65 » sab mar 28, 2009 20:56

Con la slam64 12.2 mi trovo piuttosto bene a parte un'unico problema, il microfono, non ne vuol sapere di funzionare.Sono passato dalla 12,0 alla 12,1 alla 12,2 con sempre lo stesso problema, non fuonziona il microfono e solo lui.Ho provato a cambiare la scheda audio, non cambia nulla.Ho provato a cambiare le librerie alsa a disinstallarle e ricompilarle per poi reinstallarle.Nulla, non vuol funzionare.Ovviamente ho provato anche a cambiare il microfono ma con sempre lo stesso risultato.
Suggerimenti???
maxim65
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mar nov 13, 2007 14:33
Località: Quercia di Aulla (MS)

Re: il microfono non ne vuol sapere

Messaggioda teox99 » sab mar 28, 2009 21:57

ciao
vedi se alsamixer ha il microfono unmute poi
prova da terminale
# arecord nomefileoutput.wav
Avatar utente
teox99
Linux 2.6
Linux 2.6
 
Messaggi: 729
Iscritto il: ven lug 25, 2008 13:54
Località: Roma[Eur]
Slackware: 13.37
Desktop: KDE - Xfce

Re: il microfono non ne vuol sapere

Messaggioda maxmo » dom mar 29, 2009 10:37

mi accodo al problema anche se non utilizzo slam64. Nel mio caso il microfono funziona, o meglio: microfono attivato e suono esce dalle casse ma... non registra.
Con il comando che hai suggerito da teox99 ottengo un file wav ma completamente muto.
Domanda: per terminare la registrazione attivata con arecord, che comando devo dare? io ho stoppato con ctrl+c
Avatar utente
maxmo
Linux 2.4
Linux 2.4
 
Messaggi: 336
Iscritto il: lun feb 28, 2005 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: il microfono non ne vuol sapere

Messaggioda teox99 » dom mar 29, 2009 13:21

ciao,
per uscire da arecord e' corretto usare ctrl+c
# arecord -f cd -t wav file.wav

ribadisco pero' il fatto di usare alsamixer + tab, per andare nella sez. Capture,
da li vedete se c'e' qualche canale CaptureLR da abilitare o alzare.

# arecord -l
dovreste avere una linea tipo: (dove mic e' riconosciuto)
card 0: Live [SB Live 5.1 [SB0220]], device 1: emu10k1 mic [Mic Capture]
Subdevices: 1/1
Subdevice #0: subdevice #0

quando farete partire arecord e parlerete al mic una serie di caratteri verra' visualizzata a video, significa che il canale sta catturando l'input da mic.
Avatar utente
teox99
Linux 2.6
Linux 2.6
 
Messaggi: 729
Iscritto il: ven lug 25, 2008 13:54
Località: Roma[Eur]
Slackware: 13.37
Desktop: KDE - Xfce

Re: il microfono non ne vuol sapere

Messaggioda maxmo » dom mar 29, 2009 17:40

ok ora funziona tutto, dovevo attivare capture.
Grazie teox99
Avatar utente
maxmo
Linux 2.4
Linux 2.4
 
Messaggi: 336
Iscritto il: lun feb 28, 2005 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: il microfono non ne vuol sapere

Messaggioda maxim65 » lun mar 30, 2009 12:37

La stessa card la vede ripetuta due volte.L'output verso le casse funzione perfettamente, ma non registra.Anche impostando capture al massimo.Mi sembra strano si sia rotto solo l'input verso il microfono ma potrebbe esserci qualche problema di compatibilità con questo chipset. si sente solo fruscio:Ho disattivato il chipset vt8237 della mb e ho installato una vecchia sounblaster ed ora sembra che riesca anche a registrare.
C'è un modo, senza ogni volta lanciare alsamixer, di salvare in modo definitivo i valori impostati.
Kmix funziona sui valori di play ma non sul capture, perchè?
maxim65
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mar nov 13, 2007 14:33
Località: Quercia di Aulla (MS)

Re: il microfono non ne vuol sapere

Messaggioda g4b0 » mer apr 01, 2009 20:02

Ciao ragazzi,
Stavo smanettando per far funzionare il microfono, provando quanto scritto sopra, ma mi si è rallentato tremendamente il pc. Da quando ho piazzato la slack 12.2, apparentemente ogni qualvolta c'è di mezzo dell'audio, mi si inchioda tutto.

Allego il syslog dall'avvio di questa sessione, c'è qualcosa di relativo all'audio verso la fine, ma non mi è ben chiaro come posso risolvere... Se non sbaglio c'è anche qualcosa a proposito del driver della Nvidia, ma al massimo ne parliamo in un altro post.

Ecco qua:
Codice: Seleziona tutto
Apr  1 20:30:35 slack kernel: ACPI: RSDP 000F7720, 0014 (r0 VIAK8M)
Apr  1 20:30:35 slack kernel: ACPI: RSDT 5FEE3040, 002C (r1 VIAK8M AWRDACPI 42302E31 AWRD        0)
Apr  1 20:30:35 slack kernel: ACPI: FACP 5FEE30C0, 0074 (r1 VIAK8M AWRDACPI 42302E31 AWRD        0)
Apr  1 20:30:35 slack kernel: ACPI: DSDT 5FEE3180, 525B (r1 VIAK8M AWRDACPI     1000 MSFT  100000E)
Apr  1 20:30:35 slack kernel: ACPI: FACS 5FEE0000, 0040
Apr  1 20:30:35 slack kernel: ACPI: APIC 5FEE8440, 005A (r1 VIAK8M AWRDACPI 42302E31 AWRD        0)
Apr  1 20:30:35 slack kernel: Zone PFN ranges:
Apr  1 20:30:35 slack kernel:   DMA      0x00000010 -> 0x00001000
Apr  1 20:30:35 slack kernel:   Normal   0x00001000 -> 0x00038000
Apr  1 20:30:35 slack kernel:   HighMem  0x00038000 -> 0x0005fee0
Apr  1 20:30:35 slack kernel: Movable zone start PFN for each node
Apr  1 20:30:35 slack kernel: early_node_map[2] active PFN ranges
Apr  1 20:30:35 slack kernel:     0: 0x00000010 -> 0x0000009f
Apr  1 20:30:35 slack kernel:     0: 0x00000100 -> 0x0005fee0
Apr  1 20:30:35 slack kernel: Enabling APIC mode:  Flat.  Using 1 I/O APICs
Apr  1 20:30:35 slack kernel: Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 389745
Apr  1 20:30:35 slack kernel: PID hash table entries: 4096 (order: 12, 16384 bytes)
Apr  1 20:30:35 slack kernel: Detected 1799.744 MHz processor.
Apr  1 20:30:35 slack kernel: Console: colour dummy device 80x25
Apr  1 20:30:35 slack kernel: Mount-cache hash table entries: 512
Apr  1 20:30:35 slack kernel: ENABLING IO-APIC IRQs
Apr  1 20:30:35 slack kernel: ACPI Warning (dsobject-0501): Package List length (6) larger than NumElements count (2), truncated
Apr  1 20:30:35 slack kernel:  [20080609]
Apr  1 20:30:35 slack kernel: ACPI: RTC can wake from S4
Apr  1 20:30:35 slack kernel: highmem bounce pool size: 64 pages
Apr  1 20:30:35 slack kernel: Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Apr  1 20:30:35 slack kernel: GFS2 (built Nov 20 2008 22:30:39) installed
Apr  1 20:30:35 slack kernel: Console: switching to colour frame buffer device 128x48
Apr  1 20:30:35 slack kernel: Compaq SMART2 Driver (v 2.6.0)
Apr  1 20:30:35 slack kernel: ACPI: PCI Interrupt Link [ALKA] enabled at IRQ 20
Apr  1 20:30:35 slack kernel: hdc: host side 80-wire cable detection failed, limiting max speed to UDMA33
Apr  1 20:30:35 slack kernel: ide-floppy driver 1.00
Apr  1 20:30:35 slack kernel: Loading Adaptec I2O RAID: Version 2.4 Build 5go
Apr  1 20:30:35 slack kernel: scsi: <fdomain> Detection failed (no card)
Apr  1 20:30:35 slack kernel: Emulex LightPulse Fibre Channel SCSI driver 8.2.7
Apr  1 20:30:35 slack kernel: Copyright(c) 2004-2008 Emulex.  All rights reserved.
Apr  1 20:30:35 slack kernel: Failed initialization of WD-7000 SCSI card!
Apr  1 20:30:35 slack kernel: GDT-HA: Storage RAID Controller Driver. Version: 3.05
Apr  1 20:30:35 slack kernel: 3ware Storage Controller device driver for Linux v1.26.02.002.
Apr  1 20:30:35 slack kernel: 3ware 9000 Storage Controller device driver for Linux v2.26.02.011.
Apr  1 20:30:35 slack kernel: Driver 'st' needs updating - please use bus_type methods
Apr  1 20:30:35 slack kernel: Driver 'sd' needs updating - please use bus_type methods
Apr  1 20:30:35 slack kernel: Driver 'sr' needs updating - please use bus_type methods
Apr  1 20:30:35 slack kernel: ACPI: PCI Interrupt Link [ALKB] enabled at IRQ 21
Apr  1 20:30:35 slack kernel: raid6: int32x1    663 MB/s
Apr  1 20:30:35 slack kernel: raid6: int32x2    672 MB/s
Apr  1 20:30:35 slack kernel: raid6: int32x4    645 MB/s
Apr  1 20:30:35 slack kernel: raid6: int32x8    466 MB/s
Apr  1 20:30:35 slack kernel: raid6: mmxx1     1445 MB/s
Apr  1 20:30:35 slack kernel: raid6: mmxx2     2685 MB/s
Apr  1 20:30:35 slack kernel: raid6: sse1x1     978 MB/s
Apr  1 20:30:35 slack kernel: raid6: sse1x2    1533 MB/s
Apr  1 20:30:35 slack kernel: raid6: sse2x1    1473 MB/s
Apr  1 20:30:35 slack kernel: raid6: sse2x2    2097 MB/s
Apr  1 20:30:35 slack kernel: raid6: using algorithm sse2x2 (2097 MB/s)
Apr  1 20:30:35 slack kernel: Using IPI No-Shortcut mode
Apr  1 20:30:35 slack kernel: VFS: Mounted root (reiserfs filesystem) readonly.
Apr  1 20:30:35 slack kernel: i2c_core: exports duplicate symbol i2c_smbus_xfer (owned by kernel)
Apr  1 20:30:35 slack kernel: i2c_core: exports duplicate symbol i2c_smbus_xfer (owned by kernel)
Apr  1 20:30:35 slack kernel: nvidia: module license 'NVIDIA' taints kernel.
Apr  1 20:30:35 slack kernel: NVRM: loading NVIDIA UNIX x86 Kernel Module  173.14.18  Mon Mar  2 12:17:40 PST 2009
Apr  1 20:30:35 slack kernel: via-rhine: Broken BIOS detected, avoid_D3 enabled.
Apr  1 20:30:35 slack kernel: ACPI: PCI Interrupt Link [ALKD] enabled at IRQ 23
Apr  1 20:30:35 slack kernel: fuse init (API version 7.9)
Apr  1 20:30:52 slack avahi-daemon[3152]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
Apr  1 20:30:57 slack kdm_greet[3195]: Can't open default user face
Apr  1 20:31:35 slack pulseaudio[3285]: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
Apr  1 20:31:35 slack pulseaudio[3285]: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_13f6_111_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.
Apr  1 20:31:35 slack pulseaudio[3285]: module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files
Apr  1 20:31:35 slack pulseaudio[3285]: module.c: Failed to load  module "module-console-kit" (argument: ""): initialization failed.
Apr  1 20:31:35 slack pulseaudio[3285]: main.c: Module load failed.
Apr  1 20:31:35 slack pulseaudio[3285]: main.c: Failed to initialize daemon.
Apr  1 20:31:44 slack kernel: process `skype' is using obsolete setsockopt SO_BSDCOMPAT
Apr  1 20:50:23 slack pulseaudio[3549]: polkit.c: Cannot set UID on session object.
Apr  1 20:50:23 slack pulseaudio[3549]: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
Apr  1 20:50:23 slack pulseaudio[3549]: core-util.c: setpriority(): Permission denied
Apr  1 20:50:30 slack pulseaudio[3551]: module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files
Apr  1 20:50:31 slack pulseaudio[3551]: module.c: Failed to load  module "module-console-kit" (argument: ""): initialization failed.
Apr  1 20:50:31 slack pulseaudio[3551]: main.c: Module load failed.
Apr  1 20:50:31 slack pulseaudio[3551]: main.c: Failed to initialize daemon.
Apr  1 20:50:32 slack pulseaudio[3549]: main.c: Daemon startup failed.


A parte il microfono l'audio funziona (fino a che non saltano fuori quegli errori nel syslog, poi tutto diventa muto e lento)

Ho trovato anche questo in /var/log/messages:
Codice: Seleziona tutto
Apr  1 20:31:34 slack pulseaudio[3285]: module-alsa-sink.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
Apr  1 20:31:35 slack pulseaudio[3285]: module-alsa-source.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
Apr  1 20:50:23 slack pulseaudio[3549]: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
Apr  1 20:50:23 slack pulseaudio[3549]: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Apr  1 20:50:23 slack pulseaudio[3549]: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Apr  1 20:50:23 slack pulseaudio[3551]: module-alsa-sink.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
Apr  1 20:50:30 slack pulseaudio[3551]: module-alsa-source.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
Ultima modifica di g4b0 il mer apr 01, 2009 20:07, modificato 1 volta in totale.
Avatar utente
g4b0
Linux 2.4
Linux 2.4
 
Messaggi: 318
Iscritto il: lun dic 27, 2004 0:00
Località: Torino
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: kde 3.5.10

Re: il microfono non ne vuol sapere

Messaggioda danix » mer apr 01, 2009 20:06

per salvare le impostazioni di alsamixer si usa da root il comando:
Codice: Seleziona tutto
alsactl store
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: il microfono non ne vuol sapere

Messaggioda maxim65 » gio apr 02, 2009 13:07

Questo messaggio

Apr 1 20:31:35 slack pulseaudio[3285]: alsa-util.c: Error opening PCM device hw:0: Device or resource busy

sembrerebbe indicarte un problema con il sound server pulseaudio.Se non ti è indispensabile puoi provare a disattivarlo.
Potrebbe esserci un problema con il driver della scheda audio.
Puoi provare e riconfigurare il kernel con il driver migliore per il tuo chipset.
maxim65
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mar nov 13, 2007 14:33
Località: Quercia di Aulla (MS)

Re: il microfono non ne vuol sapere

Messaggioda g4b0 » gio apr 02, 2009 13:33

maxim65 ha scritto:Questo messaggio

Apr 1 20:31:35 slack pulseaudio[3285]: alsa-util.c: Error opening PCM device hw:0: Device or resource busy

sembrerebbe indicarte un problema con il sound server pulseaudio.Se non ti è indispensabile puoi provare a disattivarlo.
Potrebbe esserci un problema con il driver della scheda audio.
Puoi provare e riconfigurare il kernel con il driver migliore per il tuo chipset.


Ho downgradato xine-lib-1.1.16 (scaricato tramite slackyd) con la versione precedente xine-lib-1.1.15, ho disinstallato pulseaudio (sempre installato con slackyd) e la lentezza pare scomparsa. Il microfono è sempre muto, però..

Devo ricompilare il kernel?
Avatar utente
g4b0
Linux 2.4
Linux 2.4
 
Messaggi: 318
Iscritto il: lun dic 27, 2004 0:00
Località: Torino
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: kde 3.5.10

Re: il microfono non ne vuol sapere

Messaggioda maxim65 » gio apr 02, 2009 15:23

Se sai come fare a ricompilare il kernel lo puoi ottimizzare altrimenti è meglio di no.Comunque se ti va bene anche senza il sound server puoi continuare con quel kernel che hai ora.Io l'ho sempre disattivato, per evitare vari problemi.....
Per il microfono prova a seguire le indicazioni che trovi nei precedenti passi indicati su questo argomento, come le impostazioni dell'alsamixer.
maxim65
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mar nov 13, 2007 14:33
Località: Quercia di Aulla (MS)

Re: il microfono non ne vuol sapere

Messaggioda g4b0 » gio apr 02, 2009 15:35

Ricompilare non è un problema, anche se non ne ho una gran voglia.. I tentativi dei post precedenti li ho fatti tutti, ma il microfono continua ad essere muto!

Ma nel caso della ricompilazione che opzioni devo attivare/disattivare? Dove trovo il supporto per la mia scheda? Mi conviene compilare l'ultimo kernel, o è meglio ricompilare la versione che già ho?
Avatar utente
g4b0
Linux 2.4
Linux 2.4
 
Messaggi: 318
Iscritto il: lun dic 27, 2004 0:00
Località: Torino
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: kde 3.5.10

Re: il microfono non ne vuol sapere

Messaggioda maxim65 » gio apr 02, 2009 16:28

Ti conviene l'ultima versione la 2.6.29, io ho quella ora e sembra vada bene .
Ti conviene verificare l'hardware che hai con il commando lspci e di conseguenza selezionare le varie opzioni nel kernel.Le scelte da fare sono molte a cominciare se smp o no, se hai un solo processore unicore ovviamente no.La lista è lunga e conviene comunque fare con calma per evitare scelte sbagliate che su alcune opzioni, potrebbero mettere in seria crisi il sistema.Nella configurazione del kernel c'è anche un help in linea che può aiutare.Comunque sotto usr/src/linux trovi tutta una serie di documenti e altri file di testo che ti possono aiutare
maxim65
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mar nov 13, 2007 14:33
Località: Quercia di Aulla (MS)

Re: il microfono non ne vuol sapere

Messaggioda g4b0 » gio apr 02, 2009 17:50

Rimangio ciè che ho detto. Dopo 20 minuti scarsi di amarok e firefox (con 3 tab aperti), di colpo è saltata la musica ed il sistema è diventato per nulla reattivo. Ad esempio, per passare da un tab all'altro di firefox mi ci vogliono quasi 2 sec.

/va/log/messages e /var/log/syslog questa volta non dicono nulla, mi sa che mi tocca ricompilare. Il problema è che non so come fare a configurare il kernel per la mia sk audio:

Codice: Seleziona tutto
00:09.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev ff) (prog-if ff)
        !!! Unknown header type 7f
        Kernel driver in use: C-Media PCI
        Kernel modules: snd-cmipci


Any hints?
Avatar utente
g4b0
Linux 2.4
Linux 2.4
 
Messaggi: 318
Iscritto il: lun dic 27, 2004 0:00
Località: Torino
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: kde 3.5.10

Re: il microfono non ne vuol sapere

Messaggioda maxim65 » gio apr 02, 2009 20:08

Il diffetto te lo fà a caldo?
Non è detto non possa essere un problema hardware.Per prima cosa dovresti, dopo aver fatto un riavvio, lanciare uno di quei programmini per testare la ram.Ne avevo trovato uno molto valido su un dischetto di unbuntu 7, era nel menu di installazione dello stesso; è un test piuttosto lungo ma fa una verifica completa della ram.Probabilmente c'è anche su quello dello slack da qualche parte.
Poi, se questo non dovesse trovarti errori, verifica se la versione del bios della tua mb ha dei problemi del genere.
A seguire, quando si riverifica il problema audio, riavvia il pc e nel menu del bios verifica la temperatura della cpu.
Infine, se non hai ancora trovato il difetto, disabilità il chip audio dal bios e installa un'altra sk audio pci, se ne hai una da qualche parte.
maxim65
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mar nov 13, 2007 14:33
Località: Quercia di Aulla (MS)

Prossimo

Torna a Porting Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite

cron