Repository 32bit  Forum
Repository 64bit  Wiki

ci hanno provato?

Postate qui per tutte le discussioni legate alla sicurezza di Linux/Slackware

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

ci hanno provato?

Messaggioda pino.giaquinto » ven set 01, 2006 9:00

Premetto che ho una rete WIFI mista (1 desktop WinXP + un portatile WInXP + un portatile Slack 10.2) collegati tra loro a mezzo di un router Linksys WAG54G connesso 24h su 24h a internet.
Ho notato che nella directory /var/log del portatile linux ci sono dei log samba relativi a IP non appartenenti alla mia rete:
Codice: Seleziona tutto
samba.151.83.x.x
samba.87.x.x.x

Il contrenuto dei log è sempre lo stesso (ovviamente cambia l'IP):
Codice: Seleziona tutto
[2006/08/20 17:12:16, 0] lib/access.c:check_access(328)
  Denied connection from  (151.83.4.158)
[2006/08/20 17:12:16, 1] smbd/process.c:process_smb(1107)
  Connection denied from 151.83.4.158
[2006/08/20 17:12:38, 0] lib/access.c:check_access(328)
  Denied connection from  (151.83.4.158)
[2006/08/20 17:12:38, 1] smbd/process.c:process_smb(1107)
  Connection denied from 151.83.4.158

Ci hanno provato e samba ha resistito all'attacco?
Cosa mi consigliate?
Avatar utente
pino.giaquinto
Linux 2.4
Linux 2.4
 
Messaggi: 329
Iscritto il: mer gen 25, 2006 11:14

Messaggioda gioco » ven set 01, 2006 11:02

Queste http://www.samba.org/samba/docs/server_security.html sono precauzioni utili.
Il mio consiglio è di isolare i servizi della rete locale impostando a dovere le regole di firewall. Setta le policy di default a DROP, accetta connessioni solo per i servizi davvero necessari e specifica nelle regole quanti più flag possibile per i pacchetti (non solo la porta, ma anche l'interfaccia, IP sorgente/destinazione...). Non dimenticare di controllare il traffico anche sulla chain di OUTPUT.
Avatar utente
gioco
Packager
Packager
 
Messaggi: 900
Iscritto il: sab giu 18, 2005 23:00
Località: in the court of the Wesnoth king
Slackware: last stable

Messaggioda kreen » ven set 01, 2006 12:21

In questo momento non sono a casa, ma mi pare tu abbia il router uguale al mio.
Nella sezione Applications & Gaming (se non erro) c'e' la finestra del port forwarding... Le porte che vuoi inibire dall'esterno reindirizzale verso la 9 interna e non dovresti più avere problemi.
Avatar utente
kreen
Linux 2.4
Linux 2.4
 
Messaggi: 228
Iscritto il: mer feb 01, 2006 18:32
Località: Verona
Slackware: 12.0
Kernel: 2.6.21.5-smp
Desktop: KDE

Messaggioda pino.giaquinto » ven set 01, 2006 20:09

Grazie kreen... ci proverò :-)
Intanto ho installato Guarddog e sono riuscito praticamente subito a configurarlo in modo da poter 'navigare' e inviare/ricevere email.
Purtroppo è da un bel pò che cerco di far funzionare samba ma non ci riesco!
Se disabilito il firewall è tutto ok, quindi dipende sicuramente da Guarddog.
Ho 'spuntato' <Microsoft SMB su TCP> e <Windows Networking (NETBIOS)> ma se provo a usare smbtree da console:
Codice: Seleziona tutto
Packet send failed to 192.168.1.255(137) ERRNO=Operation not permitted
Packet send failed to 192.168.1.255(137) ERRNO=Operation not permitted
Packet send failed to 192.168.1.255(137) ERRNO=Operation not permitted

e se tento di accedere alla rete locale con kde:
Codice: Seleziona tutto
Impossibile trovare un gruppo di lavoro nella tua rete locale. Potrebbe essere dovuto alla presenza di un firewall.


Please help me...!
Avatar utente
pino.giaquinto
Linux 2.4
Linux 2.4
 
Messaggi: 329
Iscritto il: mer gen 25, 2006 11:14

Messaggioda Sonic » dom set 03, 2006 13:57

Dunque dovrebbe avere trovato la 137 chiusa.
A questo punto non ti resta che aprire le porte 137,138, 139, 445 come porte sorgenti e di destinazione sui protocolli tcp e udp.

Supponendo che tu abbia come interfaccia eth0 e come categoria di IP della tua LAN 192.168.1.0/24:

Codice: Seleziona tutto
iptables -A INPUT -i eth0 -s 192.168.1.0/24 -p tcp --dport 137:138 -j ACCEPT
iptables -A INPUT -i eth0 -s 192.168.1.0/24 -p tcp --dport 139:445 -j ACCEPT
iptables -A INPUT -i eth0 -s 192.168.1.0/24 -p udp --dport 137:138 -j ACCEPT
iptables -A INPUT -i eth0 -s 192.168.1.0/24 -p udp --dport 139:445 -j ACCEPT

iptables -A INPUT -i eth0 -s 192.168.1.0/24 -p tcp --sport 137:138 -j ACCEPT
iptables -A INPUT -i eth0 -s 192.168.1.0/24 -p tcp --sport 139:445 -j ACCEPT
iptables -A INPUT -i eth0 -s 192.168.1.0/24 -p udp --sport 137:138 -j ACCEPT
iptables -A INPUT -i eth0 -s 192.168.1.0/24 -p udp --sport 139:445 -j ACCEPT
Avatar utente
Sonic
Linux 1.0
Linux 1.0
 
Messaggi: 34
Iscritto il: ven set 02, 2005 23:00
Località: ...da dove capita...


Torna a Sicurezza

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite