Repository 32bit  Forum
Repository 64bit  Wiki

Xorg modulare + beryl + slamd64

Forum dedicato ai Porting ufficiali e non di Slackware, vedi Slack/390, ARMedslack, Slamd64, Slackintosh, Ocsid, Sloox, Zenwalk, How-Tux, Slax etc etc

Moderatore: Staff

Regole del forum
1) Specificare nome e versione del porting.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Xorg modulare + beryl + slamd64

Messaggioda pippoZzz » mar mar 13, 2007 4:42

Ciao a tutti.... sn nuovo di questo forum.... spero di aver postato nel posto giusto...
Poco tempo fa io e il mio acer 1511 abbiamo deciso di sfruttare tutti i 64 bit del processore e, fedelissimi alla slacky, abbiamo optato per la slamd64..
Tutto bene a parte qualche riminescenza a 32 bit...

Ma visto che andava tutto bene ho deciso di mettere beryl e quindi xorg 7...

Per il momento beryl l'ho visto solo su youtube... :( :( :(

Dopo aver seguito più volte la guida del buon Meska[...] il risultato è che sono rimasto senza desktop :shock:

Fortunatamente ho il mio serverino (sempre slacky ovviamente 8) 8) ) che mi permette di cercare aiuto...

Non so più cosa fare e sinceramente mi piange il cuore a dover rinunciare a beryl e ancor di più ai 64 bit...

Eseguendo startx mi da quest'errore...

(==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar 13 05:40:56 2007
(==) Using config file: "/etc/X11/xorg.conf"
dlopen: /usr/X11R7/lib/xorg/modules//libglx.so: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/X11R7/lib/xorg/modules//libglx.so
(EE) Failed to load module "glx" (loader failed, 7)
dlopen: /usr/X11R7/lib/xorg/modules/drivers//nvidia_drv.so: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/X11R7/lib/xorg/modules/drivers//nvidia_drv.so
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available.

Fatal server error:
no screens found

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

Chiedo a voi e anche a Lei grande Meska[...] onnipotente...
pippoZzz
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: mar mar 13, 2007 4:19

Messaggioda pippoZzz » mar mar 13, 2007 4:52

ah... premessa

dlopen: /usr/X11R7/lib/xorg/modules//libglx.so: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/X11R7/lib/xorg/modules//libglx.so
(EE) Failed to load module "glx" (loader failed, 7)
dlopen: /usr/X11R7/lib/xorg/modules/drivers//nvidia_drv.so: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/X11R7/lib/xorg/modules/drivers//nvidia_drv.so
(EE) Failed to load module "nvidia" (loader failed, 7)

libxgl.so e i driver nvidia_drv.so ci sono e sono nelle rispettive directory indicate sopra...

Il problema (credo) sta nel fatto che nel report dell'errore di startx vengono chiamati con una doppia barra
[...]modules//libglx.so
[...]drivers//nvidia_drv.so
che oltretutto a volte cambia in funzione della directoty in cui sono quando do il comando startx... ad esempio se sono in [...]modules/ il doppio slash lo da prima di drivers..
PS: ho linkato libglx.so in modules oltre che il extensions pensando di risolvere il problema.... ovviamente non ha funzionato....

Grassie mille in anticipo.... :kiss:
pippoZzz
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: mar mar 13, 2007 4:19

Messaggioda prometeo79 » mar mar 13, 2007 12:25

Ciao

Qui Xorg 7.1


Qui gli slackbuild per compilare Beryl 1.4

Ne approfitto per ringraziare hyke da slamd64.com per avermi fornito i pacchetti.

Funziona più che bene, i pacchetti di beryl non te li do perchè è preferibile ricompilarli.

Compilali e installali nell'ordine:

beryl-core

beryl-settings

beryl-plugins

emerald

emerald-themes


P.S. C'è uno slackbuild per la compilazione dei driver per le ati ma con quello non ti so aiutare (ho nvidia)
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda pippoZzz » mar mar 13, 2007 15:52

Grazie mille...
ma scusa la domanda da noobby (in realtà non sono troppo smanettone perche la mai slacky è sempre stata "server" quindi senza troppi fronzoli...)...

Dei link che mi hai dato devo installare a mano tutti i pacchetti o solo quelli che mi sevono? In tal caso quali mi servono??

E soprattutto di beryl c'è sono un pacchetto che non sia 1 KB quindi ... in realta non so come muovermi...

Quancuno mi puo dare una piccola delucidazione??

PS: Chiedo scusa allo staff per aver postato nel posto sbagliato.... :cry: non accadrà più! ;)
pippoZzz
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: mar mar 13, 2007 4:19

Messaggioda prometeo79 » mar mar 13, 2007 17:17

Allora, rimuovi tutti i pacchetti di xorg (praticamente tutti i pacchetti che stanno qui http://mirror.vbfx.com/slamd64/slamd64- ... ackware/x/)

1) Installi tutti quelli al link che ti ho passato (http://www.cs.rpi.edu/~honj/x11/)
poi avvii kde e se non da errori l'installazione di xorg 7.1 è andata a buon fine (in più se apri nvidia-settings ti dice che versione di xorg hai)

2) Qui http://releases.beryl-project.org/0.1.4/ scarichi i pacchetti sorgenti di beryl e li metti in una directory sul pc.

3) Prendi gli scipt (non sono pacchetti) del secondo link che ti ho dato e li salvi nella stessa directory di beryl

4) Apri una shell, ti sposti nella directory di beryl e digiti

Codice: Seleziona tutto
sh ./beryl-core.SlackBuild


inizia a compilare, finita la compilazione

Codice: Seleziona tutto
installpkg beryl-core.0.1.4-x86_64-jh.tgz



5) Ripeti il punto quattro per tutti i pacchetti nell'ordine:

beryl-core

beryl-settings

beryl-plugins

emerald

emerald-themes

6) Avvii kde ed esegui il comando baryl-manager.

7) Fammi sapere com'è andata :D
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda pippoZzz » mar mar 13, 2007 17:38

ancora grazie mille.... ora vado a lezione.... :evil: :evil:
di fisica :shock: :shock: :shock: :shock: :shock:
e dopo provo a fare il tutto....

Nel frattempo sto facendo una lista di URL che mi permetta di scaricare tutto con wget... e velocizzare il tutto con:
wget -i lista

Per caso non c'è un comando/opzione di wget che mi permetta di prendere tutto a partira da una URL?? tipo
wget --prendi-tutto http://www.tuttoquellochecedaprendere.org

tnks one thousand
pippoZzz
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: mar mar 13, 2007 4:19

Messaggioda pippoZzz » mar mar 13, 2007 22:50

Ok... fatta tutta la prima parte e udite udite.....
non va :shock: :shock: :shock: :shock:

almeno l'errore è cambiato ma anche stavolta non so come risovere...
mi sembra di aver capito che si riferisce ai font

eccovi il dettaglio ;)
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar 13 23:44:33 2007
(==) Using config file: "/etc/X11/xorg.conf"

xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc/pc(pc105)+pc/us" };
xkb_geometry { include "pc(pc105)" };
Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/OTF, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing from list!

Fatal server error:
could not open default font 'fixed'
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

Spero ne sappiate piu di me... anche google sembra no voler collaborare...

almeno ora l'interfaccioa grafica non mi serve più me la cavo benissimo a linea di testo.... :lol: :lol: :lol:
pippoZzz
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: mar mar 13, 2007 4:19

Messaggioda pippoZzz » mer mar 14, 2007 1:23

Ok dopo ore e ore di lavoro sono a metà strada e gia mi sento un figo... 8) 8)

Mi sono reistallato i font che ho trovato sul DVD della slamd64.....

Adesso startx avvial KDE ma mancano alcune scritte....
e.g. Quando faccio un download fa firefox non riesco a leggere il nome delle directory del filesystem oppure non vedo nulla nelle proprietà di gkrellm :shock:

Fastidiosissimo ma almeno in parte va...

Se avvio startx da remoto (anche da locale ma nn lo vedrei.. he he ) mi da quest'errore...

-scusate la lunghezza-

(==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 14 02:19:27 2007
(==) Using config file: "/etc/X11/xorg.conf"

xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc/pc(pc105)+pc/us" };
xkb_geometry { include "pc(pc105)" };
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
xset: bad font path element (#312), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
xset: bad font path element (#312), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
startkde: Starting up...
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
kbuildsycoca running...
QFont::setPointSize: Point size <= 0 (-3)
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc/pc(pc104)+pc/it" };
xkb_geometry { include "pc(pc104)" };
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
KWrited - Ascolto il dispositivo /dev/pts/1
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
X Error: BadMatch (invalid parameter attributes) 8
Major opcode: 156
Minor opcode: 6
Resource id: 0x138
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!
couldn't open fontconfigs chosen font with Xft!!!

Non so cosa mi manca ancora....
Pleaze help me... :cry: :cry: :cry: :cry:
pippoZzz
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: mar mar 13, 2007 4:19

Messaggioda prometeo79 » mer mar 14, 2007 9:16

azz....colpa mia!
Mi son dimenticato che tra i pacchetti di xorg 7.1 non ci sono quelli dei font.
Da http://mirror.vbfx.com/slamd64/slamd64- ... ackware/x/
installa i pacchetti dei font di xorg 6.9 (x11-fonts-100dpi-6.9.., x11-fonts-cyrillic-6.9.., ecc).
Così dovrebbe partire
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda pippoZzz » mer mar 14, 2007 14:39

Ok... kde funzica bene mi sembra... he he erano proprio i font che scazzavano ;) ;)

Fatto ciò ho provato ad installare beryl...

Altra cosa che non va....

Ho capito come fare con i .SlackBuild (prima li compilo cn sh ./??? poi installpkg del pacchetto che ho scoperto finire in /tmp...)

Riavvio kde e non trovo beryl-manager... trovo solo beryl e se provo ad runnarlo mi spariscono le barre superiori delle finestre e non rieco piu a fare nulla...

Cosa dovrei fare con i .bz2 scaricati dal secondo link??

Oltretutto adesso ho un discreto puttanaio sul pc e sara un bel casino mettere e togliere cose ma ce la devo fare... solo non ho ben capito la relazione tra .SlackBuild e .bz2.... non per tutti c'è sia lo slackbuild che il bz2...

Non so che altro fare... sento che sono vicino alla soluzione...

altra cosa che non so è: devo instalare anche 32misc-1.0-x86_64-1jh.tgz?? se si prima o dopo beryl-core??

PS ho fatto tutto con kde aperto... qualcosa mi dice che non è stata un'ideona vero??
pippoZzz
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: mar mar 13, 2007 4:19

Messaggioda prometeo79 » mer mar 14, 2007 15:01

Allora, piano.

Se avvii beryl è normale che ti spariscano tutte le barre perchè non ti carica nessun tema.
Una volta compilati e installati i pacchetti .tgz, i .bz2 e gli slackbuild li puoi anche buttarli. Prima però capiamo se funziona tutto a dovere.
Il pacchetto 32misc non ricordo se l'ho caricato o meno, indago sulla sua utilità e ti dico.

Che vuol dire che non parte beryl-manager? Se lo lanci da console ti da errore? Se si, quale? Se no, dovrebbe apparirti un diamante rosso vicino all'orologio sulla barra delle applicazioni.


P.S. Qui la spiegazione degli slackbuild
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda pippoZzz » mer mar 14, 2007 15:10

Allora....

ho installato gli slackbuild ma il comando beryl-manager non lo trovo proprio... non è che mi da errore... non c'è...

per quanto riguarda i bz2 non so proprio come installarli...

La mia confusione è nata con il vedre gli stessi nomi (tipo beryl-manager) sia slackbuoild che bz2....

altra cosa: dopo aver installato emerald-theme installo tutto il resto (tipo aquamarine-0.1.4.tar.bz2, fglrx.SlackBuild, heliodor-0.1.4.tar.bz2, libwnck.SlackBuild, x11.SlackBuild) senza seguire un ordine in particolare o installo solo quello che hai listato tu in quell'ordine ben preciso??

scusa se continuo ma non so più dove mettere le mani...
pippoZzz
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: mar mar 13, 2007 4:19

Messaggioda prometeo79 » mer mar 14, 2007 15:58

No aspetta, siamo completamente fuori strada.

Riiniziamo dal punto 4.

Apri una shell, ti sposti nella directory di beryl e digiti

sh ./beryl-core.SlackBuild

lo slackbuild decomprime il file bz2, compila il suo contenuto e ti crea il pacchetto .tgz. Fatto questo in /tmp trovi il file beryl-core.0.1.4-x86_64-jh.tgz e del file beryl-core.0.1.4.bz2 e dello slackbuild non te ne frega più nulla.

Ora ti sposti in /tmp/ e dai installpkg beryl-core.0.1.4-x86_64-jh.tgz.

Poi ritorni nella directory dove ci sono gli slackbuild e dai sh ./beryl-settings.slackbuild, finita la compilazione ti sposti in /tmp e dai installpkg beryl-settings.0.1.4-x86_64-jh.tgz.

Pio fai la stessa cosa con beryl-plugins .slackbuild, poi con emerald.slackbuild e poi con emerald-themes.slackbuild.

Hai fatto tutte queste cose? Degli altri pacchetti non ti preoccupare, inizia a fare questo.
Se non capisci qualcosa chiedi prima di fare casino sul pc
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda pippoZzz » mer mar 14, 2007 16:12

Già fatto :?

allora... tanto per... ecco quello che ho fatto...

ho scompattatto i bz2...
./configure
make
make install

quando ho fatto emerald il configure m'ha detto che non trova gtk pangocairo libwnck e xrender.... quindi per prima cosa ho utilizzato libwnck.slackbuild ma sembra non aver fatto nulla difatti l'errore rimane...

letto il tuo post.... :shock: :shock: :shock: :shock:

ripreso dallo shok...:shock: :shock: :shock: :shock: :shock: :shock: :shock:

raccolto da terra tutto quello che ho lanciato....

considerato che non per tutti gli slackbuild c'è il relativo bz2...

considerato che prima avevo fatto cosi ma non sapevo a che punto fare lo slackbuild di libwnck.slackbuild fglrx.slackbuild x11.slackbuild e quando installare 32misc*.tgz

sto pensando a come rimettere tutto apposto....
__________________________________________-

libwnck.slackbuild fglrx.slackbuild x11.slackbuild non necessitano dei relativi *.bz2??

perche il primo solo con lo slackbuild non installa nulla... o almeno credo...
pippoZzz
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: mar mar 13, 2007 4:19

Messaggioda prometeo79 » mer mar 14, 2007 16:34

Che casino... :D

Gli slackbuild sono solo script. Se non hai una scheda ati fglrx non ti serve a nulla, x11.slackbuild serve a compilare i pacchetti di xorg 7.1 e se li hai già installati non ti serve

Allora i pacchetti pango, cairo e gtk li trovi sotto

http://mirror.vbfx.com/slamd64/slamd64- ... ackware/l/

prima di installarli controlla che davvero non ci siano sul tuo pc.

libwnck puoi prenderlo da qui

http://ftp.cgu.edu.tw/Mirror/linuxpacka ... 4-1frg.tgz

Installati questi pacchetti esegui gli slackbuilds
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Prossimo

Torna a Porting Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

cron