Repository 32bit  Forum
Repository 64bit  Wiki

ASUS A2 - Guida al config del wimodem con i driver SmartLink

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

ASUS A2 - Guida al config del wimodem con i driver SmartLink

Messaggioda agallin » dom apr 29, 2007 20:33

Riscrivo questa guida, dall' esempio di Astragalo riguardo Mandrake http://www.mandrakeitalia.org/userinfo.php?uid=681, in seguito all' esperienza personale sul mio portatile e soprattutto per incominciare a sentirrmi un pò OPEN ...:D ! Questa guida è dedicata a tutti quelli che dopo vari tentativi ancora non sono riusciti a far lavorare il loro winmodem con SlackWare su ASUS A2 (penso valida anche in altre situazioni simili).

Preciso di non essere un esperto quindi in caso ho commesso qualche errore che può compromettere il sistema ò per suggerimenti e consigli sulla guida, gli esperti non esitassero.

<--------------------------------------------------------------------------------------------------------

Punto primo bisogna scaricare il driver slmodem-2.9.11 da qui:

http://linmodems.technion.ac.il/packages/smartlink/
http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20070204.tar.gz


Per l' installazione di tutti i driver, è necessario aver installato i sorgenti del kernel, ed è importante che siano quelli del vostro kernel in utilizzo.

Una volta in possesso del driver, (io l'ho posizionato nella home) è necessario decomprimerlo, per fare ciò aprire un terminale decomprimetelo con il seguente comando:

[utente@localhost]$ tar -zxvf slmodem-2.9.11-20070204.tar.gz


oppure tasto destro estrai qui.

Una volta decompresso il driver si può operare come riportato sul readme dello stesso.

Le operazioni di seguito riportate vengono eseguite da terminale.

Consiglio ai meno esperti di partire con una macchina appena avviata per evitare problemi dovuti a tentativi precedenti.


Spostarsi all'interno della directory del driver:

[utente@localhost]$cd slmodem-2.9.11-20070204


e lanciare i comandi:

[utente@localhost slmodem-2.9.11-20070204]$ make clean


e

[utente@localhost slmodem-2.9.11-20070204]$ make


loggarsi come root:

[utente@localhost slmodem-2.9.11-20070204]$ su


seguito dalla password, e dare il comando:

[root@localhost slmodem-2.9.11-20070204]# make install


Installato il driver è necessario aggiungere sul file /etc/modprobe.conf le seguenti due righe:

alias char-major-212 slamr
alias char-major-213 slusb

Per fare ciò è necessario editare il file come root.

Adesso bisogna copiare lo script d'avvio rc.slmodemd che si trova nella directory del modem /scripts/slackware/ e posizionarlo nella directory /etc/rc.d/.

Avviare il modem con il comando:

[root@localhost slmodem-2.9.11-20070204]# /etc/rc.d/rc.slmodemd start

dovremo aver ottenuto un OK all'esecuzione del comando.

Per la configurazione con PPP o Kppp consiglio vivamente di documentarsi tramite La guida Slackware For Dummies S4D che trovate su Slacky. In linea di massima, se come me, usate KPPP, bisogna creare un link al device con:

[root@localhost slmodem-2.9.11-20070204]# ln -s /dev/ttySL0 /dev/modem

disattivare il controllo di linea (attendi il segnale...), di portare il tempo di attesa per la ricomposizione almeno a cinque secondi, ed il timeout modem a 60 secondi.

Purtroppo al riavvio il modem non verrà più riconosciuto e dovrete rieseguire tutta l'operazione.... scherzo! :D
Per evitare appunto questo inconveniente dovrete apportare iin cima allo script di avvio del modem "/etc/rc.d/rc.slmodemd" le seguenti modifiche:
Cambiare
SLMODEMD_DEVICE=/dev/slusb0
in
SLMODEMD_DEVICE=/dev/slamr0

ed aggiungere alle prime righe successive:

mknod -m 600 /dev/slamr0 c 242 0 ; mknod -m 600 /dev/slamr1 c 242 1 ; mknod -m 600 /dev/slamr2 c 242 2 ; mknod -m 600 /dev/slamr3 c 242 3 ; echo -n
mknod -m 600 /dev/slusb0 c 243 0 ; mknod -m 600 /dev/slusb1 c 243 1 ; mknod -m 600 /dev/slusb2 c 243 2 ; mknod -m 600 /dev/slusb3 c 243 3 ; echo -n

Serve inoltre avviare il modulo e generare il link al device in fase di avvio quindi aggiungere in /etc/rc.d/rc.local le relative seguenti righe:

/etc/rc.d/rc.slmodemd start
ln -s /dev/ttySL0 /dev/modem

Per l' uso da parte degli utenti non dimenticate di aggiungere questi al gruppo uucp e di decommentare la riga (= togliere il segno # davanti ad una riga): #noauth
all' interno di
/etc/ppp/options
-------------------------------------------------------------------------------------------------------->

Ecco fatto, ...a me funziona! ;)
Se a qualcuno torna utile potreste segnalarmelo in questo post, Grazie!
Ciao a tutti
agallin
Linux 1.0
Linux 1.0
 
Messaggi: 19
Iscritto il: gio apr 19, 2007 19:47
Località: Napoli

Messaggioda michele.p » dom apr 29, 2007 21:32

...inserisci la guida direttamente nel wiki...qui con l'incedere del tempo (..e dei messaggi) tende a "perdersi"....

Bye
Avatar utente
michele.p
Packager
Packager
 
Messaggi: 1275
Iscritto il: ven nov 24, 2006 16:52
Località: Pontecorvo(FR)
Nome Cognome: Michele Petrecca
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE
Distribuzione: ..Fedora e Mandriva

Messaggioda agallin » lun apr 30, 2007 12:40

;) infatti!
8) ok, ...provo!
:) ciao
agallin
Linux 1.0
Linux 1.0
 
Messaggi: 19
Iscritto il: gio apr 19, 2007 19:47
Località: Napoli

Re: ASUS A2 - Guida al config del wimodem con i driver SmartLink

Messaggioda P3RUGINO1 » gio gen 29, 2009 12:27

per caso qualcuno è riuscito a compilare slusb su kernel 2.6.8.x???
P3RUGINO1
Linux 2.4
Linux 2.4
 
Messaggi: 281
Iscritto il: dom lug 10, 2005 23:00


Torna a Laptop

Chi c’è in linea

Visitano il forum: Bing [Bot] e 3 ospiti