Repository 32bit  Forum
Repository 64bit  Wiki

[GNOME 2.18.1] Gravi problemi -RISOLTO-

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Messaggioda gohanz » mer mag 16, 2007 19:52

Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda submax82 » mer mag 16, 2007 20:13



c'è anche una patch

cioè per questo

There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

The name org.gnome.SettingsDaemon was not provided by any .service files

GNOME will still try to restart the Settings Daemon next time you log in.


Codice: Seleziona tutto
--- gnome-settings-daemon/gnome-settings-dbus.c 2007-05-01 15:49:23.000000000 -0400
+++ gnome-settings-daemon/gnome-settings-dbus.c 2007-05-01 15:47:44.000000000 -0400
@@ -221,9 +221,13 @@
        if (!org_freedesktop_DBus_request_name
            (driver_proxy, "org.gnome.SettingsDaemon", 0, &request_ret,
             &error)) {
- g_warning ("Unable to register service: %s",
- error->message);
- g_error_free (error);
+ if (error != NULL) {
+ g_warning ("Unable to register service: %s",
+ error->message);
+ g_error_free (error);
+ } else {
+ g_warning ("Unable to register service because of unknown DBUS error");
+ }
        }

        g_object_unref (driver_proxy);


risolverà il problema?
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Messaggioda stan » mer mag 16, 2007 21:39

Ma sono l'unico con quel problema qua?
La patch andrebbe applicata a controlcenter-2.18.0 o controlcenter-2.18.1?
Perchè ho visto che nell'ultima gnome slacky c'e' controlcenter-2.18.0.
E poi....bisogna passare qualche param al configure o è sufficiente ./configure && make && make install?

Io ho provato ma ho fatto un pò di casini mi sa... :roll:
Non è che potete pacchettizzare controlcenter patchato e dirmi che passi fare?
Io ora disinstallo gnomeslacky e la reinstallo....poi disinstallo il control center compilato da me.
Se qualcuno ha risolto lanci un urlo...
Avatar utente
stan
Linux 2.6
Linux 2.6
 
Messaggi: 524
Iscritto il: lun dic 25, 2006 11:55
Località: Bs
Slackware: 12.1
Kernel: 2.6.xx
Desktop: Kde3

Messaggioda submax82 » gio mag 17, 2007 0:54

aspetta... fai fare il pacchetto a gohanz... applicherà lui la patch...

il bug è in gnome-settings-daemon
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Messaggioda gohanz » gio mag 17, 2007 8:02

stan ha scritto:Ma sono l'unico con quel problema qua?
La patch andrebbe applicata a controlcenter-2.18.0 o controlcenter-2.18.1?
Perchè ho visto che nell'ultima gnome slacky c'e' controlcenter-2.18.0.
E poi....bisogna passare qualche param al configure o è sufficiente ./configure && make && make install?

Io ho provato ma ho fatto un pò di casini mi sa... :roll:
Non è che potete pacchettizzare controlcenter patchato e dirmi che passi fare?
Io ora disinstallo gnomeslacky e la reinstallo....poi disinstallo il control center compilato da me.
Se qualcuno ha risolto lanci un urlo...


Stan controlcenter è nella versione 2.18.0 anche in Gnome 2.18.1! http://ftp.gnome.org/pub/GNOME/desktop/ ... 1/sources/ mi sembra che la versione di Gslacky 2.18.0 ti girasse correttamente vero?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda submax82 » gio mag 17, 2007 9:58

@gohanz

prova quella patch....! :D
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Messaggioda stan » gio mag 17, 2007 10:40

gohanz ha scritto:Stan controlcenter è nella versione 2.18.0 anche in Gnome 2.18.1! http://ftp.gnome.org/pub/GNOME/desktop/ ... 1/sources/ mi sembra che la versione di Gslacky 2.18.0 ti girasse correttamente vero?

La 2.18.0 l'avevo installata su un altro portatile e non avevo problemi.
La 2.18.1 l'ho installata su un portatile diverso. Quindi non ho fatto un upgrade dalla 2.18.0 ma un'installazione ex-novo.
Ovviamente su una slack 11.
Se puoi provare a creare un controlcenter patchato potrei riprovare.
Ops...Io avevo provato a patchare i sorgenti di control center control-center-2.18.1.tar.bz2

Se riesci ad essere così gentile da crearmi il tgz di control-center-2.18.0 patchato poi lo provo.
Cosi almeno siamo sicuri che il pacchetto controlcenter patchato e installato è corretto!
Avatar utente
stan
Linux 2.6
Linux 2.6
 
Messaggi: 524
Iscritto il: lun dic 25, 2006 11:55
Località: Bs
Slackware: 12.1
Kernel: 2.6.xx
Desktop: Kde3

Messaggioda gund4m » gio mag 17, 2007 10:46

ho trovato un'altro pacchettino che potrebbe tornare utile per gnomeslacky..

Gsynaptics pero' manca solo una libreria per poter essere compilato...
Glitz che io ho preso da dropline in quanto non riescivo a compilarla...

una domanda...

visto che avete messo hal ... dov'e' il file in cui si puo' specificare di montare i filesystem ntfs con ntfs-3g?

con dropline stava in /usr/share/hal ma ora non lo trovo + ...

pls help
Avatar utente
gund4m
Linux 1.0
Linux 1.0
 
Messaggi: 33
Iscritto il: mer mag 09, 2007 19:26

Messaggioda gohanz » gio mag 17, 2007 10:54

Glitz ce l'ho, non l'ho inserito in quanto l'unico pacchetto che l'usava è cairo, ma in maniera molto Alpha! Per Gsynaptics posso provare infine per Ntfs-3g, io uso modificare direttamente /etc/fstab!

Dai anche un'occhiata al Wiki! http://www.slacky.eu/forum/viewtopic.php?t=18779
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gund4m » gio mag 17, 2007 11:02

quale wiki?....
Avatar utente
gund4m
Linux 1.0
Linux 1.0
 
Messaggi: 33
Iscritto il: mer mag 09, 2007 19:26

Messaggioda gohanz » gio mag 17, 2007 11:04

gund4m ha scritto:quale wiki?....


http://www.slacky.eu/wikislack/index.ph ... al_ntfs-3g

Gsynaptics a me compila senza problemi!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gund4m » gio mag 17, 2007 11:16

ma il problema non e' gsynaptics ma glitz... non riesco a compilare glitz.. ma ho risolto mettendo il pkg di dropline...
Avatar utente
gund4m
Linux 1.0
Linux 1.0
 
Messaggi: 33
Iscritto il: mer mag 09, 2007 19:26

Messaggioda gohanz » gio mag 17, 2007 11:32

gund4m ha scritto:ma il problema non e' gsynaptics ma glitz... non riesco a compilare glitz.. ma ho risolto mettendo il pkg di dropline...


Non saprei a me non da nessun particolare problema in compilazione! Comnque lo inserirò nella revisione della 2.18.1!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda Cenni » gio mag 17, 2007 18:28

@gohanz
scusa se non ti ho informato sul risultato dei tuoi consigli, (il problema permaneva ossia il tutto funzionava solo da root), ma nel frattempo mi è caduto il portatile a terra e ho rotto il monitor.. Gnome a quel punto per me è diventato secondario.
Sarai già stufo dei ringraziamenti, ma lo stesso grazie sia per il tuo lavoro sia per la tua disponibilità.
Avatar utente
Cenni
Linux 2.0
Linux 2.0
 
Messaggi: 104
Iscritto il: mar feb 27, 2007 15:12
Località: Torino
Nome Cognome: Cenni
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: XFCE
Distribuzione: salix e puppeee

Messaggioda gohanz » gio mag 17, 2007 18:44

Cenni ha scritto:@gohanz
scusa se non ti ho informato sul risultato dei tuoi consigli, (il problema permaneva ossia il tutto funzionava solo da root), ma nel frattempo mi è caduto il portatile a terra e ho rotto il monitor.. Gnome a quel punto per me è diventato secondario.
Sarai già stufo dei ringraziamenti, ma lo stesso grazie sia per il tuo lavoro sia per la tua disponibilità.


Stiamo lavorando con Submax per risolvere il problema, spero che tu non abbia spaccato il poratile per i nervi! :D ;)
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

PrecedenteProssimo

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron