Repository 32bit  Forum
Repository 64bit  Wiki

gnome: come renderlo in italiano

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

gnome: come renderlo in italiano

Messaggioda slucky » ven mag 25, 2007 18:40

Salve a tutti,oggi ho installato gnome-slacky e devo dire che funziona benissimo....anche meglio della versione nativa che uso su Ubuntu Feisty :D ,quindi prima di tutto i miei complimenti vivissimi per il grande e ottimo lavoro a tutti gli sviluppatori =D> .
Ora mi resta solo questo da sistemare, renderlo in lingua italiana, ce qualche pacchetto da installare o cosa?

Ciao e buona Slack-Gnome a tutti!!! :D
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2378
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: gnome: come renderlo in italiano

Messaggioda gohanz » ven mag 25, 2007 18:51

slucky ha scritto:Salve a tutti,oggi ho installato gnome-slacky e devo dire che funziona benissimo....anche meglio della versione nativa che uso su Ubuntu Feisty :D ,quindi prima di tutto i miei complimenti vivissimi per il grande e ottimo lavoro a tutti gli sviluppatori =D> .
Ora mi resta solo questo da sistemare, renderlo in lingua italiana, ce qualche pacchetto da installare o cosa?

Ciao e buona Slack-Gnome a tutti!!! :D


Basta che modifichi /etc/profile.d/lang.sh così

Codice: Seleziona tutto
# en_US is the Slackware default locale:
export LANG=it_IT@euro


E grazie per il feedback!! :D
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda slucky » ven mag 25, 2007 22:47

Perfetto Gohanz :D ............pero ehmmm..la tastiera risulta essere ancora quella americana, per ccambiarla sempre nello stesso file devo modificare.

Ciao e grazie dell'aiuto :D
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2378
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Messaggioda gohanz » sab mag 26, 2007 7:23

Per la tastiera Italiana, puoi usare l'applet in preferenze > tastiera!

Oppure vai direttamamente a modificare /etc/X11/xorg.conf manualmente o usando xorgconfig.

Per info più dettagliate leggi la pag 60 e la pagina 67 di Slackware 4 Dummies!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda slucky » sab mag 26, 2007 11:11

Grazie per la risposta Gohanz....comunque già ieri sera ho risolto modificando infatti xorg.conf, ora funziona anche la tastiera italiana.....quindi tutto a posto e ancora complimenti per l'ottimo lavoro svolto con Gnome :D

Diciamo che ora mi sento proprio a casa........visto che da sempre uso lo Gnomo :D .prima su Debian ora su Ubuntu.....ed ora anche su Slackware 11 :o

Ciao e buona Gnome-Slacky a tutti!!!
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2378
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Messaggioda korkiras » mar giu 19, 2007 6:18

ho modificato il mio lang.sh cosi
#!/bin/csh
# Set the system locale. (no, we don't have a menu for this ;-)
# For a list of locales which are supported by this machine, type:
# locale -a

# en_US is the Slackware default locale:
export LANG=it_IT@euro

# 'C' is the old Slackware (and UNIX) default, which is 127-bit
# ASCII with a charmap setting of ANSI_X3.4-1968. These days,
# it's better to use en_US or another modern $LANG setting to
# support extended character sets.
#setenv LANG C

# There is also support for UTF-8 locales, but be aware that
# some programs are not yet able to handle UTF-8 and will fail to
# run properly. In those cases, you can set LANG=C before
# starting them. Still, I'd avoid UTF unless you actually need it.
#setenv LANG it_IT.UTF-8

# Another option for en_US:
#setenv LANG en_US.ISO8859-1

# One side effect of the newer locales is that the sort order
# is no longer according to ASCII values, so the sort order will
# change in many places. Since this isn't usually expected and
# can break scripts, we'll stick with traditional ASCII sorting.
# If you'd prefer the sort algorithm that goes with your $LANG
# setting, comment this out.
setenv LC_COLLATE C

# End of /etc/profile.d/lang.csh



lingua italiana da nessuna parte , tastiera rimasta us
:?
korkiras
Linux 2.4
Linux 2.4
 
Messaggi: 476
Iscritto il: gio nov 23, 2006 18:14
Località: Κέρκυρα , Hellas
Slackware: 12.2

Messaggioda gohanz » mar giu 19, 2007 6:56

korkiras ha scritto:ho modificato il mio lang.sh cosi
#!/bin/csh
# Set the system locale. (no, we don't have a menu for this ;-)
# For a list of locales which are supported by this machine, type:
# locale -a

# en_US is the Slackware default locale:
export LANG=it_IT@euro

# 'C' is the old Slackware (and UNIX) default, which is 127-bit
# ASCII with a charmap setting of ANSI_X3.4-1968. These days,
# it's better to use en_US or another modern $LANG setting to
# support extended character sets.
#setenv LANG C

# There is also support for UTF-8 locales, but be aware that
# some programs are not yet able to handle UTF-8 and will fail to
# run properly. In those cases, you can set LANG=C before
# starting them. Still, I'd avoid UTF unless you actually need it.
#setenv LANG it_IT.UTF-8

# Another option for en_US:
#setenv LANG en_US.ISO8859-1

# One side effect of the newer locales is that the sort order
# is no longer according to ASCII values, so the sort order will
# change in many places. Since this isn't usually expected and
# can break scripts, we'll stick with traditional ASCII sorting.
# If you'd prefer the sort algorithm that goes with your $LANG
# setting, comment this out.
setenv LC_COLLATE C

# End of /etc/profile.d/lang.csh



lingua italiana da nessuna parte , tastiera rimasta us
:?



La tastiera viene configurata in /etc/X11/xorg.conf! In /etc/profile.d/lang.sh viene cambiata la localizzazione dei programmi! Per intenderdi cambiano le voci dall'inglese di default all'italiano!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda korkiras » mar giu 19, 2007 7:04

ho capito grazie , che cosa cambio a xorg.conf ?
korkiras
Linux 2.4
Linux 2.4
 
Messaggi: 476
Iscritto il: gio nov 23, 2006 18:14
Località: Κέρκυρα , Hellas
Slackware: 12.2

Messaggioda gohanz » mar giu 19, 2007 7:07

Questa è la mia sezione di xorg.conf che regola la tastiera Italiana!

Puoi anche usare xorgconfig, se non vuoi modicare a mano!

Codice: Seleziona tutto
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "compaqeak8"
    Option "XkbLayout"   "it"

EndSection
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda mauro » mer giu 20, 2007 12:50

sei sicuro che sia il lang.sh?

queste due righe mi insospettiscono un po'...

Codice: Seleziona tutto
#!/bin/csh
...
# End of /etc/profile.d/lang.csh
Avatar utente
mauro
Linux 2.4
Linux 2.4
 
Messaggi: 281
Iscritto il: gio mag 11, 2006 20:51
Slackware: current
Kernel: uno degli ultimi...
Desktop: dwm

Messaggioda submax82 » mer giu 20, 2007 13:07

mauro ha scritto:sei sicuro che sia il lang.sh?

queste due righe mi insospettiscono un po'...

Codice: Seleziona tutto
#!/bin/csh
...
# End of /etc/profile.d/lang.csh


leggi S4D
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Messaggioda panduz » lun ott 08, 2007 8:07

scusate se riuppo il topic, ma facendo quello che avete indicato, gnome è in italiano solo per l'utente root, mentre per l'user normale no, qualcuno mi sa dire come renderlo italiano anche per quest'ultimo?

Grazie e complimenti ancora a tutto lo staff che lavora dietro a questo progetto

:mille:
Avatar utente
panduz
Linux 1.0
Linux 1.0
 
Messaggi: 69
Iscritto il: ven mar 24, 2006 19:16
Località: Caraglio (CN)
Slackware: 12.0


Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti