Repository 32bit  Forum
Repository 64bit  Wiki

font e terminale root

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Messaggioda 6C33C » dom mag 27, 2007 8:02

Sembra un problema legato ad HAL e Dbus! Fai una cosa, installa l'ultima versione di HAL presente su Slacky! E aggiungi il tuo user al gruppo "plugdev". Dalla versione 0.5.9 di Hal, il paccheto di Slacky si è adeguato alle direttive della current! Quindi passando dal gruppo "mounters" al gruppo"plugdev"


Ancora no l' ho installato adesso provo .....
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Messaggioda gohanz » dom mag 27, 2007 8:16

6C33C ha scritto:
Sembra un problema legato ad HAL e Dbus! Fai una cosa, installa l'ultima versione di HAL presente su Slacky! E aggiungi il tuo user al gruppo "plugdev". Dalla versione 0.5.9 di Hal, il paccheto di Slacky si è adeguato alle direttive della current! Quindi passando dal gruppo "mounters" al gruppo"plugdev"


Ancora no l' ho installato adesso provo .....


Ok va bene! Un'altra cosa che kernel usi?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda 6C33C » dom mag 27, 2007 8:41

Allora ho installato hal 0.5.9 e hal info
ma l'errore ancora rimane ..

l' output dei 2 comandi è questo :
bash-3.1# ldd /usr/libexec/gnome-settings-daemon | grep missing
bash-3.1# ps aux | grep dbus
1002 2560 0.0 0.1 2284 912 ? Ss 09:28 0:00 /usr/bin/dbus-daemon --system
giorgio 2693 0.0 0.1 2152 996 ? S 09:29 0:00 dbus-daemon --session --print-address --nofork
giorgio 2896 0.0 0.1 2156 1000 ? S 09:31 0:00 dbus-daemon --session --print-address --nofork
giorgio 3005 0.0 0.1 2152 996 ? S 09:33 0:00 dbus-daemon --session --print-address --nofork
giorgio 3454 0.0 0.1 2152 832 ? Ss 09:38 0:00 /usr/bin/dbus-daemon --fork --print-pid 4 --print-address 6 --session
giorgio 3455 0.0 0.0 2528 652 tty1 S 09:38 0:00 dbus-launch --sh-syntax --exit-with-session
giorgio 3480 0.0 0.1 2152 996 ? S 09:38 0:00 dbus-daemon --session --print-address --nofork
root 3783 0.0 0.1 2052 788 pts/1 R+ 09:41 0:00 grep dbus


per il kernel è huge26.s

ho fatto una prova diminuendo i punti per pollice in dettagli
cosi rimpicciolisce il carattere e sembra non dare nessun problema.
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Messaggioda gohanz » dom mag 27, 2007 8:45

6C33C ha scritto:Allora ho installato hal 0.5.9 e hal info
ma l'errore ancora rimane ..

l' output dei 2 comandi è questo :
bash-3.1# ldd /usr/libexec/gnome-settings-daemon | grep missing
bash-3.1# ps aux | grep dbus
1002 2560 0.0 0.1 2284 912 ? Ss 09:28 0:00 /usr/bin/dbus-daemon --system
giorgio 2693 0.0 0.1 2152 996 ? S 09:29 0:00 dbus-daemon --session --print-address --nofork
giorgio 2896 0.0 0.1 2156 1000 ? S 09:31 0:00 dbus-daemon --session --print-address --nofork
giorgio 3005 0.0 0.1 2152 996 ? S 09:33 0:00 dbus-daemon --session --print-address --nofork
giorgio 3454 0.0 0.1 2152 832 ? Ss 09:38 0:00 /usr/bin/dbus-daemon --fork --print-pid 4 --print-address 6 --session
giorgio 3455 0.0 0.0 2528 652 tty1 S 09:38 0:00 dbus-launch --sh-syntax --exit-with-session
giorgio 3480 0.0 0.1 2152 996 ? S 09:38 0:00 dbus-daemon --session --print-address --nofork
root 3783 0.0 0.1 2052 788 pts/1 R+ 09:41 0:00 grep dbus


per il kernel è huge26.s

ho fatto una prova diminuendo i punti per pollice in dettagli
cosi rimpicciolisce il carattere e sembra non dare nessun problema.


Dbus gira correttamente, qual'è il carattere che crea problemi?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda 6C33C » dom mag 27, 2007 8:58

Il carattere è quello di default cioè " Sans "

Non avevo bisogno di cambiare il tipo di carattere ma solo la sua dimensione e

portarla da 10 a 9

comunque l' errore esce fuori anche cambiando il tipo di font...

Se può essere di auto l' installazione è una full con kernel huge26.s senza nessuna modifica , poi ho installato tutte le ultime patch e in ultimo lo gnome nella versione full.

grazie ancora per la tua pazienza :D
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Messaggioda gohanz » dom mag 27, 2007 9:00

Prova con questi comandi da shell!


Codice: Seleziona tutto
gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders


e

Codice: Seleziona tutto
gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules


Vediamo se riusciamo a risolvere!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda 6C33C » dom mag 27, 2007 9:31

Niente il problema rimane :?
inoltre se tento di riportare il font alle dimensioni originali
oltre a tante finestre di crash ho questa scherma
Immagine

ma poi il gestore compare e posso riportare tutto come in origine.

nb l' immagine è delle 9:35 ma non pensavo fosse importante , se lo era chiedo scusa :oops:
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Messaggioda gohanz » dom mag 27, 2007 10:39

6C33C ha scritto:Niente il problema rimane :?
inoltre se tento di riportare il font alle dimensioni originali
oltre a tante finestre di crash ho questa scherma
Immagine

ma poi il gestore compare e posso riportare tutto come in origine.

nb l' immagine è delle 9:35 ma non pensavo fosse importante , se lo era chiedo scusa :oops:


Ma non è che hai toccato qualcosa riguardo X? Hai la versione della 11.0 oppure sei passato alla versione della current?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda 6C33C » dom mag 27, 2007 11:15

No no della current non ho installato niente !!!

Descrivo come ho fatto la mia installazione così da dare una eventuale via alla risoluzione del problema
1) ho installato la 11.0 completa di tutti i pacchetti , kernel huge26.s

2) al reboot ho installato kernel-headers e kerrnel-modules + kernel-sources
dagli extra/linux-2.6.17.13

3) ho configurato xorg.conf con xorgsetup e con mc modificato alcune cose
che non prende in automatico ( vedi Modes "1280x1024.... e Option ZaxisMapping )

4) ho scaricato e installato tutte le patches con upgradepkg --install-new *tgz
da init 3

5) poi verificato che si tutto aposto con kde ho installato lo gnomo da init3
fatto questo ho riavviato ed entrato in gnome da gdm.

Se vuoi posso riprovare a reinstallare tutto , tanto l' ho stavo provando su un atlhon x p1800 che appunto uso x fare le prove " scusa le ripetizioni " :D

scusa ma ho modificato perchè mi ero scordato le patches ore 12:30 circa
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Messaggioda gohanz » dom mag 27, 2007 16:49

6C33C ha scritto:No no della current non ho installato niente !!!

Descrivo come ho fatto la mia installazione così da dare una eventuale via alla risoluzione del problema
1) ho installato la 11.0 completa di tutti i pacchetti , kernel huge26.s

2) al reboot ho installato kernel-headers e kerrnel-modules + kernel-sources
dagli extra/linux-2.6.17.13

3) ho configurato xorg.conf con xorgsetup e con mc modificato alcune cose
che non prende in automatico ( vedi Modes "1280x1024.... e Option ZaxisMapping )

4) ho scaricato e installato tutte le patches con upgradepkg --install-new *tgz
da init 3

5) poi verificato che si tutto aposto con kde ho installato lo gnomo da init3
fatto questo ho riavviato ed entrato in gnome da gdm.

Se vuoi posso riprovare a reinstallare tutto , tanto l' ho stavo provando su un atlhon x p1800 che appunto uso x fare le prove " scusa le ripetizioni " :D

scusa ma ho modificato perchè mi ero scordato le patches ore 12:30 circa



Allora secondo me il problema sta in Dbus! Ora sappiamo che il demone gira correttamanente da
Codice: Seleziona tutto
ps -aux | grep dbus
, mentre probabilemente il client
dbus-launch
non viene lanciato all'avvio del dekstop!

Puoi fare un semplice test, dai da shell questi comandi a desktop avviato!

Codice: Seleziona tutto
dbus-launch --sh-syntax --exit-with-session


e poi

Codice: Seleziona tutto
/usr/libexec/gnome-settings-daemon



Controlla se Gnome torna a funzionare! Questi comandi vengono eseguiti dallo script xinintrc, ora devo capire il perchè con te non vengono eseguiti!




Se puoi, alla fine, fare un test! Ovvero rifare l'installazione, ma dopo aver installato la 11.0, non avviare KDE per primo! Quindi fai l'installazione della 11.0, installi Gnome e dopo alla fine avvia per primo Gnome !
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda 6C33C » dom mag 27, 2007 21:53

Scusa ma posso risponderti solo ora
impegni di famiglia me lo hanno impedito....
questi sono gli output dei tre comandi :
bash-3.1# ps -aux | grep dbus
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
1002 2559 0.0 0.1 2152 860 ? Ss 22:48 0:00 /usr/bin/dbus-daemon --system
giorgio 2687 0.0 0.1 2156 820 ? Ss 22:49 0:00 dbus-daemon --fork --print-address 18 --print-pid 20 --session
giorgio 2692 0.0 0.0 2740 452 ? S 22:49 0:00 dbus-launch --autolaunch 86c3fc5a5c6ad6a89146990046533f00 --binary-syntax
giorgio 2693 0.0 0.0 2152 740 ? Ss 22:49 0:00 /usr/bin/dbus-daemon --fork --print-pid 6 --print-address 8 --session
giorgio 2716 0.0 0.1 2156 1000 ? S 22:49 0:00 dbus-daemon --session --print-address --nofork
root 2962 0.0 0.1 2048 784 pts/1 R+ 22:52 0:00 grep dbus

bash-3.1# dbus-launch --sh-syntax --exit-with-session
DBUS_SESSION_BUS_ADDRESS='unix:abstract=/var/run/dbus/dbus-BGq5E4c4X6,guid=65f8b4e5e6248a0f8acdcf004659f02c';
export DBUS_SESSION_BUS_ADDRESS;
DBUS_SESSION_BUS_PID=3002;
bash-3.1# /usr/libexec/gnome-settings-daemon
You can only run one xsettings manager at a time; exiting



forse domani sera riprovo ad reinstallare tutto seguendo il tuo consiglio di non avviare kde

Grazie ancora per il supporto
:D
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Messaggioda 6C33C » mer mag 30, 2007 20:07

Dunque ho provato rifare l' installazione 4 volte, cambiando il dvd della slackware, scaricandolo con slackdvd (grazie Loris ), ho riscaricato l' iso di gnome dall' ftp (grazie gnubit ).
Ho provato ad installare gnome senza installare le patches ma l' errore rimane ...... :cry:
Potrebbe essere un prolema hardware ?
Molto probabilmente faccio qualche errore nell' installazione..... :?
Per ora me la tengo così funzia più che bene .
:mille: gohanz per il suppoto.
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Precedente

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Exabot [Bot] e 0 ospiti