Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] Strano errore di xfce4 su slackware 12

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto] Strano errore di xfce4 su slackware 12

Messaggioda marcello » gio lug 05, 2007 11:36

Curiosamente quando setto
Codice: Seleziona tutto
export LANG=it_IT@euro
in /etc/profile.d/lang.sh, xfdesktop, il desktop di xfce, va in crash (segmentation fault).
Se rimetto
Codice: Seleziona tutto
export LANG=en_US
torna tutto a posto.
Succede solo con xfce: altri wm (es WindowMaker) vengono regolarmente italianizzati.
Succede anche ad altri?
Ultima modifica di marcello il gio lug 05, 2007 14:19, modificato 2 volte in totale.
Avatar utente
marcello
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: sab dic 04, 2004 0:00
Località: Messina

Messaggioda meritil » gio lug 05, 2007 11:55

mv /etc/xfce/xdg/xfce4/desktop/xfce-registered-categories.xml.it /etc/xfce/xdg/xfce4/desktop/xfce-registered-categories.xml.ita

;)
meritil
Master
Master
 
Messaggi: 1651
Iscritto il: lun ago 23, 2004 23:00
Slackware: bluewhite64

Messaggioda marcello » gio lug 05, 2007 14:18

Grazie meritil,
ora xfce4 parla perfettamente italiano.
Avatar utente
marcello
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: sab dic 04, 2004 0:00
Località: Messina

Messaggioda meritil » ven lug 06, 2007 0:58

ci sono altre imperfezioni quando lo traduci, tipo il menù impostazioni vuoto mentre permane il menù settings pieno in inglese... appena ho tempo controllo, cmqe ho imparato consultando lo slackbuild del pacchetto di lorys magari ci può dare ulteriori lumi :D
meritil
Master
Master
 
Messaggi: 1651
Iscritto il: lun ago 23, 2004 23:00
Slackware: bluewhite64

Messaggioda serevi » ven lug 06, 2007 8:05

Io uso il pacchetto di PV della ex current .... il problema lo avevo risolto tempo fa, perchè avevo visto che era un BUG di xfce, praticamente per qualche strano motivo .... il file relativi alla traduzione italiana sono di contenuto doppio.

Praticamente:
/etc/xfce/xdg/xfce4/desktop/menu.xml.it
/etc/xfce/xdg/xfce4/desktop/xfce-registered-categories.xml.it

sono doppi nel contenuto, quindi li ho editati e tolto le righe superflue (doppie appunto).
serevi
Linux 1.0
Linux 1.0
 
Messaggi: 95
Iscritto il: mar mag 03, 2005 23:00
Località: Porto Sant'Elpidio (AP)
Slackware: current
Kernel: 2.6.24.7
Desktop: kde 3.5.10

Messaggioda marcello » ven lug 06, 2007 8:10

serevi,
grazie per la segnalazione.
Provvedo anch'io a correggere i file.
Avatar utente
marcello
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: sab dic 04, 2004 0:00
Località: Messina

Messaggioda calicant » ven lug 06, 2007 18:44

molte grazie
ora mi sono ritornate le icone e xfce ha ripreso a gestire il desktop :)
calicant
Linux 1.0
Linux 1.0
 
Messaggi: 2
Iscritto il: ven lug 06, 2007 15:01

Messaggioda meritil » ven lug 06, 2007 18:55

serevi ha scritto:Io uso il pacchetto di PV della ex current .... il problema lo avevo risolto tempo fa, perchè avevo visto che era un BUG di xfce, praticamente per qualche strano motivo .... il file relativi alla traduzione italiana sono di contenuto doppio.

Praticamente:
/etc/xfce/xdg/xfce4/desktop/menu.xml.it
/etc/xfce/xdg/xfce4/desktop/xfce-registered-categories.xml.it

sono doppi nel contenuto, quindi li ho editati e tolto le righe superflue (doppie appunto).



io ho risolto invece editando tramite l'apposito tool rendendo soltanto invisibili i campi doppione... questo perchè appena vai ad aggiornare il pacchetto xfce tutto il lavoro svanisce insieme ai vecchi file.... (per esempio il menu andate ad editare il menu personalizzato nella home almeno questo vi rimane in caso)

resta il fatto che il menù settings rimane e il menu impostazioni è vuoto... sigh.. vabbè cacchiate infatti non mi va nemmeno di imbarcarmi alla ricerca del problema ehehe...
meritil
Master
Master
 
Messaggi: 1651
Iscritto il: lun ago 23, 2004 23:00
Slackware: bluewhite64

Messaggioda submax82 » mar dic 04, 2007 16:27

scusate ma i file non sono in /etc/X11/xdg/xfce4/ ?

come si fà con un comando tipo sed a eliminare le righe doppie?
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite