Repository 32bit  Forum
Repository 64bit  Wiki

Grave problema video con Intel 945GM

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Grave problema video con Intel 945GM

Messaggioda jacobbe » ven lug 27, 2007 16:42

Ciao ragazzi fino all'altro giorno avevo una slack11 con i pacchetti Pinky build di Xorg 7.2 e tutto ok.
Ora ho fatto l'upgrade a Slack12 e con l'occasione ho anche installato Gnome Slacky 2.18.3 .
Mi si presentano 2 problemi gravi:
- se da GDM seleziono Xfce crasha xfdesktop (il desktop di Xfce 4.4)
Il problema non si presenta se faccio il boot testuale.

- con il driver video di Xorg i810 che ho sempre usato il pc è inutilizzabile con font giganti. Ora sto usandolo con i lenti driver vesa.
Questo non dovrebbe essere un problema di GS ma se qualcuno ha avuto un esperienza simile accetto consigli ;)

Grazie!!
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda mimmoforlug » ven lug 27, 2007 19:39

Pare che gli ultimi driver i810 siano bacati. Anche io ho avuto problemi con alcune applicazioni (come Terminal), ma solo se le avvio da Kde, non da xfce4 (li funzionano). Addirittura, gli stessi problemi si presentano con le applicazioni di X (come xv). Ho registrato, blocchi di sistema e crash del server X. Speriamo che li mettano apposto. Con la 11 il mio portatile era una roccia. Per il momento, elimino le applicazioni che crashano dal menu di kde. Mplayer (e tutti gli altri: Xine, gxine, etc) non sono in grado di utilizzare xv, si vede solo uno riquadro blu. Ho dovuto impostare gl come uscita dei player (ma richiede grandi risorse della cpu).

Se qualcuno volesse fornire dei rimedi, sarebbero molto graditi.

Aggiungo che con i810, compiz va benone (nel caso lo si volesse abilitare), però, secondo me, non vale la pena avere un desktop roteante in trasparenza in cambio di un sistema che può bloccarsi per il semplice avvio di un programma. Eppure,
pensavo che i driver intel fossero open e pertanto più compatibili. In tal caso sarebbe proprio una beffa: software open che gira bene solo su hardware con driver proprietari.
Avatar utente
mimmoforlug
Packager
Packager
 
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Località: Caserta
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox

Messaggioda jacobbe » ven lug 27, 2007 20:47

Se volete ho pacchettizzato gli ultimissimi driver intel-2.1.0 con lo Slackbuild di Pat:
http://www.megaupload.com/it/?d=9LQB13HM

Io non ho risolto il problema però ditemi voi se volete provare.

Vedere i video con Gl è troppo pesante :?
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda jacobbe » ven lug 27, 2007 20:57

Il problema font grandi è conosciuto, ecco cosa c'è scritto nel README dei driver Intel:
Common issues not caused by the driver
- Font sizes (DPI) are wrong. Some displays incorrectly report their
physical size, which is harmless on most OSes that always assume 96dpi
displays. This can be fixed through quirks for specific monitors in the X
Server, and the output of xrandr --prop along with a physical measurement of
the screen size in a bug report against the server can help get that fixed.
- gnome-panel is located in the middle of the screen. gnome-panel places
itself within head #0's boundaries, which doesn't work well with a second
head covering the same area as head #0 but larger.
- Older resolution-changing applications have poor results in
multihead systems. Previous extensions such as RandR 1.1 exposed only a
single output to client programs, and those requests map poorly to multi-head
systems. Currently, those requests map to just one of the outputs in the
RandR 1.2 environment, and those applications need to be updated to RandR 1.2
API when available for better results.


Si può risolvere editando /usr/bin/startx
defaultserverargs="-dpi 96"

e per GDM, su /etc/X11/gdm/gdm.conf
command=/usr/X11R6/bin/X -dpi 96 -audit 0
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda mimmoforlug » sab lug 28, 2007 2:11

Grazie, ho provato il pacchetto, ma gli errori sono aumentati (anche se sono aumentati un po' anche l'FPS di glxgears)

(EE) intel(0): detecting sil164
(EE) intel(0): Unable to read from DVOI2C_E Slave 112.
(EE) intel(0): Unable to read from DVOI2C_E Slave 236.
(EE) intel(0): ivch: Unable to read register 0x00 from DVOI2C_B:04.
(EE) intel(0): Unable to read from DVOI2C_E Slave 112.
(EE) intel(0): tfp410 not detected got VID FFFFFFFF: from DVOI2C_E Slave 112.

con quello originale della Slackware 12 ottenevo solo

(EE) intel(0): detecting sil164
(EE) intel(0): Unable to read from DVOI2C_E Slave 112.
(EE) intel(0): Unable to read from DVOI2C_E Slave 236.

In compenso con la versione 2.1.0 funziona il driver xv per i video, ma i crash di X non sono mancati.

Ho reinstallato il driver originario e ho impostato i lettori multimediali sul driver video xshm (meno versatile ma non esoso come opengl).

queste sono le sezioni più importanti del mio xorg.conf, puo' darsi che ci sia qualcosa di sbagliato in esse (nel caso mi farebbe piacere saperlo):

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Touchpad" "SendCoreEvents"
Option "AIGLX" "true"
#Option "Clone" "off"
#Option "Xinerama" "off"
EndSection


Section "Module"
Load "i2c"
Load "glx"
Load "extmod"
# Load "xtrap"
# Load "record"
Load "dbe"
Load "dri"
Load "freetype"
Load "type1"
# Load "v4l"
# Load "bitmap"
Load "ddc"
Load "int10"
Load "vbe"
EndSection

Section "Device"
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "82852/855GM Integrated Graphics Device"
BusID "PCI:0:2:0"
Option "DRI" "true"
VideoRam 131072
Option "XAANoOffscreenPixmaps" "true"
EndSection

Section "DRI"
Group "video"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "enable"
# Option "RENDER" "enable"
EndSection

grazie in anticipo, ciao
Avatar utente
mimmoforlug
Packager
Packager
 
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Località: Caserta
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox

Messaggioda jacobbe » dom lug 29, 2007 18:46

Problema arginato!
http://www.megaupload.com/it/?d=2XI4NP3R
http://www.tecnicaict.com/xf86-video-i8 ... i486-1.tgz

Con la vecchia versione dei driver i810 funziona tutto bene nessun problema con i DPI errati, nessun problema con xv.
In attesa di nuove versioni più stabili.

PS: non sono i driver intel ma i810!
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda mimmoforlug » lun lug 30, 2007 1:12

Grazie.
Soluzione ottima!
Ho solo dovuto dare una sistemata alla dimensione dei font di kde e gtk.
Crasha ancora terminal (solo sotto kde) e le FPS sono scese di molto (ma posso ancora giocare a torcs egregiamente).
Mplayer ora funziona bene con l'output impostato su xv.

Speriamo arrivino presto dei nuovi driver.
Avatar utente
mimmoforlug
Packager
Packager
 
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Località: Caserta
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox

Messaggioda mimmoforlug » mer ott 17, 2007 12:54

tutti i problemi con la scheda intel del portatile li ho risolti installando i due pacchetti:

xf86-video-i810-1.7.4-i486-1.tgz
xf86-video-intel-2.1.0-i486-1.tgz

e dando

upgradepkg --reinstall xf86-video-i810-1.7.4-i486-1.tgz

altrimenti alcuni file del pacchetto i810 sono sovrascritti dal pacchetto intel.
se non dovesse funzionare, si tratta solo di un problema di configurazione
del file xorg.conf

entrambi sono pacchetti originali della Slackware 12
Avatar utente
mimmoforlug
Packager
Packager
 
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Località: Caserta
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox


Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti