Repository 32bit  Forum
Repository 64bit  Wiki

Gslacky e librerie.

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Gslacky e librerie.

Messaggioda mkt0 » gio set 06, 2007 15:50

Salve a tutto l'onorevole forum!!

Ho da poco installato slackware 12 (installazione quasi full), compilato il kernel 2.6.22.6 con patch suspend2 e bootsplash, scaricata la iso di gslacky 2.18.3 e installata (full ovviamente). Riavvio il pc e vedo che il comando gdk-pixbuf-query-loaders messo in rc.local da errore:

Codice: Seleziona tutto
g_module_open() failed for /usr/lib/gtk-2.0/2.10.0/loaders/svg_loader.so: /usr/lib/libcairo.so.2: undefined symbol:
png_set_expand_gray_1_2_4_to_8


Usando xwmconfig configuro .xinitrc, do' startx e gnome si carica parzialmente, le applet danno errore e non fanno aprire il panel, facendo uscire finestre di warning che dicono che il panel e' gia' aperto e non ne puo' essere aperto un'altro. Lo stesso errore di prima esce sul terminale da cui lancio startx.

Ho provato a cercare in giro ma non ho trovato nulla.
Cosa mi consigliate?
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Messaggioda gohanz » gio set 06, 2007 17:27

Perdonami, ma che vuol dire installazione quasi full della 12.0? L'errore è dovuto alla mancanza di qualche libreria! In particolare mi sembra delle libpng! Prova a reinstallare il pacchetto libpng della 12.0!

http://packages.slackware.it/package.ph ... .18-i486-1
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda mkt0 » gio set 06, 2007 18:31

Per quasi full intendo che ho installato tramite il menu selettivo dei pkg, eliminando apache, php, mysql, rpm e altri che non siano librerie o soft importanti.

Per quanto riguarda le librerie png ho provato a reinstallarle ma non cambia nulla.

Avviando a mano gnome-panel sulla sessione gnome mi da' questo errore:

Codice: Seleziona tutto
Fontconfig warning: line 43: unknown element "cachedir"
Fontconfig warning: line 44: unknown element "cachedir"
Fontconfig warning: "/etc/fonts/conf.d/80-delicious.conf", line 18: invalid match target "scan"
gnome-panel: symbol lookup error: /usr/lib/libgtk-x11-2.0.so.0: undefined symbol: g_bookmark_file_new


Mentre gdk-pixbuf-query-loaders continua a dire:

Codice: Seleziona tutto
g_module_open() failed for /usr/lib/gtk-2.0/2.10.0/loaders/svg_loader.so: /usr/lib/libcairo.so.2: undefined symbol: png_set_expand_gray_1_2_4_to_8
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Messaggioda gohanz » gio set 06, 2007 18:44

Sono tutti errori dovuti a mancanza od errata versione di librerie! Il primo rigurada le libpng il secondo dalle glib, due pacchetti che non fanno parte di GSlacky 2.18.3, ma fanno parte della 12.0!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda mkt0 » gio set 06, 2007 18:46

ho reinstallato sia le libpng che tutte le glib ma niente.
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Messaggioda gohanz » gio set 06, 2007 18:56

L'iso di GSlacky l'hai presa dal server o tramite torrent?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda mkt0 » gio set 06, 2007 21:55

l'ho presa dal server. ho anche controllato l'md5 ed e' giusto.

per ora ripiego su e17... ma voglio comunque sistemare gnome.

grazie mille per il supporto.
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Messaggioda gohanz » ven set 07, 2007 7:05

mkt0 ha scritto:l'ho presa dal server. ho anche controllato l'md5 ed e' giusto.

per ora ripiego su e17... ma voglio comunque sistemare gnome.

grazie mille per il supporto.


Senti per doppio controllo puoi provare a scaricare l'iso dal Torrent! Io proverei anche un'installazione full della 12.0!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda mkt0 » ven set 07, 2007 10:43

Sto' cercando di scaricare da torrent la iso, ma c'e' un solo seed che fa scaricare raramente a 0.4Kb.

La mia iso ha md5: e084230d1df7cf353aa62ccbaedb1db0 GSlacky2.18.3.iso
E' uguale a quella che gira su torrent?
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Messaggioda gohanz » ven set 07, 2007 18:43

mkt0 ha scritto:Sto' cercando di scaricare da torrent la iso, ma c'e' un solo seed che fa scaricare raramente a 0.4Kb.

La mia iso ha md5: e084230d1df7cf353aa62ccbaedb1db0 GSlacky2.18.3.iso
E' uguale a quella che gira su torrent?


Si l'md5 è giusto! Non saprei se non ci sono problemi di spazio su disco, mi viene da pensare che manca qualcosa nell'installazione della 12.0!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda mkt0 » ven set 07, 2007 19:13

ho seguito il tuo consiglio... ho reinstallato tutto, e funziona.

ricordo perfettamente di non aver deselezionato librerie o prog utili alla precedente installazione. inoltre gslacky l'ho sempre installato full.

stile un po windowsiano reinstallare tutto... ma ha sicuramente funzionato.

grazie mille!
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Messaggioda gohanz » ven set 07, 2007 19:16

Meno male che hai risolto! ;)
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda mkt0 » ven set 07, 2007 20:16

ed ecco svelato il mistero... altro che reinstallazioni stile windowz...

ieri tramite swaret ho installato acetoneiso e le sue dipendenze, per "giocare" con la iso di gslacky senza masterizzarla, per poi installarla.

dopo averla scompattata sul mi hd, alla seconda installazione di slack nn ho piu' reinstallato acetoneiso ed le sue dip e tutto e' filato liscio con gnome.

pensando di aver risolto alla grande reinstallo fiducioso acetoneiso e le sue dipendenze... ed ecco il problema che si ripresenta :lol:

dopo aver provato ad eliminare le dipendenze una ad una, il pacchetto che da' problemi e':

wengophone-2.1.1-i686-1as

che dite?
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Messaggioda gohanz » sab set 08, 2007 7:08

Non è che il problema derivi da AcetoneISo? :roll:
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda mkt0 » sab set 08, 2007 11:30

no. acetoneiso2 e' attualmente installato e funziona. se installo il pacchetto wengophone-2.1.1-i686-1as mi fa' il bordello.

ma un'altra domanda... networkmanager? non riesco a fargli andare giu' il dhcp... non ne vuole sapere di funzionare. il dhclient va' sempre in timeout, ed in syslog ho:

Codice: Seleziona tutto
Sep  8 12:13:19 paghi lt-NetworkManager: <WARN>  nm_dbus_get_networks_cb(): error received: org.freedesktop.NetworkManagerInfo.NoNetworks - There are no wireless networks stored..
Sep  8 12:13:22 paghi dhclient: Usage: dhclient [-1dqr] [-nw] [-p <port>] [-s server]
Sep  8 12:13:22 paghi dhclient:                 [-cf config-file] [-lf lease-file][-pf pid-file] [-e VAR=val]
Sep  8 12:13:22 paghi dhclient:                 [-sf script-file] [interface]
Sep  8 12:13:22 paghi dhclient:
Sep  8 12:13:22 paghi dhclient: If you did not get this software from ftp.isc.org, please
Sep  8 12:13:22 paghi dhclient: get the latest from ftp.isc.org and install that befor
.....


mi sembra che venga chiamato con parametri errati, e dhclient stampi il suo messaggio di help.
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Prossimo

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron