Repository 32bit  Forum
Repository 64bit  Wiki

ssh e accesso da remoto (problemi)

Postate qui per tutte le discussioni legate alla sicurezza di Linux/Slackware

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

ssh e accesso da remoto (problemi)

Messaggioda oierpa » ven set 28, 2007 8:21

Ciao a tutti.
Anche a me di recente è stata tentata più di un'intrusione che vedo in /var/log/messages.
A dire il vero è impressionante il numero di tentativi che sono stati fatti!
Ho configuraro il server ssh seguendo un po' di istruzioni che ho trovato in rete e credevo fosse sicuro.
Ho limitato gli host in /etc/ssh/ssh_config alla mini rete locale che ho a casa (fisso con Slack e portatile con xp) e all'ip fisso del firewall router del lavoro (è un firewall linux) e sono riuscito a entrare nel mio pc di casa dal lavoro on winscp.
Tutto andava alla perfezione ma quando ho voluto condividere alcuni contenuti con un amico, qualche giorno fa, ho notato che non riusciva ad entrare, anche con nome utente e pwd giuste (sempre con winscp).
Provo da lavoro e non riesco ad accedere anche io, ma dalla rete locale si!
Ho controllato 1000 volte la configurazione ma non riesco proprio a capire dove sia il problema.
Non ho fatto l'autenticazione con le chiavi pgp perché non conosco ancora il sistema perciò entro con la password ma mai da root.
Ad ogni modo dalla rete locale non ho problemi.
Ho cambiato la porta a cui connettermi mettendo un numero alto e ancora da rete locale ok ma non da fuori, eppure con winscp riuscivo a farla funzionare bene e ora no senza aver modificato i file di configurazione.
Ho cercato ovunque e ho pensato che:
-qualcuno è riuscito ad entrare, ha cancellato le tracce e ora mi impedisce l'accesso da remoto...
-il sistema è talmente fatto bene che se su una scheda di rete subisce tanti attacchi dopo un po' si scoccia e chiude la possibilità di accesso da qeulla scheda.
Fra le due mi sembra più plausibile la prima...
In pratica in /etc/ssh/ssh_config ho aggiunto:
Host ip_fisso_del_lavoro
Host ip del portatile (rete locale)
in /etc/ssh/sshd_config
Protocol 2
ServerKeyBits 1024
LogLevel INFO
PermitRootLogin no
PermitEmptyPasswords no
che ho copiato da http://openskills.info/infobox.php?ID=291
Aggiungo che per accedere con winscp uso il servizio no-ip e sono circa 3 anni che non mi ha dato grossi problemi.
Grazie in anticipo.
Avatar utente
oierpa
Linux 2.0
Linux 2.0
 
Messaggi: 123
Iscritto il: ven set 24, 2004 23:00
Località: Torino
Kernel: 2.6.29.6
Desktop: kde
Distribuzione: slackware 13

ricerca.

Messaggioda oierpa » ven set 28, 2007 12:07

Ciao a tutti.
Continuando a cercare nella rete mi sono accorto che in effetti nella mia /home non c'è la directory .ssh, mi sembra alquanto strano!
Ciao
Avatar utente
oierpa
Linux 2.0
Linux 2.0
 
Messaggi: 123
Iscritto il: ven set 24, 2004 23:00
Località: Torino
Kernel: 2.6.29.6
Desktop: kde
Distribuzione: slackware 13

Messaggioda anycolouryoulike » ven set 28, 2007 12:17

Mi accodo alla tua richiesta.
Qui ci sono molti consigli per controllare gli accessi http://www.slacky.eu/forum/viewtopic.php?t=20735. Io ho risolto cambiando porta.

Comunque ho il tuo stesso problema: dalla LAN riesco a connettermi mentre da remoto no. Ho un classico router Netgear DG834G con NAT abilitato.

Sono sicuro che nessuno ha mai avuto accesso al mio computer perché ho sempre il /var/log/messages e per sicurezza anche lo who su Conky aggiornato ogni secondo.

Usando questo sito http://www.dnstools.it/ non riesco a pingare il mio host...
Ma perché ho avuto quei tentativi di accesso da parte di estranei mentre io non riesco a connettermi?
Per caso bisogna abilitare il NAT anche nel computer da cui si effettua la connessione?

oierpa ha scritto:Ciao a tutti.
Continuando a cercare nella rete mi sono accorto che in effetti nella mia /home non c'è la directory .ssh, mi sembra alquanto strano!
Ciao
Nemmeno io ho ~/.ssh può essere dovuto a quello?
Grazie
Avatar utente
anycolouryoulike
Packager
Packager
 
Messaggi: 1158
Iscritto il: gio ago 09, 2007 23:00
Slackware: 12.2
Kernel: 2.6.34.8
Desktop: KDE 3.5.10

aggiungo

Messaggioda oierpa » ven set 28, 2007 12:34

Quello che non capisco io è che non ho cambiato la configurazione di ssh e ho anche aggiunto in host.allow l'ip del firewall di lavoro.
Ma soprattutto fino a pochi giorni fa ci lavoravo, proprio come sto tentando di fare
Ora mi viene in mente che il ruouter potrebbe aver perso la configurazione del firewall quando ho staccato la corrente per mettere il lampadario!
Però il nome utente e la password di Tiscali li ha tenuti in memoria, non ha molto senso!

P.s.: quando ho visto la sfilza di host che hanno tentato di entrare mi sono reso conto che Internet è veramente pericolosa, non mi fiderei di far fare lo stesso lavoro a windows.
Avatar utente
oierpa
Linux 2.0
Linux 2.0
 
Messaggi: 123
Iscritto il: ven set 24, 2004 23:00
Località: Torino
Kernel: 2.6.29.6
Desktop: kde
Distribuzione: slackware 13

Messaggioda Unicondor » mer ott 24, 2007 18:39

Ma quando hai cambiato ip dove far girare il demone ssh hai aperto anche la porta sul dispositivo NAT del tuo router ??
Magari è questo il problema dato che il NAT funziona solo per le connessioni da remoto per la lan interna non ha limitazioni
Unicondor
Linux 2.0
Linux 2.0
 
Messaggi: 147
Iscritto il: mar nov 30, 2004 0:00
Località: Potenza
Slackware: 13.1
Kernel: 2.6.37.6

Messaggioda albatross » gio dic 13, 2007 11:22

secondo me il problema è il nat sull'interfaccia esterna del router della tua connessione internet.

In pratica devi girare (nattare) le richieste che arrivano sulla porta ssh (22 se non hai modificato il demone) dell'interfaccia esterna del router verso la corrispondente macchina sulla quale gira il serivizio che devi poter raggiungere dall'esterno

cheers
albatross
albatross
Linux 1.0
Linux 1.0
 
Messaggi: 97
Iscritto il: lun ott 20, 2003 23:00


Torna a Sicurezza

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 2 ospiti