Repository 32bit  Forum
Repository 64bit  Wiki

GSlacky 2.20.1 e bug reporting tool

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

GSlacky 2.20.1 e bug reporting tool

Messaggioda nagash » mar nov 13, 2007 7:33

Ho scaricato la nuova versione di GSlacky e innanzitutto volevo fare i complimenti a tutti per il lavoro, e volevo segnalare dei problemini che ho all'avvio:
Non appena loggo mi appaiono due bug reporting tool per il crash delle applicazioni nmapplet e gnome-screensaver (l'installazione è appena stata fatta) e quindi non mi funziona lo screensaver (nella vecchia versione non mi andava il blocco dello schermo con password, qui non ho potuto provare).
Inoltre come posso eliminare le Mail Notification Propeties che si aprono all'avvio? Ho provato dal gnome-control-center ma nulla.
nagash
Linux 1.0
Linux 1.0
 
Messaggi: 15
Iscritto il: gio ago 18, 2005 23:00

Messaggioda gohanz » mar nov 13, 2007 7:40

Hai fatto un'installazione da una Slackware 12.0 pulita, oppure un upgrade dalla 2.20.0?
In questa versione è stato fixato il problema che impediva il locking degli screensaver. Dovresti provare anche con un nuovo account.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda nagash » mar nov 13, 2007 7:52

Prima avevo una 2.18.3, l'ho disinstallata e poi installato la 2.20.1.
Anche provando con un nuovo account mi dà gli stessi problemi.
nagash
Linux 1.0
Linux 1.0
 
Messaggi: 15
Iscritto il: gio ago 18, 2005 23:00

Messaggioda gohanz » mar nov 13, 2007 7:56

Strano probabilmente è qualche impostazione o libreria della "vecchia" 2.18.3 che da fastidio.
Comunque cerco di studiare il problema, per Mail-notification. Basta che vai in Sistema > preferenze > Sessioni da li puoi disabiliare anche Nm-applet che ti da fastidio.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda nagash » mar nov 13, 2007 8:06

ok grazie mille!
nagash
Linux 1.0
Linux 1.0
 
Messaggi: 15
Iscritto il: gio ago 18, 2005 23:00

Messaggioda jacobbe » mar nov 13, 2007 12:55

Io ho fatto la stessa procedura per aggiornare da 2.18.3 ma non ho questi problemi...
gnome-screensaver non crasha (secondo me ti manca qualche libreria) e nmapplet sebbene non la usi abitualmente l'ho provata e funziona.
Mi sembra di aver capito che per quell'applet siano necessari privilegi particolari, specifico che io appartengo ai seguenti gruppi:
Codice: Seleziona tutto
bash-3.1$ groups
users disk cdrom halusers plugdev netdev stb-admin
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda jacobbe » mar nov 13, 2007 13:01

Poi posta le ultime righe dell'output "strace gnome-screensaver" e eventualmente confronta l'output di "ldd /usr/bin/gnome-screensaver" con il mio

Codice: Seleziona tutto
bash-3.1$ ldd /usr/bin/gnome-screensaver
        linux-gate.so.1 =>  (0xffffe000)
        libgtk-x11-2.0.so.0 => /usr/X11/lib/libgtk-x11-2.0.so.0 (0xb7a7c000)
        libgdk-x11-2.0.so.0 => /usr/X11/lib/libgdk-x11-2.0.so.0 (0xb79da000)
        libatk-1.0.so.0 => /usr/X11/lib/libatk-1.0.so.0 (0xb79c1000)
        libgdk_pixbuf-2.0.so.0 => /usr/X11/lib/libgdk_pixbuf-2.0.so.0 (0xb79a7000)
        libpangocairo-1.0.so.0 => /usr/X11/lib/libpangocairo-1.0.so.0 (0xb799d000)
        libpangoft2-1.0.so.0 => /usr/X11/lib/libpangoft2-1.0.so.0 (0xb796b000)
        libpango-1.0.so.0 => /usr/X11/lib/libpango-1.0.so.0 (0xb792c000)
        libcairo.so.2 => /usr/X11/lib/libcairo.so.2 (0xb78a4000)
        libfontconfig.so.1 => /usr/X11/lib/libfontconfig.so.1 (0xb7879000)
        libfreetype.so.6 => /usr/X11/lib/libfreetype.so.6 (0xb780b000)
        libz.so.1 => /usr/X11/lib/libz.so.1 (0xb77f7000)
        libexpat.so.1 => /usr/X11/lib/libexpat.so.1 (0xb77d7000)
        libpng12.so.0 => /usr/X11/lib/libpng12.so.0 (0xb779c000)
        libXrender.so.1 => /usr/X11/lib/libXrender.so.1 (0xb7794000)
        libm.so.6 => /lib/libm.so.6 (0xb776d000)
        libdbus-glib-1.so.2 => /usr/X11/lib/libdbus-glib-1.so.2 (0xb7753000)
        libnsl.so.1 => /lib/libnsl.so.1 (0xb773b000)
        libdbus-1.so.3 => /usr/X11/lib/libdbus-1.so.3 (0xb7702000)
        libgconf-2.so.4 => /usr/X11/lib/libgconf-2.so.4 (0xb76ce000)
        libORBit-2.so.0 => /usr/X11/lib/libORBit-2.so.0 (0xb7677000)
        libgmodule-2.0.so.0 => /usr/X11/lib/libgmodule-2.0.so.0 (0xb7674000)
        libgthread-2.0.so.0 => /usr/X11/lib/libgthread-2.0.so.0 (0xb766f000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb7658000)
        librt.so.1 => /lib/librt.so.1 (0xb7650000)
        libgobject-2.0.so.0 => /usr/X11/lib/libgobject-2.0.so.0 (0xb7611000)
        libgnome-menu.so.2 => /usr/X11/lib/libgnome-menu.so.2 (0xb75fb000)
        libfam.so.0 => /usr/X11/lib/libfam.so.0 (0xb75f5000)
        libglib-2.0.so.0 => /usr/X11/lib/libglib-2.0.so.0 (0xb7525000)
        libSM.so.6 => /usr/X11/lib/libSM.so.6 (0xb751d000)
        libICE.so.6 => /usr/X11/lib/libICE.so.6 (0xb7505000)
        libXss.so.1 => /usr/X11/lib/libXss.so.1 (0xb7502000)
        libXxf86vm.so.1 => /usr/X11/lib/libXxf86vm.so.1 (0xb74fd000)
        libXxf86misc.so.1 => /usr/X11/lib/libXxf86misc.so.1 (0xb74fa000)
        libxcb-xlib.so.0 => /usr/X11/lib/libxcb-xlib.so.0 (0xb74f7000)
        libxcb.so.1 => /usr/X11/lib/libxcb.so.1 (0xb74e0000)
        libXext.so.6 => /usr/X11/lib/libXext.so.6 (0xb74d2000)
        libX11.so.6 => /usr/X11/lib/libX11.so.6 (0xb73ea000)
        libXdmcp.so.6 => /usr/X11/lib/libXdmcp.so.6 (0xb73e5000)
        libdl.so.2 => /lib/libdl.so.2 (0xb73e1000)
        libXau.so.6 => /usr/X11/lib/libXau.so.6 (0xb73de000)
        libc.so.6 => /lib/libc.so.6 (0xb729b000)
        libXcomposite.so.1 => /usr/X11/lib/libXcomposite.so.1 (0xb7298000)
        libXdamage.so.1 => /usr/X11/lib/libXdamage.so.1 (0xb7295000)
        libXfixes.so.3 => /usr/X11/lib/libXfixes.so.3 (0xb7290000)
        libXinerama.so.1 => /usr/X11/lib/libXinerama.so.1 (0xb728d000)
        libXi.so.6 => /usr/X11/lib/libXi.so.6 (0xb7284000)
        libXrandr.so.2 => /usr/X11/lib/libXrandr.so.2 (0xb727e000)
        libXcursor.so.1 => /usr/X11/lib/libXcursor.so.1 (0xb7275000)
        /lib/ld-linux.so.2 (0xb7efe000)
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda submax82 » mar nov 13, 2007 15:11

nagash ha scritto:Prima avevo una 2.18.3, l'ho disinstallata e poi installato la 2.20.1.
Anche provando con un nuovo account mi dà gli stessi problemi.


attenzione che come specificato nella pagina di gslacky per rimuovere devi usare il vecchio cd della versione che vuoi rimuovere e poi a quel punto puoi reinstallare quella nuova.

attenzione a un bug nella rimozione della 2.20 che non ripristina i pacchetti originali di slack
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Messaggioda nagash » mar nov 13, 2007 18:15

si si ho utilizzato il cd della 2.18.
ldd /usr/bin/gnome-screensaver mi dà circa lo stesso output, le ultime righe di strace gnome-screensaver invece sono:

Codice: Seleziona tutto
rt_sigprocmask(SIG_BLOCK, ~[ILL ABRT BUS FPE SEGV RTMIN RT_1], [ILL ABRT FPE SEGV TSTP WINCH RT_4 RT_5 RT_12], 8) = 0
open("à&(·/0e5366da-4a0f-4746-6031f1fe-058ff6a4.dmp", O_WRONLY|O_CREAT|O_EXCL, 0600) = -1 ENOENT (No such file or directory)
rt_sigprocmask(SIG_SETMASK, [ILL ABRT FPE SEGV TSTP WINCH RT_4 RT_5 RT_12], ~[BUS KILL STOP RTMIN RT_1], 8) = 0
fstat64(1, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 1), ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb6fc0000
write(1, "0e5366da-4a0f-4746-6031f1fe-058f"..., 470e5366da-4a0f-4746-6031f1fe-058ff6a4 is dumped
) = 47
pipe([15, 16])                          = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0xb72b8708) = 3876
close(16)                               = 0
read(15, "", 8)                         = 0
close(15)                               = 0
waitpid(3876, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0) = 3876
--- SIGCHLD (Child exited) @ 0 (0) ---
unlink("/tmp/0e5366da-4a0f-4746-6031f1fe-058ff6a4.dmp") = -1 ENOENT (No such file or directory)
exit_group(0)                           = ?
Process 3875 detached


Inoltre gnome mi dà l'impressione che sia un pò lento, non l'ho provato su altre distro, ma è abbastanza scattoso e "pesante" eppure ho un athlon 64 3500+ un giga di ram un ati radeon x800 con i driver correttamente installati (i giochi vanno una bomba)

EDIT: Credo il problema sia qualche libreria, in quanto anche altri programmi tipo amule e vlc crashano e xfce si avvia ma dopo poco si pianta.
nagash
Linux 1.0
Linux 1.0
 
Messaggi: 15
Iscritto il: gio ago 18, 2005 23:00

Messaggioda gohanz » mar nov 13, 2007 19:06

Usa
Codice: Seleziona tutto
ldd /usr/bin/gnome-screensaver | grep  "not found"
è la maniera più semplice per cercare le eventuali librerie mancanti.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda nagash » mar nov 13, 2007 19:17

no sembrerebbero esserci tutte.
nagash
Linux 1.0
Linux 1.0
 
Messaggi: 15
Iscritto il: gio ago 18, 2005 23:00

Messaggioda gohanz » mar nov 13, 2007 19:24

nagash ha scritto:no sembrerebbero esserci tutte.


Prova anche a controllare

Codice: Seleziona tutto
ldd /usr/libexec/gnome-screensaver-dialog | grep  "not found"
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda nagash » mar nov 13, 2007 19:26

idem, se provassi a disinstallare gnome e tutte le relative librerie e reinstallare tutto ex novo potrebbe essere una soluzione? non potrebbe essere rimasto qualcosa dalla precedente versione (che avevo disinstallato però col suo cd) ?
nagash
Linux 1.0
Linux 1.0
 
Messaggi: 15
Iscritto il: gio ago 18, 2005 23:00

Messaggioda gohanz » mar nov 13, 2007 19:32

nagash ha scritto:idem, se provassi a disinstallare gnome e tutte le relative librerie e reinstallare tutto ex novo potrebbe essere una soluzione? non potrebbe essere rimasto qualcosa dalla precedente versione (che avevo disinstallato però col suo cd) ?

Si certo puoi provare. magari è qualche libreria corrotta. Di certo indivuarla, se non è mancante, diventa un'impresa!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00


Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 0 ospiti