Repository 32bit  Forum
Repository 64bit  Wiki

Compiz 0.6.2 su 2.20.1

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Compiz 0.6.2 su 2.20.1

Messaggioda jacobbe » mar nov 13, 2007 9:46

Ciao raga, volevo compilare compiz 0.6.2 con lo slackbuild di loris però c'è un errore nel compilare il gtk-window-decorator:
Codice: Seleziona tutto
gtk-window-decorator.o: In function `position_action_menu':
gtk-window-decorator.c:(.text+0xbe9): undefined reference to `wnck_window_get_client_window_geometry'
gtk-window-decorator.o: In function `update_window_decoration_name':
gtk-window-decorator.c:(.text+0xf40): undefined reference to `wnck_window_get_client_window_geometry'
gtk-window-decorator.o: In function `update_window_decoration_size':
gtk-window-decorator.c:(.text+0x103b): undefined reference to `wnck_window_get_client_window_geometry'
gtk-window-decorator.o: In function `update_event_windows':
gtk-window-decorator.c:(.text+0x1408): undefined reference to `wnck_window_get_client_window_geometry'
gtk-window-decorator.o: In function `window_geometry_changed':
gtk-window-decorator.c:(.text+0x1725): undefined reference to `wnck_window_get_client_window_geometry'
gtk-window-decorator.o:gtk-window-decorator.c:(.text+0x1ac9): more undefined references to `wnck_window_get_client_window_geometry' follow
collect2: ld returned 1 exit status


Sono installati i pacchetti
/mnt/dvd/packages/desktop/libwnck2-2.20.1-i686-6as.tgz
/mnt/dvd/packages/devlib/libwnck-2.18.3-i686-5as.tgz

Avete idee?
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda gohanz » mar nov 13, 2007 11:31

Jacobbe è un conflitto tra le due versioni dei pacchetti, ho dovuto usarli entrambi perchè alcuni pacchetti di Gnome 2.20.0 fanno ancora riferimento alla librerie wnck della serie 2.18.*
Puoi risolvere facilmente disinstallando entrambi i pacchetti e poi reinstallando libwnck2-2.20.0-i686-6as.

Se ci riesco, per stasera, manderò a Loris dei precompilati Compiz-fusion per GSlacky 2.20.1. In questa manierà non ci saranno altri problemi.

Grazie per la segnalazione!

Ps. Jacobbe hai anche tu lo stesso problema segnalato da Nagash? Anche lui ha effettuato l'upgrade dalla 2.18.3.

http://www.slacky.eu/forum/viewtopic.php?t=21764
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda jacobbe » mar nov 13, 2007 13:07

gohanz ha scritto:Jacobbe è un conflitto tra le due versioni dei pacchetti, ho dovuto usarli entrambi perchè alcuni pacchetti di Gnome 2.20.0 fanno ancora riferimento alla librerie wnck della serie 2.18.*
Puoi risolvere facilmente disinstallando entrambi i pacchetti e poi reinstallando libwnck2-2.20.0-i686-6as.

Se ci riesco, per stasera, manderò a Loris dei precompilati Compiz-fusion per GSlacky 2.20.1. In questa manierà non ci saranno altri problemi.


Perfetto, grazie... eventualmente stasera provo a pasticciare e se non ci riesco aspetto il tuo compiz ufficale!

gohanz ha scritto:Ps. Jacobbe hai anche tu lo stesso problema segnalato da Nagash? Anche lui ha effettuato l'upgrade dalla 2.18.3.

http://www.slacky.eu/forum/viewtopic.php?t=21764

Non avevo avuto questo tipo di problemi comunque gli ho risposto!
Ciaooooo :compress:
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda gohanz » mar nov 13, 2007 19:25

Jacobbe ho preparato i pacchetti, me li dovresti provare, perchè non ho hardware in grado di far girare Compiz. Tra poco li metti su una directory provvisoria del server ftp di GSlacky e ti passo l'indirizzo.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda jacobbe » mar nov 13, 2007 19:45

Perfetto!
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda gohanz » mar nov 13, 2007 20:10

Li sto uppando qui, purtroppo ho un po di problemi con la connessione!! :roll:

http://gnome.slacky.eu/gnome/12.0/2.20. ... es/compiz/
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda jacobbe » mar nov 13, 2007 22:32

Upgrade eseguito!
Sembra funzionare bene, lo testo per bene e domani provvedo a fornire bugreport se fosse necessario!

Ciao, grazie ancora!!!
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda jacobbe » gio nov 15, 2007 12:58

Dall'uso moderatamente intensivo che ho fatto mi sento di consigliarlo..
Mi sembra perfetto!
Non seguo attivamente lo sviluppo di compiz comunque a prima vista con questa versione mi sembrano risolti anche diversi piccoli bug (tipo i dialog vuoti che comparivano solo se ridimensionati).

Buona installazione 8)
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda gohanz » gio nov 15, 2007 19:54

Ho visto che Compiz-fusion richiede come dipendenza opzionale Fuse. La inserisco o posso omettere questa dipendenza?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda jacobbe » gio nov 15, 2007 19:59

Puoi decisamente omettere senza rimpianti ;)
Avatar utente
jacobbe
Linux 1.0
Linux 1.0
 
Messaggi: 76
Iscritto il: sab mag 14, 2005 23:00
Località: Treviso, Padova
Slackware: 12.0

Messaggioda gohanz » gio nov 15, 2007 20:01

Ok va bene! Grazie per il test! ;)
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda nicop » ven nov 16, 2007 1:35

gohanz ha scritto:Li sto uppando qui, purtroppo ho un po di problemi con la connessione!! :roll:

http://gnome.slacky.eu/gnome/12.0/2.20. ... es/compiz/


scusate l'ignoranza ma sono curioso di provare compiz...devo installare i tgz presenti in ogni
directory??
ciao
Avatar utente
nicop
Linux 2.4
Linux 2.4
 
Messaggi: 232
Iscritto il: mer gen 18, 2006 11:21
Località: San Martino In P. (Cb)
Nome Cognome: Nicola Palmieri
Slackware: 12.0
Kernel: 2.6.21.5
Desktop: Gnome Slacky

Messaggioda gohanz » ven nov 16, 2007 8:10

nicop ha scritto:
gohanz ha scritto:Li sto uppando qui, purtroppo ho un po di problemi con la connessione!! :roll:

http://gnome.slacky.eu/gnome/12.0/2.20. ... es/compiz/


scusate l'ignoranza ma sono curioso di provare compiz...devo installare i tgz presenti in ogni
directory??
ciao


Si, poi ti devi configurare anxche xorg.conf. Trovi info sul forum!

Nicop i pacchetti sono per GSlacky 2.20.1!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00


Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite