Repository 32bit  Forum
Repository 64bit  Wiki

Problema clients associati con airodump-ng

Postate qui per tutte le discussioni legate alla sicurezza di Linux/Slackware

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema clients associati con airodump-ng

Messaggioda kos » mer mar 26, 2008 19:16

Ciao a tutti,
Quando metto la mia scheda di rete pro/wireless 3945 (iwl3945) in modalità promiscua e avvio airodump-ng con questo comando: airodump-ng wlan0
la scheda di rete inizia a sniffare e mi va ad individuare il mio access point assieme ad altri 3 che non sono miei, dei quali non conoscevo l'esistenza 8) Tutto funziona a meraviglia. Il problema sta nel fatto che non riesce a sniffare(non visualizzo niente con airodump-ng) i pacchetti dei clients associati agli access points. Ho fatto la prova con quello mio e un altro pc connesso in wireless. airodump-ng mi dovrebbe sniffare il traffico del mio pc, invece sniffo soltanto traffico di access points. Ho provato pure con l'opzione -a ma il risultato non cambia. Si accettano suggerimenti,grazie. :lol:
Avatar utente
kos
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: sab mar 22, 2008 19:53
Località: dmi.unict
Slackware: 12

Re: Problema clients associati con airodump-ng

Messaggioda kos » gio mar 27, 2008 1:33

Questo è il secondo post che scrivo su slacky.eu. Il primo, nella sezione laptop, non ho ricevuto neanche una risposta :doubt: , anzi mi sono dovuto rispondere da solo e risolverlo sempre da solo il problema :) . Spero che in questo qualcuno magari intervenga, magari per il semplice piacere di scambiare 2 chiacchere :( . Non credo che i problemi che incontro non siano mai capitati a nessuno [-X . In attesa che qualche anima pia risponda :cry:
Avatar utente
kos
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: sab mar 22, 2008 19:53
Località: dmi.unict
Slackware: 12

Re: Problema clients associati con airodump-ng

Messaggioda Toni » gio mar 27, 2008 1:46

http://www.aircrack-ng.org/doku.php

qui trovi tutto il supporto necessario :documentazione , forum , canale irc etc etc
in bocca al lupo :thumbright:
Avatar utente
Toni
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: lun gen 30, 2006 22:08
Località: milano
Slackware: slackware-14
Kernel: 3.10.5
Desktop: i3

Re: Problema clients associati con airodump-ng

Messaggioda kos » gio mar 27, 2008 13:08

Grazie notturnista per la risposta ;) , comunque le pagine di quel sito le avevo già spulciate :) .
Googlando di quà e di là, penso di aver capito quale sia il problema, e cioè è il driver della mia scheda di rete ( intel pro/wireless 3945). Io uso gli iwl3945 e non gli ipw3945. Gli iwl3945, qualcuno mi corregga se sbaglio, non supportano la modalità monitor, anche se la cosa che non capisco e che se dò questi comandi:
Codice: Seleziona tutto
1) iwconfig wlan0 down  2) iwconfig wlan0 mode monitor  3) iwconfig wlan0 up
4) iwconfig
la wlan0 viene settata in mode monitor :-k Se provo a settare la scheda utilizzando lo script airmon-ng del pacchetto aircrack-ng con il comando: airmon-ng start wlan0 mi dà questo errore: iwl3945 - [phy0]/usr/sbin/airmon-ng: line 357: /sys/class/ieee80211/phy0/add_iface: No such file or directory mon0: ERROR while getting interface flags: No such device (monitor mode enabled on mon0). Vado a vedere se c'è l'interfaccia mon0 e non c'è niente. Cosa mi consigliate da fare, passare ad ipw3945 che mi sembra supporti la modalità monitor e che si tratta, da quel che ho capito, di un progetto destinato a scomparire a causa degli iwl3945, oppure attendere che quelli dell'intel sviluppino nuovi driver iwl3945 che supportino la modalità monitor :roll: Oppure mettere una scheda wireless esterna :x A voi la parola :D
Avatar utente
kos
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: sab mar 22, 2008 19:53
Località: dmi.unict
Slackware: 12

Re: Problema clients associati con airodump-ng

Messaggioda Toni » gio mar 27, 2008 15:46

Avatar utente
Toni
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: lun gen 30, 2006 22:08
Località: milano
Slackware: slackware-14
Kernel: 3.10.5
Desktop: i3

Re: Problema clients associati con airodump-ng

Messaggioda kos » sab mar 29, 2008 15:55

Ciao notturnista :) grazie per il tuo tempo.
A quanto pare le pagine del sito non le avevo spulciate molto bene :oops: Corregimi se sbaglio. Da quanto ho capito, installando un' opportuna patch ai miei driver iwl3945 risolvo il problema dellla modalità monitor senza dover passare agli ipw3945, giusto :?: la patch è ieee80211_softmac_adjust_bitrate.patch da questo link http://patches.aircrack-ng.org/ :?:
Avatar utente
kos
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: sab mar 22, 2008 19:53
Località: dmi.unict
Slackware: 12

Re: Problema clients associati con airodump-ng

Messaggioda Dani » sab mar 29, 2008 16:08

http://dl.aircrack-ng.org/drivers/ipwra ... 08.tar.bz2

Devi compilare questi driver secondo le istruzioni presenti nell'archivio stesso. Il modulo è ipwraw, caricalo ed usalo quando devi fare injection e sniffing, poi quando finisci e devi usare 'normalmente' la periferica lo scarichi e carichi iwl3945.
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Re: Problema clients associati con airodump-ng

Messaggioda kos » sab mar 29, 2008 17:28

Grazie Dani, ho risolto =D>
Un' ultima cosa: I left the default speed at 54 MBit. You may want to lower it to 1 MBit before injection with iwconfig wifi0 rate 1M. Why :?:
Avatar utente
kos
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: sab mar 22, 2008 19:53
Località: dmi.unict
Slackware: 12

Re: Problema clients associati con airodump-ng

Messaggioda kos » sab mar 29, 2008 17:46

Il messaggio in inglese sopra ( a parte il "Why ?" finale) era nel README del driver. Mi piacerebbe capire la motivazione, cioè perchè dovrei abbassare la banda a 1 M prima dell' iniezione dei pacchetti :-k
Avatar utente
kos
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: sab mar 22, 2008 19:53
Località: dmi.unict
Slackware: 12

Re: Problema clients associati con airodump-ng

Messaggioda Dani » sab mar 29, 2008 18:46

Perchè abbassandola teoricamente dovresti avere piu' probabilità di successo :)
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch


Torna a Sicurezza

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron