Repository 32bit  Forum
Repository 64bit  Wiki

errore esd con il nuovo gslacky [RISOLTO]

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

errore esd con il nuovo gslacky [RISOLTO]

Messaggioda sbabaro » sab mag 24, 2008 21:51

Ho appena installato gslacky nuovo e....non parte.
mi dà come errore che non riesce a caricare libesd.so.0
ma come, non doveva esserci pulse audio?
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: errore esd con il nuovo gslacky

Messaggioda slucky » sab mag 24, 2008 22:24

ma la 2.22.1 è compilata sulla 12.1, tu quale versione di slack usi? dal tuo profilo leggo 11.0 quasi 12.....quindi :-k penso che il problema possa dipendere da questo...

saluti
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2379
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: errore esd con il nuovo gslacky

Messaggioda sbabaro » sab mag 24, 2008 22:33

ho installato su una macchina virtuale la 12.1, per migrare tutto
è lì che non trova libesd
comunque sto provando a reinstallare da capo
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: errore esd con il nuovo gslacky

Messaggioda sbabaro » sab mag 24, 2008 23:24

confermo che dopo aver reinstallato tutto il sistema da capo è andato tutto liscio come l'olio
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: errore esd con il nuovo gslacky

Messaggioda gohanz » dom mag 25, 2008 7:28

Allora segno il post come risolto! Comuqure GSlacky non tocca il pacchetto esound e le librerie che hai citato libesd.so.0., pachetto che rimane quindi l'originale della 12.1.
Per far funzionare i suoni del desktop, che usando esound, GSlacky crea un link simbolico tra /usr/bin/esdcompat e /usr/bin/esd,
rimuovendo quindi il binario esd. Esdcompat è il modulo pulseaudio che si occupa dell'emulazione Esound.
Inoltre GSlacky crea due link simbolici nella home, questo tramite un file desktop che si autoesegue ad ogni avvio del desktop.

Codice: Seleziona tutto
ln -sf /var/run/pulse/.esd_auth ~/.esd_auth

ln -sf /var/run/pulse/.pulse-cookie ~/.pulse-cookie


Senza questi due link simbolici i suoni del desktop smetterebbero di funzionare.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00


Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite