problemi con l'installazione di gslacky 2.22.1

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2385
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1
Kernel: 4.6.3-smp
Desktop: xfce

problemi con l'installazione di gslacky 2.22.1

Messaggioda slucky » dom mag 25, 2008 12:03

Allora, in breve, quando provo a installare la nuova versione, mi dice:

"Slackware Version must be: "Slackware 12.1.0" :oops:

il bello è che sono su una partizione con la 12 aggiornata alla 12.1, infatti se:

cat /etc/slackware-version mi dice Slackware 12.1.0 e allora dov'è l'inghippo? :-k

Saluti
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda gohanz » dom mag 25, 2008 12:17

Ricontrolla il file /etc/slackware-version forse è corrotto. Deve contenere solo la stringa

Codice: Seleziona tutto

Slackware 12.1.0

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2385
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1
Kernel: 4.6.3-smp
Desktop: xfce

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda slucky » dom mag 25, 2008 12:29

sì, ho controllato il file è uguale...comunque ora riprovo l'installazione e poi ti faccio sapere... ;)
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2385
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1
Kernel: 4.6.3-smp
Desktop: xfce

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda slucky » dom mag 25, 2008 14:57

allora effettivamente era un problema del file corrotto, l'ho sistemato ed ha effettuato l'installazione senza problemi, l'unico problema ora è che nella fase di boot prima del login pulse-audio mi da questo errore:

Starting PulseAudio Daemon:/usr/lib/pulseaudio --system --daemonize --high-priority --log-target=syslog/usr/bin/pulseaudio: symbol lookup error: /usr/lib/libsndfile.so.1: undefined symbol= FLAC_seekable_stream_encoder_set_write_callback


però quella libreria è regolarmente presente nel sistema, ho già controllato, quale la causa?

ciao e saluti a tutti
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda gohanz » dom mag 25, 2008 15:56

slucky ha scritto:allora effettivamente era un problema del file corrotto, l'ho sistemato ed ha effettuato l'installazione senza problemi, l'unico problema ora è che nella fase di boot prima del login pulse-audio mi da questo errore:

Starting PulseAudio Daemon:/usr/lib/pulseaudio --system --daemonize --high-priority --log-target=syslog/usr/bin/pulseaudio: symbol lookup error: /usr/lib/libsndfile.so.1: undefined symbol= FLAC_seekable_stream_encoder_set_write_callback


però quella libreria è regolarmente presente nel sistema, ho già controllato, quale la causa?

ciao e saluti a tutti


Ma sei sicuro di aver installato correttamente la 12.1? Dall'errore sembra che non trovi la libreria flac, che è presente di default sulla 12.1. Esattamenet libsndfile dipende da

Codice: Seleziona tutto

flac >= 1.1.2-i486-3
reinstalla quel pacchetto e dovrebbe andare tutto a posto.

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2385
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1
Kernel: 4.6.3-smp
Desktop: xfce

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda slucky » dom mag 25, 2008 16:47

certo, con upgradepkg aggiorno tutto il sistema , come faccio di solito, finora mai avuto problemi, comunque ho anche controllato sul dvd della slackware 12.1 ho il pacchetto /slackware/ap/flac-1.2.1-i486-1.tgz, e lo stesso pacchetto in pkgtool, mentre tu mi segnali un'altra versione:

flac >= 1.1.2-i486-3


:oops: allora come mai sono versioni differenti...allora penso che dovrò scaricarlo da slacky.... :-k

edit: quel pacchetto è la versione per la 12.0, ho controllato il dvd della 12, logicamente aggiornando alla 12.1 è stato rimosso e aggiornato con il nuovo , ora provvedo a reinstallarlo, però perchè pulseaudio cerca la vecchia versione? :?:
forse perchè è stato comunque compilato partendo dai pacchetti della 12...e ne ha bisogno in quanto dipendenze...mi chiedo :-k
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda gohanz » dom mag 25, 2008 19:01

Slucky scusami hai ragione il pacchetto flac è giusto. Puoi controllaer l'md5 dell'immagine iso? Questo se hai scaricato l'iso direttamente dal server. Non vorrei che hai scaricato l'iso corrotta. Se hai letto i post ho avuto grossi problemi ad caricare l'iso sul server di Simplex.

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2385
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1
Kernel: 4.6.3-smp
Desktop: xfce

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda slucky » dom mag 25, 2008 19:32

di niente non ti preoccupare gohanz, no problem... alla fine tutto si sistema ;) comunque in effetti io non ho scaricato il torrent ma l'iso dal server uglyplace, in ogni caso come mi hai consigliato, ho controllato l'iso e il checksum mi ha restituito
78f5e2bc2747f13c94ef663bcee1b5ab


che poi controllando quello dell'iso sul server è uguale, penso che sia a posto... comunque devo dire che a parte pulseaudio finora non ho avuto altri malfunzionamenti, tra poco riavvio il sistema per vedere se tutto funziona e poi ti faccio sapere..

Ciao e grazie per l'aiuto :thumbright:
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda gohanz » dom mag 25, 2008 19:35

Ok allora fammi sapere. Perchè se l'iso è buona, quell'errore non lo deve dare.

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2385
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1
Kernel: 4.6.3-smp
Desktop: xfce

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda slucky » dom mag 25, 2008 22:21

allora al riavvio nessun errore del demone di pulseaudio e tutto funziona...mi resta però una domanda per curiosità perchè ho dovuto reinstallare il pacchetto FLac della 12 per sistemare? :-k

Saluti :)
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2385
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1
Kernel: 4.6.3-smp
Desktop: xfce

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda slucky » lun mag 26, 2008 1:28

comunque sto avendo problemi con pulseaudio :? se provo a riprodurre un file musicale con un programma tipo rhytmnbox, xmms non si sente nulla....se lancio PulseAudioManager e provo a riprodurre il file pulse-hotplug nel tab Sample Cache invece si sente, penso che si tratti di problema di configurazione, se qualcuno mi da una dritta per sistemare mi farebbe un gran favore :)

Saluti
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda gohanz » lun mag 26, 2008 8:17

Premesso che PulseAudio deve funzionare anche con flac della 12.1. Per configurare Gnome in modo che usi PulseAudio come server, devi semplicemente andare in Sistema > Preferenze > Audio e selezionare PulseAudio. Per attivare gli effetti sonori del desktop devi semplicemente mettere un segno di spunta, nella scheda suoni, dalla stessa applet.

Immagine

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2385
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1
Kernel: 4.6.3-smp
Desktop: xfce

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda slucky » lun mag 26, 2008 18:39

sì okay gohanz errore mio....bastava abilitare il server in audio #-o ora va bene :)

Ciao
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2385
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1
Kernel: 4.6.3-smp
Desktop: xfce

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda slucky » ven mag 30, 2008 0:04

solo per dire che dopo alcuni giorni d'uso ed eccetto i problemini iniziali di configurazione con pulseaudio, devo dire che questa versione dello gnomo è sicuramente la migliore mai uscita :thumbright: gohanz hai fatto un ottimo lavoro, anche nautilus ora è molto più veloce, non c'è più quel notevole ritardo quando si prova ad aprire dir popolose, ma tutto il sistema in generale è molto più reattivo e ,cosa che non guasta mai , anche più piacevole, merito anche dei suoni di sistema :D
Solo una domanda se volessi provare ad installarla su una 12 ci sarebbero problemi? e volendo provare c'è un modo per aggirare il controllo di versione?

Ciao e saluti a tutti :D
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: problemi con l'installazione di gslacky 2.22.1

Messaggioda gohanz » ven mag 30, 2008 11:12

Grazie per i complimenti Slucky! \:D/ Comunque penso che siano pochissime possibiltà di far girare GSLacky 2.22.1 sulla 12.0.


Torna a “Gnome Slacky”

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti