Open/Libre-Office autobuilder segnalazioni e problemi

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » ven giu 13, 2008 13:59

c'è un un'errore nello slack-required ... sistemo subito e lo uppo

Avatar utente
tigerwalk
Linux 2.6
Linux 2.6
Messaggi: 870
Iscritto il: lun feb 25, 2008 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.1
Kernel: 2.6.33.4-tiger
Desktop: kde4/fluxbox
Località: Napoli
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda tigerwalk » ven giu 13, 2008 16:05

ho provato, installa tutto senza problemi ma il programma non si apre. Da terminale mi da i seguenti errori

Codice: Seleziona tutto

/opt/openoffice.org2.4/program/soffice: line 237: /opt/openoffice.org2.4/program/pagein: No such file or directory
/opt/openoffice.org2.4/program/soffice.bin: error while loading shared libraries: libstlport_gcc.so: cannot open shared object file: No such file or directory

Ho notato che in /opt/openoffice.org2.4/program/ mancano tutti i file pagein ed anche soffice.

Avatar utente
tigerwalk
Linux 2.6
Linux 2.6
Messaggi: 870
Iscritto il: lun feb 25, 2008 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.1
Kernel: 2.6.33.4-tiger
Desktop: kde4/fluxbox
Località: Napoli
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda tigerwalk » ven giu 13, 2008 20:49

Ho provato a scaricare il pacchetto dal 7° mirror invece che dal 1° ed il problema si è risolto!

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » ven giu 13, 2008 21:43

tigerwalk ha scritto:Ho provato a scaricare il pacchetto dal 7° mirror invece che dal 1° ed il problema si è risolto!


a ecco !!! mi sembrava strano... grazie della segnalazione, magari capita ad altri ;)

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4556
Iscritto il: mer lug 28, 2004 0:00
Nome Cognome: Nino
Slackware: 14.2 64bit
Kernel: 4.4.29
Desktop: XFCE
Località: Reggio Calabria
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda aschenaz » sab giu 14, 2008 9:48

Upgradato stamattina, dal mirror 1: tutto ok, veloce e indolore! :thumbright:

Avatar utente
tigerwalk
Linux 2.6
Linux 2.6
Messaggi: 870
Iscritto il: lun feb 25, 2008 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.1
Kernel: 2.6.33.4-tiger
Desktop: kde4/fluxbox
Località: Napoli
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda tigerwalk » dom giu 15, 2008 16:09

L' autobuilder è semplicemente eccezionale! ;)

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » dom giu 15, 2008 17:27

8) 8) 8) eccezzzzziunalu veramente 8) 8) 8)

:lol: :lol: :lol:

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » mar giu 17, 2008 0:24

come và con slapt-get/swaret ? qualcuno ha provato?

se usate slpat-get/swaret è buona norma rimuovere l'autobuilder dopo che ha creato e installato il pacchetto di openoffice, questo perchè quando aggiornate, aggiorna anche l'autobuilder e riparte la costruzione...

Avatar utente
tigerwalk
Linux 2.6
Linux 2.6
Messaggi: 870
Iscritto il: lun feb 25, 2008 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.1
Kernel: 2.6.33.4-tiger
Desktop: kde4/fluxbox
Località: Napoli
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda tigerwalk » mar giu 17, 2008 17:33

submax82 ha scritto:come và con slapt-get/swaret ? qualcuno ha provato?

se usate slpat-get/swaret è buona norma rimuovere l'autobuilder dopo che ha creato e installato il pacchetto di openoffice, questo perchè quando aggiornate, aggiorna anche l'autobuilder e riparte la costruzione...

Non li uso ma, buono a sapersi....! :)

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3413
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda Trotto@81 » ven giu 20, 2008 22:07

Ma se voglio aggiornare openoffice basta fare l'upgrade dell'autobuilder e aggiorna in automatico il anche package?

EDIT: Ho provato ad aggiornare ma mi da subito questo dopo l'upgradepkg.

Codice: Seleziona tutto

+==============================================================================
| Upgrading openoffice-autobuilder-multilang-2.4.0-i586-3sm package using ./openoffice-autobuilder-multilang-2.4.1-i586-5sm.tgz
+==============================================================================

Pre-installing package openoffice-autobuilder-multilang-2.4.1-i586-5sm...
choice n.:
choice n.:

Com'è possibile??
Questo package mi st afacendo dannare!!
Ma non mi doveva fare scegliere nuovamente la lingua e il resto?
Ho interrotto il tutto con ctrl-c perchè giustamente non sapevo che scegliere e se controllo i package installati con ls /var/log/packages/ | grep open
mi resistuisce
openoffice-autobuilder-multilang-2.4.0-i586-3sm-upgraded-2008-06-20,22:27:58
openoffice-autobuilder-multilang-2.4.1-i586-5sm

Ho provato ad eliminare l'ultimo builder ma naturalmente mi dice questo:

Codice: Seleziona tutto

Removing package /var/log/packages/openoffice-autobuilder-multilang-2.4.1-i586-5sm...
Removing files:
  --> /install/doinst.sh was found in another package. Skipping.
  --> /install/slack-desc was found in another package. Skipping.
  --> /install/slack-required was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/doinst.sh.gz was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/isocodes was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/languages was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/mirrors was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/openoffice-multilang.SlackBuild was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/slack-desc was found in another package. Skipping

Come mi devo comportare ora?

POSTEDIT: Ho eliminato a mano anche il builder del 2.4.0 e ho dovuto eliminare a mano anche il package del 2.4.0 e ora sto reinstallando il builder 2.4.1.
Perchè non mi ha consentito l'aggiornamento?
Ma se elimino il builder perchè non rimuove anche il package annesso?
Sempre per quanto riguarda la puliza del sistema da file svolazzanti la cosa dovrebbe essere tranquilla vero?
Io ci tengo ad avere ogni singolo file del mio sistema tracciato da pkgtool. :)

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » sab giu 21, 2008 4:09

è normale se aggiorni l'autobuilder devi dare

Codice: Seleziona tutto

upgradepkg --verbose --install-new openoffice-autobuilder-multilang-*.tgz


Ma se elimino il builder perchè non rimuove anche il package annesso?

l'autobuilder è un pacchetto mentre il vero openoffice-lang è un'altro... non sono connessi... comunque quando crea il pacchetto della nuova versione di openoffice la aggiorna senza problemi, non hai bisogno di rimuovere la vecchia.

Sempre per quanto riguarda la puliza del sistema da file svolazzanti la cosa dovrebbe essere tranquilla vero?


gli unici file tracciati dall'autobuilder sono sotto /usr/src/openoffice-autobuilder-multilang/

quando l'autobuilder ha finito tutto e installato/aggiornato openoffice ripulisci tmp con

Codice: Seleziona tutto

rm -rf /tmp/tgz/*


e sei a posto, tutti file sono tracciati ;)

p.s.: anche io ho la stessa fissa che tutto sia tracciato dai pkgtools, non installo mai nulla con il metodo classico del "make install" proprio per questo :thumbright:

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3413
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda Trotto@81 » sab giu 21, 2008 8:37

[quote="submax82"]è normale se aggiorni l'autobuilder devi dare

Codice: Seleziona tutto

upgradepkg --verbose --install-new openoffice-autobuilder-multilang-*.tgz


Ah ecco!! Non sapevo si dovesse passare anche questa opzione.
Grazie mille come sempre per la tua infinita pazienza. :)

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » sab giu 21, 2008 14:35

Trotto@81 ha scritto:
submax82 ha scritto:è normale se aggiorni l'autobuilder devi dare

Codice: Seleziona tutto

upgradepkg --verbose --install-new openoffice-autobuilder-multilang-*.tgz


Ah ecco!! Non sapevo si dovesse passare anche questa opzione.
Grazie mille come sempre per la tua infinita pazienza. :)


sono io che devo ringraziarti, perchè grazie alle tue osservazioni e feedback sono riuscito a migliorare il builder ;)

Avatar utente
Codemaster71
Linux 1.0
Linux 1.0
Messaggi: 42
Iscritto il: ven feb 29, 2008 23:37

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda Codemaster71 » gio lug 03, 2008 23:51

Ragazzi io ho slackware 12 e nei repository l'autobuilder per lo stesso non funziona... Posso usare tranquillamente quello del 12.1 sulla mia slack o avrei problemi?

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » ven lug 04, 2008 12:34

Codemaster71 ha scritto:Ragazzi io ho slackware 12 e nei repository l'autobuilder per lo stesso non funziona... Posso usare tranquillamente quello del 12.1 sulla mia slack o avrei problemi?


si anzi devi perchè il più recente ed è stato migliorato.


Torna a “Packages”

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 3 ospiti