Repository 32bit  Forum
Repository 64bit  Wiki

Xbindkeys e sony vaio VGN-NR21S

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Xbindkeys e sony vaio VGN-NR21S

Messaggioda CrAXoR » dom giu 29, 2008 10:38

E' quasi un mesetto che ho questo portatile e fino adesso per ascoltare musica, film o fare altro con l'audio regolavo il volume con le cuffie. Da qualche giorno, però, l'audio , che redireziono sulle cuffie da kmix, si sente solo sulla cuffia destra(e non solo su quelle cuffie, ho provato anche con altre) e quindi se voglio utilizzare gli altoparlanti non so come alzare/abbassare il volume. I tasti di default per fare queste cose sono:
Codice: Seleziona tutto
Muto        -> Fn + F2
Vol Down -> Fn + F3
Vol Up     -> Fn + F4

In xbindkeys gli ho impostati ma il volume resta sempre uguale.
CrAXoR
Linux 2.0
Linux 2.0
 
Messaggi: 114
Iscritto il: mer mar 12, 2008 22:46
Slackware: 12.1
Kernel: ...
Desktop: ...

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda Bart » dom giu 29, 2008 16:49

Puoi provare con alsamixer oppure, visto che hai citato kmix e quindi immagino che usi kde, puoi inserire nel pannello l'applet relativo al "volume manager" e gestirlo da lì.
Bart
Staff
Staff
 
Messaggi: 4248
Iscritto il: dom ago 08, 2004 23:00
Località: Rimini

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda CrAXoR » lun giu 30, 2008 8:42

Non uso kde, kmixer lo uso solo per disattivare gli altoparlanti, comunque a me interessava riuscire a ad abbasare/alzare il volume alla pressione dei tasti sopra citati. Le combinazioni le ho già sistemate, il problema è il comando da dare per ogni combinazione.
CrAXoR
Linux 2.0
Linux 2.0
 
Messaggi: 114
Iscritto il: mer mar 12, 2008 22:46
Slackware: 12.1
Kernel: ...
Desktop: ...

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda Slippery » mar lug 01, 2008 0:18

Codice: Seleziona tutto
#incrementa il mixer software di 2dB
amixer -c 0 set PCM 2dB+
#opposta alla precedente
amixer -c 0 set PCM 2dB-
#mute
amixer -c 0 set PCM 0%


Saluti
Slippery
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: mer giu 25, 2008 17:52
Località: Treviso
Slackware: 12.2
Kernel: 2.6.29.1
Desktop: KDE 3.5.10

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda CrAXoR » mar lug 01, 2008 11:34

Slippery ha scritto:
Codice: Seleziona tutto
#incrementa il mixer software di 2dB
amixer -c 0 set PCM 2dB+
#opposta alla precedente
amixer -c 0 set PCM 2dB-
#mute
amixer -c 0 set PCM 0%


Saluti

Grazie ora funziona benissimo, però un ultima cosa. Con amixer posso redirezionare un canale audio come faccio con kmix, perchè non usando kde credo sia meglio usare altro. Perchè con kmix basta mettere sul muto gli altoparlanti(o disattivarli).
CrAXoR
Linux 2.0
Linux 2.0
 
Messaggi: 114
Iscritto il: mer mar 12, 2008 22:46
Slackware: 12.1
Kernel: ...
Desktop: ...

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda Slippery » mar lug 01, 2008 22:20

Con amixer posso redirezionare un canale audio come faccio con kmix

Perdonami, non capisco cosa intendi con 'redirezionare un canale'.
amixer è un client interfacciato direttamente con ALSA quindi tutto quello che fai con kmix lo puoi fare anche con questo tool.
Per avere un elenco dei mixer disponibili 'amixer scontrols' o 'amixer scontents'. Io ti consiglio comunque di usare PCM per il controllo via software così puoi mantenere il livello del Master al massimo e se devi aumentare o abbassare il volume non devi perderti a configurarne due :)
Slippery
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: mer giu 25, 2008 17:52
Località: Treviso
Slackware: 12.2
Kernel: 2.6.29.1
Desktop: KDE 3.5.10

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda CrAXoR » mer lug 02, 2008 13:02

Io intendo che quando attacco le cuffie devo disattivare gli altoparlanti perchè se no l'audio c'è sia sulle cuffie che su quest'ultimi e quindi con kmix disattivo gli altoparlanti. Comunque ora piu o meno ho capito cosa devo fare grazie per i consigli.
CrAXoR
Linux 2.0
Linux 2.0
 
Messaggi: 114
Iscritto il: mer mar 12, 2008 22:46
Slackware: 12.1
Kernel: ...
Desktop: ...

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda Slippery » gio lug 03, 2008 1:17

CrAXoR ha scritto:Io intendo che quando attacco le cuffie devo disattivare gli altoparlanti perchè se no l'audio c'è sia sulle cuffie che su quest'ultimi e quindi con kmix disattivo gli altoparlanti. Comunque ora piu o meno ho capito cosa devo fare grazie per i consigli.

Beh questo è un bug che avevano i driver alsa presenti nei kernel < 2.6.24 hai provato ad aggiornare slack, ricompilare un kernel nuovo o aggiungere queste righe al file sound della directory /etc/modprobe.d/ (se non c'è crealo)
Codice: Seleziona tutto
socket@forgotten:/etc/modprobe.d$ cat sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=vaio

ps: non so che chipset abbia il tuo vaio ma se è ICH8 allora controlla anche che le alsa-lib & alsa-utils siano almeno alla versione 1.0.15.
Slippery
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: mer giu 25, 2008 17:52
Località: Treviso
Slackware: 12.2
Kernel: 2.6.29.1
Desktop: KDE 3.5.10

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda CrAXoR » gio lug 03, 2008 12:19

Allora ho provato ad aggiungere le righe al file /etc/modprobe.d/sound ma non è cambiato niente, per quanto riguarda il kernel ho la versione 2.6.24.5 mentre di alsa la 1.0.15. A questo punto credo che mi converrà aggiornare il kernel.
CrAXoR
Linux 2.0
Linux 2.0
 
Messaggi: 114
Iscritto il: mer mar 12, 2008 22:46
Slackware: 12.1
Kernel: ...
Desktop: ...

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda Slippery » gio lug 03, 2008 23:48

Devo ammettere molto strano, certo con un aggiornamento del kernel taglieresti la testa al toro!

ps: con la slack 12.1 la suite alsa è aggiornata alla 1.0.16 ma il problema non è questo. Ho anch'io un vaio (VGN-FZ21M) e con la slack 12.0 mi è bastato compilare il 2.6.25.4 e installare le alsa-utils & alsa-lib alla versione 1.0.15 (pacchettizzata). Poi ricordo di aver dato il classico alsaconf, riavviato il demone alsa e i problemi erano spariti!
Slippery
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: mer giu 25, 2008 17:52
Località: Treviso
Slackware: 12.2
Kernel: 2.6.29.1
Desktop: KDE 3.5.10

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda CrAXoR » ven lug 04, 2008 12:24

Slippery ha scritto:Devo ammettere molto strano, certo con un aggiornamento del kernel taglieresti la testa al toro!

ps: con la slack 12.1 la suite alsa è aggiornata alla 1.0.16 ma il problema non è questo. Ho anch'io un vaio (VGN-FZ21M) e con la slack 12.0 mi è bastato compilare il 2.6.25.4 e installare le alsa-utils & alsa-lib alla versione 1.0.15 (pacchettizzata). Poi ricordo di aver dato il classico alsaconf, riavviato il demone alsa e i problemi erano spariti!

A me era stato detto che era un problema del dispositivo, cioè che quando inserivo le cuffie non scattava il meccanismo che disattivava gli altoparlanti, però dato che non ci sono altre soluzioni ricompilerò il kernel.
CrAXoR
Linux 2.0
Linux 2.0
 
Messaggi: 114
Iscritto il: mer mar 12, 2008 22:46
Slackware: 12.1
Kernel: ...
Desktop: ...

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda sperelli » dom lug 13, 2008 23:01

Se il tuo problema è che non riesci ad associare una combinaizone di tasti al controllo del volume ti spiego come ho risolto:

Ho creato un file chiamato .Xmodmap nella home con il seguente contenuto

Codice: Seleziona tutto
#muto
keycode 160 = XF86AudioMute
#abbassa il volume
keycode 174 = XF86AudioLowerVolume
#alza il volume
keycode 176 = XF86AudioRaiseVolume


il keycode lo recuperi con il programma xev posizionandoti col puntatore del mouse sulla finestrella che viene aperta e premendo il tasto che vuoi associare alla funzione (non so se e come si possa associare una combinazione di tasti).

Poi ho creato il seguente script, che serve per "bindare" effettivamente i tasti in base a quanto scritto nel file .Xmodmap

Codice: Seleziona tutto
#!/bin/bash

[ -f ~/.Xmodmap ] && xmodmap ~/.Xmodmap


e l'ho messo in .kde/Autostart per far si che venga eseguito ad ogni avvio di X. Tu però non usi kde..ma non so come aiutarti.

ciao
Avatar utente
sperelli
Linux 1.0
Linux 1.0
 
Messaggi: 26
Iscritto il: ven lug 11, 2008 18:03
Slackware: 12.1

Re: Xbindkeys e sony vaio VGN-NR21S

Messaggioda CrAXoR » mer lug 16, 2008 13:01

sperelli ha scritto:Se il tuo problema è che non riesci ad associare una combinaizone di tasti al controllo del volume ti spiego come ho risolto:

Ho creato un file chiamato .Xmodmap nella home con il seguente contenuto

Codice: Seleziona tutto
#muto
keycode 160 = XF86AudioMute
#abbassa il volume
keycode 174 = XF86AudioLowerVolume
#alza il volume
keycode 176 = XF86AudioRaiseVolume


il keycode lo recuperi con il programma xev posizionandoti col puntatore del mouse sulla finestrella che viene aperta e premendo il tasto che vuoi associare alla funzione (non so se e come si possa associare una combinazione di tasti).

Poi ho creato il seguente script, che serve per "bindare" effettivamente i tasti in base a quanto scritto nel file .Xmodmap

Codice: Seleziona tutto
#!/bin/bash

[ -f ~/.Xmodmap ] && xmodmap ~/.Xmodmap


e l'ho messo in .kde/Autostart per far si che venga eseguito ad ogni avvio di X. Tu però non usi kde..ma non so come aiutarti.

ciao

Grazie per il consiglio però ora questo problema l'ho risolto con xbindkeys che avvio in automatico tramite il file startup di fluxbox.
CrAXoR
Linux 2.0
Linux 2.0
 
Messaggi: 114
Iscritto il: mer mar 12, 2008 22:46
Slackware: 12.1
Kernel: ...
Desktop: ...


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti