Repository 32bit  Forum
Repository 64bit  Wiki

Prima volta con un portatile... mi aiutate??

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Prima volta con un portatile... mi aiutate??

Messaggioda danix » mar set 30, 2008 10:04

infatti ieri sera ho risolto per caso così, solo che era troppo tardi per postare :D
l'unico problema è che da root in questo modo non funziona, in quanto uso su con il mio utente normale... e tra l'altro non posso nemmeno mettere una variabile che mi dia l'utente attuale essendo acpi_handler lanciato sempre da root...

Risolvendo questo ho risolto anche il problema dello schermo che non si spegne quando lo chiudo, ho dovuto mettere
su - myuser -c "export DISPLAY=:0; xset dpms force $VARIABILE"... :)

Quest'ultimo però lo dovrò modificare perchè il lid switch è troppo sensibile e mi si riaccende quasi subito...
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: Prima volta con un portatile... mi aiutate??

Messaggioda Slippery » mar set 30, 2008 10:33

se il computer è condiviso con più utenti, basta fare in modo che accetti connessioni locali da qualsiasi sessione:
Codice: Seleziona tutto
xhost +LOCAL:

in questo modo anche da root
Codice: Seleziona tutto
xset -display :0.0 dpms force off

funziona a dovere :)

Comunque trovo strano il bottone del lid sia così sensibile...
Slippery
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: mer giu 25, 2008 17:52
Località: Treviso
Slackware: 12.2
Kernel: 2.6.29.1
Desktop: KDE 3.5.10

Re: Prima volta con un portatile... mi aiutate??

Messaggioda danix » mar set 30, 2008 13:05

Codice: Seleziona tutto
xhost +LOCAL:

dove conviene metterlo??

il lid spegne lo schermo già a 40° più o meno, arrivando in fondo si riaccende... invece quando do
Codice: Seleziona tutto
xset dpms force off

a schermo aperto funziona correttamente... per questo ho pensato che fosse lo switch ad essere troppo sensibile...
come soluzione stavo pensando di modificare il mio attuale lid.sh (richiamato da acpi_handler.sh):
Codice: Seleziona tutto
#! /bin/bash

if grep -q open /proc/acpi/button/lid/C154/state
then
    ACTION="on"
else
    ACTION="off"
fi

su - danix -c "export DISPLAY=:0; /usr/bin/xset dpms force $ACTION


in qualcosa del genere:
Codice: Seleziona tutto
#! /bin/bash

if grep -q open /proc/acpi/button/lid/C154/state
then
    ACTION="on"
    until [ grep -q open /proc/acpi/button/lid/C154/state ]
    do
        sleep 1
    done
else
    ACTION="off"
fi

su - danix -c "export DISPLAY=:0; /usr/bin/xset dpms force $ACTION

ma non so nemmeno se potrebbe funzionare, l'ho scritto appena mi è venuto in mente e non l'ho ancora provato...
che ne dite??
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: Prima volta con un portatile... mi aiutate??

Messaggioda Slippery » mar set 30, 2008 17:39

Codice: Seleziona tutto
socket@forgotten:~/.kde/Autostart$ cat x11service.sh
#!/bin/sh

/usr/bin/xhost +LOCAL:root &


il lid spegne lo schermo già a 40° più o meno, arrivando in fondo si riaccende...

Hai un lid con più di due stati? OPEN, CLOSE, 40°? :D
A parte gli scherzi, credo che un'occhiata agli eventi che lancia acpid non farebbe male...
Codice: Seleziona tutto
watch -n 0.3 "tail -n 30 /var/log/acpid"


Il file 'state' dovrebbe contenere solo 'open' e 'close':
se il tuo schermo a 40° si spegne -> siamo nello stato close
se chiuso del tutto si accende -> siamo nello stato open <<-- non è normale
Slippery
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: mer giu 25, 2008 17:52
Località: Treviso
Slackware: 12.2
Kernel: 2.6.29.1
Desktop: KDE 3.5.10

Re: Prima volta con un portatile... mi aiutate??

Messaggioda danix » mar set 30, 2008 17:54

grazie della risposta e del chiarimento, :)
ancora una cosa, visto che non ho molto chiaro il comando watch, dovrei metterlo al posto di quell'until che ho postato prima, giusto?? perchè le ultime 30 righe di acpid??

Ancora grazie mille per l'aiuto... :)
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: Prima volta con un portatile... mi aiutate??

Messaggioda Slippery » mar set 30, 2008 20:39

no, il watch lo lanci su una shell di root, provi ad aprire e chiudere lo sportello e vedi che eventi il demone acpi segnala.
Dovrebbero essere due eventi uguali, sulla falsa riga di questi:
Codice: Seleziona tutto
[Tue Sep 30 19:56:24 2008] received event "button/lid LID0 00000080 00000025"
[Tue Sep 30 19:56:24 2008] notifying client 1803[82:82]
[Tue Sep 30 19:56:24 2008] notifying client 1915[0:0]
[Tue Sep 30 19:56:24 2008] notifying client 1915[0:0]
[Tue Sep 30 19:56:24 2008] executing action "/etc/acpi/acpi_handler.sh button/lid LID0 00000080 00000025"
[Tue Sep 30 19:56:24 2008] BEGIN HANDLER MESSAGES
[Tue Sep 30 20:28:51 2008] END HANDLER MESSAGES
[Tue Sep 30 20:28:51 2008] action exited with status 0
[Tue Sep 30 20:28:51 2008] completed event "button/lid LID0 00000080 00000025"
[Tue Sep 30 20:28:53 2008] received event "button/lid LID0 00000080 00000026"
[Tue Sep 30 20:28:53 2008] notifying client 1803[82:82]
[Tue Sep 30 20:28:53 2008] notifying client 1915[0:0]
[Tue Sep 30 20:28:53 2008] notifying client 1915[0:0]
[Tue Sep 30 20:28:53 2008] executing action "/etc/acpi/acpi_handler.sh button/lid LID0 00000080 00000026"
[Tue Sep 30 20:28:53 2008] BEGIN HANDLER MESSAGES
[Tue Sep 30 20:28:53 2008] END HANDLER MESSAGES
[Tue Sep 30 20:28:53 2008] action exited with status 0
[Tue Sep 30 20:28:53 2008] completed event "button/lid LID0 00000080 00000026"

Nel primo l'lcd si chiude (stato close) nel secondo si apre (stato open).
Se nel tuo caso a 40° viene lanciato davvero un evento, beh, è un lid strano :)
Slippery
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: mer giu 25, 2008 17:52
Località: Treviso
Slackware: 12.2
Kernel: 2.6.29.1
Desktop: KDE 3.5.10

Re: Prima volta con un portatile... mi aiutate??

Messaggioda danix » mar set 30, 2008 20:51

ah ok, non avevo capito, comunque questo controllo l'avevo già fatto, basta fare tail -f /var/log/acpid, gli eventi sono molto simili a quelli postati da te... solo che non so perchè lo schermo mi si riaccende quasi immediatamente quando lo chiudo... :(
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: Prima volta con un portatile... mi aiutate??

Messaggioda danix » dom ott 05, 2008 11:48

rieccomi sul discorso wifi,
ho configurato la scheda seguendo il wikislack (l'articolo dove parla delle schede broadcom)... e adesso sono online senza fili... :D

ho solo un dubbio...
avendo configurato anche la rete wired sul fisso per il forwarding dal fisso al laptop, non avrò problemi di navigazione?? non c'è uno switch per disattivare il forwarding quando non lo voglio?? in questo modo potrei tenere la rete wired solo per lo scambio di dati tra i 2 pc e quella wifi per la navigazione del portatile...


Grazie dell'aiuto...
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: Prima volta con un portatile... mi aiutate??

Messaggioda conraid » dom ott 05, 2008 11:56

danix85 ha scritto: non c'è uno switch per disattivare il forwarding quando non lo voglio??


Basta un
Codice: Seleziona tutto
echo 0 > /proc/sys/net/ipv4/ip_forward

quindi puoi farti uno script, che in Slackware c'è già, /etc/rc.d/rc.ip_forward

quindi, senza nemmeno bisogno di renderlo eseguibile se lo vuoi a tua scelta
Codice: Seleziona tutto
sh /etc/rc.d/rc.ip_forward  start

e
Codice: Seleziona tutto
sh /etc/rc.d/rc.ip_forward  stop
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Precedente

Torna a Laptop

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite