Repository 32bit  Forum
Repository 64bit  Wiki

gslacky-2.24 sulla current, è possibile?

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

gslacky-2.24 sulla current, è possibile?

Messaggioda slucky » sab ott 18, 2008 17:21

ciao gohanz,
ti volevo chiedere,e se provassi ad installare il nuovo gnomo sulla current? secondo te è possibile e può funzionare? :-k

ciao e saluti a tutti
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda gohanz » sab ott 18, 2008 18:47

Slucky non saprei proprio. L'unica è provare.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda slucky » sab ott 18, 2008 19:00

okay, provo anche questa e ti dico ;)

ciao
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda slucky » dom ott 19, 2008 14:15

ciao Gohanz,
allora oggi ho provato e sulla current, l'ultima immagine disponibile, non ci sono problemi gslacky-2.24 gira bene :)
il problema resta anche in questa versione, almeno nel mio caso, far fungere il wpa...e ci ho provato sia utilizzando n-m che da terminale, tra l'altro ho anche provato a rimuovere i gnome-system-tools e n-m + applet, a commentare i vari files di config in /etc/rc.d o a togliere i permessi di esecuzione a /etc/rc.d/rc.networkmanager...in pratica rendendo la slack con gnome un sistema nudo, senza interferenze di applet o demoni vari....ma anche così da terminale...niente da fare.....continua a connettersi e a disconnettersi ad libitum, per il wep invece nessun problema, inoltre un'ultima cosa, sebbene abbia aggiunto il mio utente ai gruppi stb-admin e netdev quando provo ad aprire la rete dall'icona in sistema-->amministrazione-->rete mi da questo errore

La configurazione non può essere caricata
non è consentito l'accesso alla configurazione di sistema


anche se ci provo da terminale con network-admin non va....comunque continuo i test :-k e complimenti in generale, questa nuova versione mi sembra molto migliore anche stilisticamente.

ciao e saluti a tutti
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda gohanz » lun ott 20, 2008 19:06

Slucky potresti fare un test? Elimina il file fi.epitest.hostap.WPASupplicant.service da /usr/share/dbus-1/services e riprova la connessione. Controlla se hai i medesimi problemi.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda slucky » lun ott 20, 2008 21:19

no problem gohanz, sono qui per aiutarti e testare :) solo che il file che hai nominato non c'è in quella directory che hai scritto, bensì è presente nella dir /etc/dbus-1/system.d/dbus-wpa_supplicant.conf insieme ad altre voci simili :

<!DOCTYPE busconfig PUBLIC
"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
<policy user="root">
<allow own="fi.epitest.hostap.WPASupplicant"/>

<allow send_destination="fi.epitest.hostap.WPASupplicant"/>
<allow send_interface="fi.epitest.hostap.WPASupplicant"/>
</policy>
<policy context="default">
<deny own="fi.epitest.hostap.WPASupplicant"/>
<deny send_destination="fi.epitest.hostap.WPASupplicant"/>
<deny send_interface="fi.epitest.hostap.WPASupplicant"/>
</policy>
</busconfig>


le cancello tutte le voci o una in particolare? :-k

ciao
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda gohanz » gio ott 23, 2008 18:54

Slucky ho preparato i pacchetti con l'ultima svn di NetworkManager. Potresti testarli? Sul mio pc mi da problemi di connessione, cosa che non avevo con la versione presente su GSlacky-2.24.0.
Fammi sapere. Nel frattempo è uscito Gnome-2.24.1!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda slucky » gio ott 23, 2008 20:58

allora, ricapitolando... :) ho provato a cancellare il file che mi avevi indicato ma niente da fare...il wpa continua a non andare, mentre per il wep invece nessun problema di sorta....per i test nessun problema, dimmi di quali versioni di pacchetti trattasi e li testo :D

Nel frattempo è uscito Gnome-2.24.1!


:shock: azz.....lo gnomo è sempre più veloce, allora aggiorniamo alla nuova versione e vediamo come funge ;)

ciao e saluti a tutti
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda gohanz » ven ott 24, 2008 7:24

Slucky ripristina il file fi.epitest.hostap.WPASupplicant.service sempre in /usr/share/dbus-1/services.
Il file di testo deve contenere queste righe. Poi riprova la connessione tramite NetworkManager.
Poi cerco di farti avere i pacchetti aggiornati per i test.
Un'altra cosa, se usi PulseAudio come server potresti provare a lasciare in play Rhytmnbox per 40 +-minuti. Ho notato che dopo questo tempo i server si blocca.
Mi piacerebbe poi trovare una patch per rimuovere le dipendenze di gdm-2.24.0 verso le libpam.

Codice: Seleziona tutto
[D-BUS Service]
Name=fi.epitest.hostap.WPASupplicant
Exec=/usr/sbin/wpa_supplicant -u
User=root
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda slucky » ven ott 24, 2008 22:54

allora ho ripristinato quel file in /usr/share/dbus-1/services ma niente da fare, sia da terminale che utilizzando n-m prova a autenticarsi ma nulla, ho però notato che nel pannello di configurazione di n-m manca la voce "managed" mentre ci sono le altre 2 voci "ad hoc" e "infrastructure"....non vorrei fosse questo il problema, preciso che sto cercando di far funzionare la connessione con IP statici, next time riproverò abilitando il dhcp e vediamo come và :-k
per il problema pulse-audio, oggi non ho avuto tempo, domani provo e ti faccio sapere...

ciao
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda slucky » dom ott 26, 2008 18:38

solo per una precisazione, nessun problema con il server pulse-audio, ho tenuto in funzione rhythmbox per parecchio tempo ma non ho avuto blocchi di sistema o altro, come da te segnalato....

ciao e saluti a tutti :)
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda gohanz » dom ott 26, 2008 19:09

slucky ha scritto:solo per una precisazione, nessun problema con il server pulse-audio, ho tenuto in funzione rhythmbox per parecchio tempo ma non ho avuto blocchi di sistema o altro, come da te segnalato....

ciao e saluti a tutti :)


Slucky hai tenuto in funzione rhythmbox per alemno 40 minuti - 1 ora? :-k Per NetworkManager puoi ottenere maggiori info lanciando da console nm-tool e facendo partire, da un'altra console, NetworkManger in modalità nodaemon
Codice: Seleziona tutto
NetworkManager --no-daemon
. Giusto per avere un po di messaggi di debug. :-k
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda slucky » dom ott 26, 2008 19:48

sinceramente ad un'ora non sono arrivato :oops: ...okay riprovo, e più tardi riposto i risultati anche di debug, riguardo l'ormai famigerato n-m


ciao ;)
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda slucky » dom ott 26, 2008 21:57

allora caro gohanz, prima non mi ero sbagliato, ho tenuto in funzione rhythmnbox per circa un'ora e 50 minuti...poi ho dovuto stopparlo, perchè dovevo spegnere il pc...e nessun problema nè blocco, tieni conto però che io gslacky la sto usando sulla current, sicuro che nel tuo caso non si tratti di qualche problema hardware? :-k
comunque almeno con pulse-audio nessun problema, la nota dolente resta il wpa con gslacky, ho riprovato e ti posto un pò di output, ma comincio a pensare che si tratti di un problema riguardante d-bus:

root@darkstar:~# /usr/bin/nm-tool
NetworkManager Tool

State: disconnected

- Device: eth0 ----------------------------------------------------------------
Type: Wired
Driver: forcedeth
State: unavailable
HW Address: 00:xx:xx:xx:xx:xx

Capabilities:
Supported: yes
Carrier Detect: yes

Wired Settings


- Device: wlan0 ----------------------------------------------------------------
Type: 802.11 Wireless
Driver: ndiswrapper
State: disconnected
HW Address: 00:xx:xx:xx:xx:xx

Capabilities:
Supported: yes

Wireless Settings
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points
Alice-54xxxxxx: Infra, 00:xx:xx:xx:xx:xx, Freq 2437 MHz, Rate 54 Mb/s, Strength 54 WPA
Alice-96xxxxxx: Infra, 00:xx:xx:xx:xx:xx, Freq 2412 MHz, Rate 54 Mb/s, Strength 32 WPA
FASTWEB-1-xxxxxxxxxxx: Infra, 00:xx:xx:xx:xx:xx, Freq 2462 MHz, Rate 54 Mb/s, Strength 15 WPA
Alice-58xxxxxx: Infra, 00:xx:xx:xx:xx:xx, Freq 2437 MHz, Rate 54 Mb/s, Strength 17 WPA
longsh: Infra, 00:xx:xx:xx:xx:xx, Freq 2427 MHz, Rate 54 Mb/s, Strength 10 WEP
mesh1: Infra, 00:xx:xx:xx:xx:xx, Freq 2427 MHz, Rate 54 Mb/s, Strength 14 WEP



root@darkstar:~# NetworkManager --no-daemon
NetworkManager: <info> starting...
NetworkManager: <WARN> nm_dbus_manager_start_service(): Could not acquire the NetworkManager service as it is already taken.
NetworkManager: <info> disconnected by the system bus.
NetworkManager: dbus_g_connection_register_g_object: assertion `connection != NULL' failed
NetworkManager: <WARN> main(): Failed to start the dbus manager.


anche l'applet restituisce degli errori

root@darkstar:~# /usr/bin/nm-applet
Errore di GConf: Contatto col server di configurazione fallito; tra le possibili cause la necessità di abilitare il supporto a TCP/IP per ORBit o la presenza di un vecchio lock NFS a causa di un crash di sistema. Consultare http://www.gnome.org/projects/gconf/ per ulteriori informazioni (Dettagli - 1: Recupero delle connessione alla sessione fallito: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
** Message: <info> New secrets for Auto Alice-xxxxxxxx/802-11-wireless-security requested; ask the user



infine, dando un'occhiata a dbus, mi dice:

root@darkstar:/usr/bin/dbus-monitor
Failed to open connection to session message bus: Did not receive a reply.
Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.


tu che ne pensi? :-k

ciao
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Re: gslacky-2.24 sulla current, è possibile?

Messaggioda slucky » lun ott 27, 2008 22:07

allora qualche idea dagli output sul problema wpa? :-k
è l'unica nota stonata sul mio sistema, ma purtroppo molto fondamentale per me, perchè ne va la sicurezza della rete :roll:
nel frattempo sto provando la beta di Ubuntu 8.10, già attrezzata con gnome-2.24.1 e non c'è più l'icona rete da amministrazione ----> sistema ma il wpa funziona senza problemi da terminale.....proprio non riesco a capire perchè con gslacky non funzioni in alcun modo #-o
anche oggi ho tenuto in funzione rhythmnbox per quasi 2 ore.....nessun blocco e nessun problema, se non lo stoppavo continuava tranquillamente a funzionare :)


saluti
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

Prossimo

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Bing [Bot] e 2 ospiti