Repository 32bit  Forum
Repository 64bit  Wiki

Impostazioni rete eth0 si perdono al riavvio

Forum dedicato ai Porting ufficiali e non di Slackware, vedi Slack/390, ARMedslack, Slamd64, Slackintosh, Ocsid, Sloox, Zenwalk, How-Tux, Slax etc etc

Moderatore: Staff

Regole del forum
1) Specificare nome e versione del porting.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Impostazioni rete eth0 si perdono al riavvio

Messaggioda Sub_mariner » gio ott 30, 2008 8:59

salve gente.
ho installato la distro nimblex, che è la versione piu' completa della slax su un vecchio pc al lavoro.
Va alla grande QUASI in tutto, quel quasi è dovuto ad alcune cosucce da sistemare ancora, ma confido di riuscirci, anche grazie al vostro aiuto \:D/
Il pc è connesso ad un router il quale è a sua volta connesso ad una rete cui fa capo un server privato.
La connessione ad internet avviene tramite proxy e password utente.
In mancanza di queste ultime l'unica pagina disponibile è quella dell'azienda.
Ho impostato i vari parametri: IP,gateway,dns,netmask e va tutto bene.
Il client si connette alla rete a va tutto benissimo, internet compresa.
C'è però un problema, non da poco; al riavvio si perdono le impostazioni e bisogna reinserirle daccapo.
Ovviamente è di fatto inutilizzabile dai più, perchè dato che mi sono preso l'incarico di gestire questo pc, se io manco internet nisba.
Ho usato sia l'utility grafica network-conf per inserire i parametri,sia da console net-config, ho cercato di modificare il file inet1.conf rimuovendo il cancelletto e inserendo i valori, ma niente da fare.
Al riavvio si perde tutto.
Potete aiutarmi?
Ultima modifica di Loris il gio ott 30, 2008 10:06, modificato 1 volta in totale.
Motivazione: Scrivere il titolo in minuscolo !!
Sub_mariner
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mer ott 01, 2008 16:07
Nome Cognome: Vincenzo Antonucci
Kernel: 2.6
Desktop: kde
Distribuzione: slax 6

Re: IMPOSTAZIONI RETE ETH0 SI PERDONO AL RIAVVIO

Messaggioda Paoletta » gio ott 30, 2008 9:29

Ho usato sia l'utility grafica network-conf per inserire i parametri,sia da console net-config, ho cercato di modificare il file inet1.conf rimuovendo il cancelletto e inserendo i valori, ma niente da fare.
Al riavvio si perde tutto.


molto strano...se il fatto di scriverli in inet1.conf non funziona puoi sempre inserire le istruzioni necessarie in rc.local...ma cosa hai messo in inet1.conf?
Avatar utente
Paoletta
Staff
Staff
 
Messaggi: 3893
Iscritto il: dom apr 24, 2005 23:00
Località: Varese
Slackware: 13.1
Desktop: fluxbox

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda Sub_mariner » gio ott 30, 2008 10:46

Ciao, quella che vedi qui sotto è la parte del file che ho modificato.
Dici che ci sono degli errori?


# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]="indirizzo ip statico"
NETMASK[0]="netmask"
#USE_DHCP[0]=""
#DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY="ip gateway"
Ultima modifica di Sub_mariner il gio ott 30, 2008 10:50, modificato 1 volta in totale.
Sub_mariner
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mer ott 01, 2008 16:07
Nome Cognome: Vincenzo Antonucci
Kernel: 2.6
Desktop: kde
Distribuzione: slax 6

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda Sub_mariner » gio ott 30, 2008 10:47

rc local dove lo trovo?
Sub_mariner
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mer ott 01, 2008 16:07
Nome Cognome: Vincenzo Antonucci
Kernel: 2.6
Desktop: kde
Distribuzione: slax 6

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda sardylan » gio ott 30, 2008 10:59

Non so come funzioni... Ma il problema di Internet penso che sia dovuto al proxy che richiede l'autenticazione...
Il fatto del proxy è un qualcosa che dovrebbe essere relativo solo al browser... Qualsiasi altro programma va configurato manualmente...
E non penso che ci sia un sistema che possa memorizzare le password del proxy e re-inserirle ogni volta che accendi il PC... Anche perché tutta la procedura di autenticazione viene fatta tramite paginetta web... giusto??

Edit:: Ma per impostazioni ti riferisci alle configurazioni IP oppure solo all'accesso internet??
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: San Vito (Cagliari)
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.1.2
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda Sub_mariner » gio ott 30, 2008 11:46

Ciao.
il proxy in questo caso serve solo per avere l'accesso a internet "completo"
Se ne può fare a meno e in questo caso va solo alla pagina principale impostata di default e ai relativi link interni.
Il problema è che perde i settaggi della rete.
intendo dire:
IP 192.168. ecc
NETMASK 255.255 ecc
GATEWAY 192.168.1.1
DNS 10.217 ECC
DNS 10.232 ECC
Di regola questi dovrebbero restare, invece non succede.
Sub_mariner
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mer ott 01, 2008 16:07
Nome Cognome: Vincenzo Antonucci
Kernel: 2.6
Desktop: kde
Distribuzione: slax 6

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda conraid » gio ott 30, 2008 12:13

Sub_mariner ha scritto:Ciao.
il proxy in questo caso serve solo per avere l'accesso a internet "completo"
Se ne può fare a meno e in questo caso va solo alla pagina principale impostata di default e ai relativi link interni.
Il problema è che perde i settaggi della rete.
intendo dire:
IP 192.168. ecc
NETMASK 255.255 ecc
GATEWAY 192.168.1.1
DNS 10.217 ECC
DNS 10.232 ECC
Di regola questi dovrebbero restare, invece non succede.


Tu stai usando nimblex, sarà anche una derivata della slackware, ma vai a sapere che script di avvio ha. Magari ha qualche script che abilita il dhcp e così via. Insomma, o ti studi bene quella distribuzione, che noi non usiamo, o installi Slackware e così possiamo aiutarti meglio.
Altrimenti cerca in rete persone che la usano e conoscono gli script di avvio di tale distribuzione.
C'è qualcosa che modifica le impostazioni, tutto qui
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda sardylan » gio ott 30, 2008 12:41

Infatti!! Concordo con conraid...
Se non sai che strada fare controllati /etc/inittab ed /etc/rc.d/rc.M o rc.S... Insomma, gli equivalenti in quella distro...
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: San Vito (Cagliari)
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.1.2
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda Sub_mariner » gio ott 30, 2008 14:08

ok, proverò :-k
Sub_mariner
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mer ott 01, 2008 16:07
Nome Cognome: Vincenzo Antonucci
Kernel: 2.6
Desktop: kde
Distribuzione: slax 6

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda zoros » sab nov 01, 2008 23:17

ciao ... solo un'idea:
se il PC in questione ha 2 schede di rete è probabile che il persistent-net.rules di udev commetta un errore scambiando eth0 con eth1 ... tenere una sola scheda eth attiva risolve nel modo più semplice
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda Luci0 » dom nov 02, 2008 10:52

Anch'io come Conraid penso che all' avvio ci sia uno script "non Slackware"che riconfigura automaticamente le schede di rete e non trovando un server dhcp fallisce ... credo che studiando il boot della distribuzione si possa riuscire a sganciarlo, oppure si può risolvere il problema a monte mettendo un server dhcp.
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda tigerwalk » mar nov 04, 2008 8:38

Sub_mariner ha scritto:rc local dove lo trovo?

lo trovi in /etc/rc.d/rc.local
Io ho una installazione di NimbleX su pennetta, gli script di avvio sono quelli che usa slackware.
Le altre impostazioni (personalizzazioni desktop e quant'altro) le mantiene?
Ho installato slackyd e tramite esso, installo i pacchetti che mi servono e le relative dipendenze, tanto che praticamente, posso dire di avere una slackware 12.1 su pennetta.
Ho installato wicd e lo uso per la connessione e le impostazioni rimangono memorizzate (quelle che ho configurato in wicd).
Avatar utente
tigerwalk
Linux 2.6
Linux 2.6
 
Messaggi: 870
Iscritto il: lun feb 25, 2008 22:08
Località: Napoli
Nome Cognome: Giuliano della Vecchia
Slackware: 13.1
Kernel: 2.6.33.4-tiger
Desktop: kde4/fluxbox

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda Sub_mariner » mar nov 04, 2008 11:18

tigerwalk ha scritto:
Sub_mariner ha scritto:rc local dove lo trovo?

lo trovi in /etc/rc.d/rc.local
Io ho una installazione di NimbleX su pennetta, gli script di avvio sono quelli che usa slackware.
Le altre impostazioni (personalizzazioni desktop e quant'altro) le mantiene?
Ho installato slackyd e tramite esso, installo i pacchetti che mi servono e le relative dipendenze, tanto che praticamente, posso dire di avere una slackware 12.1 su pennetta.
Ho installato wicd e lo uso per la connessione e le impostazioni rimangono memorizzate (quelle che ho configurato in wicd).


Questa mi piace proprio...come hai fatto?
A me nimblex piace molto e se potessi metterla su pennetta con le configurazioni sarei a posto per i prossimi anni :D
Per rispondere anche a tutti gli altri amici che lo hanno chiesto riguardo se tiene tutte le configurazioni la risposta è sì, le mantiene tutte, anche i DNS, tranne le altre cioè gateway ip ecc.
Le difficoltà enormi che ho incontrato con la nimblex?
Intanto l'installazione su HD, è un vero e proprio disatro, se poi c'è già XP e si vuol fare il dual boot è da impazzire.
Una domanda, tu ci hai provato ad installare su HD?
Sub_mariner
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mer ott 01, 2008 16:07
Nome Cognome: Vincenzo Antonucci
Kernel: 2.6
Desktop: kde
Distribuzione: slax 6

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda tigerwalk » mar nov 04, 2008 16:34

Ho usato una penna da 8 giga, ho scaricato e masterizzato l'iso di NimbleX ed ho avviato da CD. Ho scelto l'icona sul desktop "Install Nimblex", ho scelto di installare su usb, lasciata partizionare la pennetta automaticamente dall'installer, confermato di voler utilizzare la partizione dati per memorizzare i changes e fine!
Dopo il riavvio da usb, ho installato slackyd e con quello ho scaricato ogni altro pacchetto con relative dipendenze.
Ma Stiamo andando O.T.
Avatar utente
tigerwalk
Linux 2.6
Linux 2.6
 
Messaggi: 870
Iscritto il: lun feb 25, 2008 22:08
Località: Napoli
Nome Cognome: Giuliano della Vecchia
Slackware: 13.1
Kernel: 2.6.33.4-tiger
Desktop: kde4/fluxbox

Re: Impostazioni rete eth0 si perdono al riavvio

Messaggioda Sub_mariner » mer nov 05, 2008 21:52

sembrerà strano, ma ancora non son riuscito a risolvere.
ci sto provando ma al riavvio restano solo i dns nel tool network-conf.
Sub_mariner
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mer ott 01, 2008 16:07
Nome Cognome: Vincenzo Antonucci
Kernel: 2.6
Desktop: kde
Distribuzione: slax 6

Prossimo

Torna a Porting Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti