Repository 32bit  Forum
Repository 64bit  Wiki

richiesta di supporto per impostazioni rete eth0 su Nimblex

Forum dedicato ai Porting ufficiali e non di Slackware, vedi Slack/390, ARMedslack, Slamd64, Slackintosh, Ocsid, Sloox, Zenwalk, How-Tux, Slax etc etc

Moderatore: Staff

Regole del forum
1) Specificare nome e versione del porting.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

richiesta di supporto per impostazioni rete eth0 su Nimblex

Messaggioda Sub_mariner » ven nov 07, 2008 16:17

Salve !
Da circa un mese a questa parte sto incontrando delle difficoltà che non riesco a risolvere.
Ho installato su un vecchio computer pentium 3 una distro derivata slackware, la nimblex 2008, questa http://nimblex.net/ .
La distro è bella, leggera, ricca di programmi e viaggia una meraviglia in quanto a velocità e leggerezza.
Ma c'è un problema, anzi due, ma per il secondo aprirò thread apposito.
La configurazione della rete per la connessione internet.
Ho usato il tool netconfig, il tool ifconfig, la configurazione manuale di rc.inet1.conf, ma succede che ad ogni riavvio perdo le impostazioni e mi tocca reinserirle a mano.
Ovviamente non va bene.
Leggendo in vari wiki,thread,discussioni,guide ho visto che i file rc.inet1 sono da modificare anch'essi.
Io ho aperto il file in questione e tolto il segno del cancelletto che c'è su, il quale , se non ho capito male, rende il file eseguibile.
Ma qualcosa devo aver sbagliato, perchè il problema persiste.
Mi sono arenato .
Chi se la sente di darmi una mano a ricominciare tutto d'accapo partendo da zero?.
Grazie anticipate.
Ultima modifica di Sub_mariner il ven nov 07, 2008 17:10, modificato 1 volta in totale.
Sub_mariner
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mer ott 01, 2008 16:07
Nome Cognome: Vincenzo Antonucci
Kernel: 2.6
Desktop: kde
Distribuzione: slax 6

Re: RICHIESTA DI SUPPORTO PER IMPOSTAZIONI RETE ETH0 SU NIMBLEX

Messaggioda JohnnyMnemonic » ven nov 07, 2008 16:27

Il carattere # serve in tutto il file per i commenti, tranne che per la prima riga, dove si specifica l'interprete, quindi file come rc.inet1 DEVONO iniziare con

Codice: Seleziona tutto
#!/bin/sh


per renderli eseguibili il comando da dare è

Codice: Seleziona tutto
chmod +x nomefile


Magari posta i file che hai modificato, così ci diamo un'occhiata
Avatar utente
JohnnyMnemonic
Staff
Staff
 
Messaggi: 2733
Iscritto il: sab set 04, 2004 23:00
Località: Bologna
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos

Re: RICHIESTA DI SUPPORTO PER IMPOSTAZIONI RETE ETH0 SU NIMBLEX

Messaggioda Sub_mariner » ven nov 07, 2008 16:33

Ok, grazie, potrò farlo dopodomani, perchè il pc in questione non c'è l'ho con me.
Sub_mariner
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mer ott 01, 2008 16:07
Nome Cognome: Vincenzo Antonucci
Kernel: 2.6
Desktop: kde
Distribuzione: slax 6

Re: RICHIESTA DI SUPPORTO PER IMPOSTAZIONI RETE ETH0 SU NIMBLEX

Messaggioda zoros » ven nov 07, 2008 19:05

Sub_mariner ha scritto:Ok, grazie, potrò farlo dopodomani, perchè il pc in questione non c'è l'ho con me.

Avevo già ipotizzato qualcosa in un precedente topic ... ripensandoci:
ci sono buone probabilità che il sistema software sia tutto giusto ... ma le variabili nel mondo dei PC sono tantissime
e ogni tanto capitano delle cose misteriose ...
nuova ipotesi:
penso che la configurazione di rete venga applicata correttamente, ma quando il driver della scheda di rete non ha ancora completato il suo ciclo, quindi l'interfaccia eth0 non esiste ancora (un'ipotesi di hardware "strano" ... succede) ...
ti invito a copiare le istruzioni che ti avevo dato in precedenza ma nel file /etc/rc.d/rc.local che dovrebbe essere uno degli ultimi in ordine di esecuzione (un utile test) ...
sapere marca e modello della tua scheda di rete potrebbe anche essere utile ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1307
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)

Re: richiesta di supporto per impostazioni rete eth0 su Nimblex

Messaggioda Sub_mariner » ven nov 07, 2008 23:23

ok, grazie, lo farò senz'altro.
Tengo il post in aggiornamento.
Sub_mariner
Linux 1.0
Linux 1.0
 
Messaggi: 71
Iscritto il: mer ott 01, 2008 16:07
Nome Cognome: Vincenzo Antonucci
Kernel: 2.6
Desktop: kde
Distribuzione: slax 6


Torna a Porting Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite